Condition

Fonction SOMME.SI

Temps de lecture 2 minutes

La fonction SOMME.SI est basée sur le même principe que la fonction NB.SI.

Mais au lieu de compter le nombre de fois qu'un élément est présent dans une liste, vous pouvez ici calculer une somme correspondant à votre critère.

Construction de la fonction SOMME.SI

La fonction SOMME.SI a besoin de 3 paramètres pour fonctionner

  • La plage de sélection
  • Le critère de sélection
  • La plage à additionner

Comptabiliser un seul article

Par exemple, vous désirez connaitre la quantité de crayons vendus dans le mois. Dans cet exemple, nous avons 4 lignes à additionner.

Additionner une seule donnée dans une liste
  1. Commencez par écrire la formule
  2. Sélectionnez la plage de cellules qui contient vos produits (le critère)
SOMME SI sélection de la plage de critères

=SOMME.SI(B3:B12;

SOMME.SI Sélection du critère à rechercher
  1. Ensuite, inscrivez le mot "Crayon" comme critère de sélection

=SOMME.SI(B3:B12;"Crayon";

ou encore la référence de la cellule qui contient le mot Crayon

=SOMME.SI(B3:B12;G4;

Jusqu'ici, il n'y a pas de différence avec la fonction NB.SI

  1. Pour terminer, vous allez sélectionner la plage de cellules où sont les données à additionner.

=SOMME.SI(B3:B12;G4;C3:C12)    => 245

SOMME.SI Sélection de la plage à additionner

Vérification

Pour vérifier que la fonction retourne le bon résultat, il vous suffit de faire un filtre sur le critère est de compter les valeurs.

Ici, c'est facile, ça peut se faire à la main vu le peu de valeur dans notre exemple

Depuis la colonne C, nous allons additionner toutes les cellules qui correspondent à la vente de Crayon

  • 75 (cellule C3)
  • 50 (cellule C6)
  • 100 (cellule C8 )
  • 20 (cellule C12)

Ce qui fait bien 245 😃👍

Fonction SOMME.SI qui retourne la quantité vendu pour l'objet analysé

Additionner le chiffre d'affaire

Maintenant, si on cherche le montant des commandes des crayons, on va simplement changer le 3ème paramètre de la formule. Ici, on va remplacer la colonne C par la colonne E.

=SOMME.SI(B3:B12;G4;E3:E12)    =>357,5

Calculer le chiffre d'affaires avec la fonction SOMME.SI

Faire la somme sur plusieurs critères

Maintenant, si vous devez effectuer une somme sur plusieurs critère (nom du produit et couleur du produit), la fonction SOMME.SI ne pourra pas être utilisée⛔⛔⛔

Dans ce cas de figure, il faut utiliser la fonction SOMME.SI.ENS qui a été conçue pour effectuer un calcul sur 255 critères 😮😃😍

Related posts

Extraire les éléments présents qu’une seule fois

Frédéric LE GUEN

NB.SI.ENS plus grand – plus petit

Frédéric LE GUEN

Rechercher les doublons par formule

Frédéric LE GUEN

16 commentaires

Michel 30/10/2020 at 16:59

Bonjour,
Je suis en école d'ingé et j'ai un EPI sur excel de 15min,
serait-il possible d'avoir un exemple de sujet??

Répondre
Souleymane kébé 02/10/2020 at 17:08

je veux trouver la formule qui donne le résultat des nombres de valeurs additionnées. Par exemple si j'additionne 4 + 5+1+5 qui donne 15 quelle est la formule qui donne 4 le nombre total des valeurs que sont 4,5,1,5

Répondre
Harounian Herve 19/06/2019 at 06:53

bonjour j'ai une somme de temps heure:min que je dois additionner
je dois revenir à 0 toutes les 4 heures cumulée dans cette colonne d'addition
comment puis je faire
merci urgent

Répondre
Frédéric LE GUEN 19/06/2019 at 09:11

Bonjour, très difficile de vous répondre et je ne pense pas que la fonction SOMME.SI soit à utiliser dans votre situation. Un SI avec un test si le temps cumulé est supérieur ou égale à 4 serait plus approprié.

Répondre
Harounian Herve 19/06/2019 at 06:52

bonjour j'ai une somme de temps heure:min que je dois additionner
je dois revenir à 0 toutes les 4 heures cumulée
comment puis je faire
merci urgent

Répondre
Lélé 20/09/2018 at 10:57

Bonjour,
Peut-on mettre dans une cellule produit =Crayon+Gomme, et retrouver dans le tableau des totaux : 50% du montant affecté au Crayon et 50% du montant affecté au total gomme ?
Merci par avance pour votre retour,
Cordialement,

Répondre
Rovel 16/04/2018 at 22:35

Bonjour,

La formule suivante fonctionne dans mon tableau : =SOMME.SI('gd livre dépenses'!B$2:B$76;"=Publicité";'gd livre dépenses'!F$2:F$76)
Mais j'aimerais remplacer le critère par la cellule B3 contenant ce même texte.
J'ai tenté ceci : =SOMME.SI('gd livre dépenses'!B$2:B$76;"=B3";'gd livre dépenses'!F$2:F$76), mais le résultat est toujours de 0 dans ce cas.
Qu'est ce qui m'échappe?
En espérant être clair.

Répondre
Frédéric LE GUEN 17/04/2018 at 05:05

Pas de guillemets. Juste ;B3;

Répondre
MAZ 20/11/2017 at 16:21

BONJOUR
JE VOUDRAIS ADDITIONNER QUE LE NBRES >0 COMMENT UTILISER LA FORMULE?

MERCI

Répondre
Saratatat 19/02/2016 at 14:12

Comment mettre la condition d'une couleur?
Ex: Quand j'emmets une facture, j'entre le montant et j'ai une case "statut" qui est rouge tant que la facture n'est pas payée et verte quand elle l'est. Je voudrais calculer le total qui reste à me faire payer.

Donc ce que je cherche c'est une formule qui ressemble à =SOMME.SI(B3:B12;"COULEUR ROUGE";C3:C12)
Je fonctionne avec la version anglophone d'Excel, si possible fournir la formule en anglais.

* J'ai tenté : =SUMIF(A2:A29,"REDCOLOR",D2:D29) mais ça ne fonctionne pas, il cherche les mots, pas la couleur en tant que telle.

Répondre
Julien 16/02/2016 at 11:57

Il y'a une erreur non? "Si vous voulez connaître la quantité de gommes vendues" alors que l'on parlait de crayons. Et que l'on additionne les crayons :)

Merci pour l'explication sinon

Répondre
DUPIN 12/02/2016 at 14:21

Bonjour,

Si je veux calculer un bénéfice ou une perte, je veux mettre dans la case : si "charges" > "produit" alors Charge-produit --> pour les pertes.
Et pour les bénéfices : si "bénéfices" > "charges" alors bénéfices-charges

Comment l'écrire dans excel ?

Je vous remercie

Fiona

Répondre
Frédéric LE GUEN 12/02/2016 at 15:17

Ce n'est pas la fonction SOMME.SI qu'il faut utiliser mais la fonction SI. =SI(cellule contenant les charges>cellule contenant les produits;Charges-produites;Benefice-Charge)

Répondre
Yannick 03/09/2015 at 15:25

Bonjour,
J'ai un soucis véritable lorsque plusieurs dates se répètent dans le tableau:
01/08/2015 02
01/08/2015 12
02/08/2015 14
...

Faire la somme exclusivement du 01/08/2015, j'ai tout essayé sur les forum et tout en vain
Pourriez vous m'aider svp

Merci
Cordialement

Répondre
marj 04/05/2015 at 12:53

Exercice parfait pour comprendre la fonction Somme.si
Merci!

Répondre
Nico 04/01/2015 at 13:20

Parfait, merci !!

Répondre

Laissez un commentaire

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.