«

»

Fonction SOMME.SI

La fonction SOMME.SI est basée sur le même principe que la fonction NB.SI. Mais au lieu de compter le nombre de fois qu’un élément est présent dans une liste, vous pouvez ici calculer une somme correspondant à votre critère.

Construction de la fonction SOMME.SI

La fonction SOMME.SI a besoin de 3 paramètres pour fonctionner

  • La plage de sélection
  • Le critère de sélection
  • La plage à additionner

Comptabiliser un seul article

Par exemple, vous désirez connaitre la quantité de crayons vendus dans le mois.

  • Commencez par écrire la formule
  • Sélectionnez la plage de cellules qui contient vos produits (le critère)

=SOMME.SI(B3:B12;

 

  • Ensuite, inscrivez le mot “Crayon” comme critère de sélection

=SOMME.SI(B3:B12;“Crayon”;

ou encore la référence de la cellule qui contient le mot Crayon
=SOMME.SI(B3:B12;G4;

 

Jusqu’ici, il n’y a pas de différence avec la fonction NB.SI

  • Pour terminer, vous allez sélectionner la plage de cellules où sont les données à additionner.

=SOMME.SI(B3:B12;G4;C3:C12) => 245

Vérification


Pour vérifier que la fonction retourne le bon résultat, il vous suffit de faire un filtre sur le critère est de compter les valeurs.

Ici, c’est facile, ça peut se faire à la main vu le peu de valeur dans notre exemple

Depuis la colonne C, nous allons additionner toutes les cellules qui correspondent à la vente de Crayon

  • 75 (cellule C3)
  • 50 (cellule C6)
  • 100 (cellule C8 )
  • 20 (cellule C12)

Ce qui fait bien 245 😃👍

Additionner le chiffre d’affaire

Maintenant, si on cherche le montant des commandes des crayons, on va simplement changer le 3ème paramètre de la formule. Ici, on va remplacer la colonne C par la colonne E.
=SOMME.SI(B3:B12;G4;E3:E12) =>357,5

Remplissez vous-même le document suivant pour vous exercer à utiliser la fonction SOMME.SI

Fonction SOMME.SI.ENS

Maintenant, si vous devez effectuer une somme sur plusieurs critère (nom du produit et couleur du produit), la fonction SOMME.SI ne pourra pas être utilisée.⛔⛔⛔

Dans ce cas de figure, il est obligatoire d’utiliser la fonction SOMME.SI.ENS qui a été conçue pour effectuer une sélection sur 255 colonnes 😮😃😍

Articles complémentaires


Voici une liste d'articles qui pourrait également vous intéresser sur le même thème.

Lien Permanent pour cet article : https://www.excel-exercice.com/somme-si/


(9 commentaires)

Passer au formulaire de commentaire

  1. MAZ

    BONJOUR
    JE VOUDRAIS ADDITIONNER QUE LE NBRES >0 COMMENT UTILISER LA FORMULE?

    MERCI

  2. Saratatat

    Comment mettre la condition d’une couleur?
    Ex: Quand j’emmets une facture, j’entre le montant et j’ai une case “statut” qui est rouge tant que la facture n’est pas payée et verte quand elle l’est. Je voudrais calculer le total qui reste à me faire payer.

    Donc ce que je cherche c’est une formule qui ressemble à =SOMME.SI(B3:B12;”COULEUR ROUGE”;C3:C12)
    Je fonctionne avec la version anglophone d’Excel, si possible fournir la formule en anglais.

    * J’ai tenté : =SUMIF(A2:A29,”REDCOLOR”,D2:D29) mais ça ne fonctionne pas, il cherche les mots, pas la couleur en tant que telle.

  3. Julien

    Il y’a une erreur non? “Si vous voulez connaître la quantité de gommes vendues” alors que l’on parlait de crayons. Et que l’on additionne les crayons 🙂

    Merci pour l’explication sinon

  4. DUPIN

    Bonjour,

    Si je veux calculer un bénéfice ou une perte, je veux mettre dans la case : si “charges” > “produit” alors Charge-produit –> pour les pertes.
    Et pour les bénéfices : si “bénéfices” > “charges” alors bénéfices-charges

    Comment l’écrire dans excel ?

    Je vous remercie

    Fiona

    1. Frédéric LE GUEN

      Ce n’est pas la fonction SOMME.SI qu’il faut utiliser mais la fonction SI. =SI(cellule contenant les charges>cellule contenant les produits;Charges-produites;Benefice-Charge)

  5. Yannick

    Bonjour,
    J’ai un soucis véritable lorsque plusieurs dates se répètent dans le tableau:
    01/08/2015 02
    01/08/2015 12
    02/08/2015 14

    Faire la somme exclusivement du 01/08/2015, j’ai tout essayé sur les forum et tout en vain
    Pourriez vous m’aider svp

    Merci
    Cordialement

    1. Frédéric LE GUEN

      Poser votre question dans le nouveau forum prévu à cet effet et j’y répondrai
      Merci
      http://www.excel-exercice.com/forums/

  6. marj

    Exercice parfait pour comprendre la fonction Somme.si
    Merci!

  7. Nico

    Parfait, merci !!

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *