Fonction SOMME.SI

Temps de lecture : 3 minutes

La fonction SOMME.SI est basée sur le même principe que la fonction NB.SI.

Mais au lieu de compter le nombre de fois où un élément est présent dans une liste, vous pouvez ici calculer une somme correspondant à votre critère.

Construction de la fonction SOMME.SI

La fonction SOMME.SI a besoin de 3 paramètres pour fonctionner :

  • La plage de sélection.
  • Le critère de sélection.
  • La plage à additionner.

Comptabiliser un seul article

Par exemple, vous désirez connaître la quantité de crayons vendus dans le mois. Dans cet exemple, nous avons 4 lignes à additionner.

Additionner une seule donnée dans une liste
  1. Commencez par écrire la formule.
  2. Sélectionnez la plage de cellules qui contient vos produits (le critère).
SOMME SI sélection de la plage de critères

=SOMME.SI(B3:B12;

SOMME.SI Sélection du critère à rechercher
  1. Ensuite, inscrivez le mot "Crayon" comme critère de sélection.

=SOMME.SI(B3:B12;"Crayon";

ou encore la référence de la cellule qui contient le mot Crayon.

=SOMME.SI(B3:B12;G4;

Jusqu'ici, il n'y a pas de différence avec la fonction NB.SI.

  1. Pour terminer, vous allez sélectionner la plage de cellules où sont les données à additionner.

=SOMME.SI(B3:B12;G4;C3:C12)    => 245

SOMME.SI Sélection de la plage à additionner

Vérification

Pour vérifier que la fonction retourne le bon résultat, il vous suffit de faire un filtre sur le critère et de compter les valeurs.

Ici, c'est facile, ça peut se faire à la main vu le peu de valeurs dans notre exemple.

Depuis la colonne C, nous allons additionner toutes les cellules qui correspondent à la vente de Crayon.

  • 75 (cellule C3)
  • 50 (cellule C6)
  • 100 (cellule C8 )
  • 20 (cellule C12)

Ce qui fait bien 245 😃👍

Fonction SOMME.SI qui retourne la quantité vendu pour l'objet analysé

Additionner le chiffre d'affaire

Maintenant, si on cherche le montant des commandes de crayons, on va simplement changer le 3ème paramètre de la formule. Ici, on va remplacer la colonne C par la colonne E.

=SOMME.SI(B3:B12;G4;E3:E12)    =>357,5

Calculer le chiffre d'affaires avec la fonction SOMME.SI

Faire la somme sur plusieurs critères

Maintenant, si vous devez effectuer une somme sur plusieurs critères (nom du produit et couleur du produit), la fonction SOMME.SI ne pourra pas être utilisée⛔⛔⛔

Dans ce cas de figure, il faut utiliser la fonction SOMME.SI.ENS qui a été conçue pour effectuer un calcul sur 255 critères 😮😃😍

Vous trouverez des informations complémentaires sur la fonction SOMME.SI sur le site de Microsoft.

21 Comments

  1. Albane
    09/12/2021 @ 22:31

    Bonjour,

    Grâce à votre site j'ai pas mal avancé dans mon fichier mais je bloque un peu pour la suite. Je suis sur un tableau Excel contenant des chiffres, des noms et des mois :

    - J'aimerais créer en C2 un onglet ( ? ) déroulant dans une cellule pour choisir le mois de l'année souhaité. Lorsque je vais dans 3 Formules " " DateHeure " " MOIS " je rentre le chiffre 1 pour le mois de janvier mais celui ci ne s'affiche pas et reste " 1 "

    - J'ai une liste de 25 emplacements de B5:B29 avec seulement 23 noms donc un nombre de parts individuelles, auxquels on peut rajouter ou en enlever des noms dans le futur. Mais dans ma formule, j'ai besoin de prendre en compte ses 25 cellules en excluant celles qui sont/seront vides sur l'instant. Ce résultat doit apparaître dans ma cellule i10

    - Après cela, j'aurais besoin de calculer le nombre de parts précédemment calculées, en fonction du nombre de jours dans le mois, et ce, directement relié à ma cellule C2 ( que la mise à jour du nombre de jours se fasse automatiquement dans mes formules )

    J'espère que je me suis clairement exprimée.

    Je vous remercie par avance pour votre réponse

    Reply

    • Frédéric LE GUEN
      10/12/2021 @ 11:29

      C'est pas une question mais un projet complet que vous me demandez de développer. Si tel est le cas, il faut contacter ma société pour évaluer le temps à passer et le chiffrage associé.

      Reply

      • Albane
        16/12/2021 @ 08:18

        Bonjour, merci pour votre réponse. A tête reposée j'ai pu finaliser mon tableur, pas besoin de la formule DATE, seulement d'un petit tableau avec le nom du mois et son numéro ( Janvier 1, Février 2, ... ) et de la fonction RECHERCHEV pour mon 3eme point.

        Merci encore pour votre site !

        Belle journée

  2. LAURENT
    24/11/2021 @ 22:04

    Bonjour,
    Je sèche depuis 2 heures pour:
    Faire la somme des valeurs d'une colonne situé sur une FEUIL3 (tableau1), colonne "MC-TOT-o
    avec un critère se travant dans le tableau1, en colonne "sem-cde" qui est un nombre
    pour ùettre le résultat dans la feuil3
    qui va prendre le numero de la semaine et mettre en dessous la somme des MC-TOT-0
    J'uilise somme.si qui me donne 0 en permanence.
    =SOMME.SI(Tableau1[[#En-têtes];[NumSem-Cde]];D6;Tableau1[[#En-têtes];[MC-TotO]])

    J'ai essaiez avec BDSomme, et là c'était #valeur, coinçant au niveau des critères.

    HELP !
    Merci

    Reply

    • Frédéric LE GUEN
      25/11/2021 @ 16:01

      Bonjour,
      Alors déjà vous utilisez un tableau (et c'est très bien). La fonction SOMME.SI semble correct mais c'est mieux d'utiliser SOMME.SI.ENS (attention, elles ne se paramètrent pas de la même façon)
      Après, il faut s'assurer qu'il n'y a pas d'erreur dans vos données (genre des espaces en trop)

      Reply

  3. Michel
    30/10/2020 @ 16:59

    Bonjour,
    Je suis en école d'ingé et j'ai un EPI sur excel de 15min,
    serait-il possible d'avoir un exemple de sujet??

    Reply

  4. Souleymane kébé
    02/10/2020 @ 17:08

    je veux trouver la formule qui donne le résultat des nombres de valeurs additionnées. Par exemple si j'additionne 4 + 5+1+5 qui donne 15 quelle est la formule qui donne 4 le nombre total des valeurs que sont 4,5,1,5

    Reply

  5. Harounian Herve
    19/06/2019 @ 06:53

    bonjour j'ai une somme de temps heure:min que je dois additionner
    je dois revenir à 0 toutes les 4 heures cumulée dans cette colonne d'addition
    comment puis je faire
    merci urgent

    Reply

    • Frédéric LE GUEN
      19/06/2019 @ 09:11

      Bonjour, très difficile de vous répondre et je ne pense pas que la fonction SOMME.SI soit à utiliser dans votre situation. Un SI avec un test si le temps cumulé est supérieur ou égale à 4 serait plus approprié.

      Reply

  6. Harounian Herve
    19/06/2019 @ 06:52

    bonjour j'ai une somme de temps heure:min que je dois additionner
    je dois revenir à 0 toutes les 4 heures cumulée
    comment puis je faire
    merci urgent

    Reply

  7. Lélé
    20/09/2018 @ 10:57

    Bonjour,
    Peut-on mettre dans une cellule produit =Crayon+Gomme, et retrouver dans le tableau des totaux : 50% du montant affecté au Crayon et 50% du montant affecté au total gomme ?
    Merci par avance pour votre retour,
    Cordialement,

    Reply

  8. Rovel
    16/04/2018 @ 22:35

    Bonjour,

    La formule suivante fonctionne dans mon tableau : =SOMME.SI('gd livre dépenses'!B$2:B$76;"=Publicité";'gd livre dépenses'!F$2:F$76)
    Mais j'aimerais remplacer le critère par la cellule B3 contenant ce même texte.
    J'ai tenté ceci : =SOMME.SI('gd livre dépenses'!B$2:B$76;"=B3";'gd livre dépenses'!F$2:F$76), mais le résultat est toujours de 0 dans ce cas.
    Qu'est ce qui m'échappe?
    En espérant être clair.

    Reply

    • Frédéric LE GUEN
      17/04/2018 @ 05:05

      Pas de guillemets. Juste ;B3;

      Reply

  9. MAZ
    20/11/2017 @ 16:21

    BONJOUR
    JE VOUDRAIS ADDITIONNER QUE LE NBRES >0 COMMENT UTILISER LA FORMULE?

    MERCI

    Reply

  10. Saratatat
    19/02/2016 @ 14:12

    Comment mettre la condition d'une couleur?
    Ex: Quand j'emmets une facture, j'entre le montant et j'ai une case "statut" qui est rouge tant que la facture n'est pas payée et verte quand elle l'est. Je voudrais calculer le total qui reste à me faire payer.

    Donc ce que je cherche c'est une formule qui ressemble à =SOMME.SI(B3:B12;"COULEUR ROUGE";C3:C12)
    Je fonctionne avec la version anglophone d'Excel, si possible fournir la formule en anglais.

    * J'ai tenté : =SUMIF(A2:A29,"REDCOLOR",D2:D29) mais ça ne fonctionne pas, il cherche les mots, pas la couleur en tant que telle.

    Reply

  11. Julien
    16/02/2016 @ 11:57

    Il y'a une erreur non? "Si vous voulez connaître la quantité de gommes vendues" alors que l'on parlait de crayons. Et que l'on additionne les crayons :)

    Merci pour l'explication sinon

    Reply

  12. DUPIN
    12/02/2016 @ 14:21

    Bonjour,

    Si je veux calculer un bénéfice ou une perte, je veux mettre dans la case : si "charges" > "produit" alors Charge-produit --> pour les pertes.
    Et pour les bénéfices : si "bénéfices" > "charges" alors bénéfices-charges

    Comment l'écrire dans excel ?

    Je vous remercie

    Fiona

    Reply

    • Frédéric LE GUEN
      12/02/2016 @ 15:17

      Ce n'est pas la fonction SOMME.SI qu'il faut utiliser mais la fonction SI. =SI(cellule contenant les charges>cellule contenant les produits;Charges-produites;Benefice-Charge)

      Reply

  13. Yannick
    03/09/2015 @ 15:25

    Bonjour,
    J'ai un soucis véritable lorsque plusieurs dates se répètent dans le tableau:
    01/08/2015 02
    01/08/2015 12
    02/08/2015 14
    ...

    Faire la somme exclusivement du 01/08/2015, j'ai tout essayé sur les forum et tout en vain
    Pourriez vous m'aider svp

    Merci
    Cordialement

    Reply

  14. marj
    04/05/2015 @ 12:53

    Exercice parfait pour comprendre la fonction Somme.si
    Merci!

    Reply

  15. Nico
    04/01/2015 @ 13:20

    Parfait, merci !!

    Reply

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.

MICROSOFT MVP

RECHERCHE D’EMPLOI AVEC