Fonction SOMME.SI

Temps de lecture 2 minutes

La fonction SOMME.SI est basée sur le même principe que la fonction NB.SI.

Mais au lieu de compter le nombre de fois qu'un élément est présent dans une liste, vous pouvez ici calculer une somme correspondant à votre critère.

Construction de la fonction SOMME.SI

La fonction SOMME.SI a besoin de 3 paramètres pour fonctionner

  • La plage de sélection
  • Le critère de sélection
  • La plage à additionner

Comptabiliser un seul article

Par exemple, vous désirez connaitre la quantité de crayons vendus dans le mois.

  • Commencez par écrire la formule
  • Sélectionnez la plage de cellules qui contient vos produits (le critère)

=SOMME.SI(B3:B12;

  • Ensuite, inscrivez le mot "Crayon" comme critère de sélection

=SOMME.SI(B3:B12;"Crayon";

ou encore la référence de la cellule qui contient le mot Crayon

=SOMME.SI(B3:B12;G4;

Jusqu'ici, il n'y a pas de différence avec la fonction NB.SI

  • Pour terminer, vous allez sélectionner la plage de cellules où sont les données à additionner.

=SOMME.SI(B3:B12;G4;C3:C12)    => 245

Vérification

Pour vérifier que la fonction retourne le bon résultat, il vous suffit de faire un filtre sur le critère est de compter les valeurs.

Ici, c'est facile, ça peut se faire à la main vu le peu de valeur dans notre exemple

Depuis la colonne C, nous allons additionner toutes les cellules qui correspondent à la vente de Crayon

  • 75 (cellule C3)
  • 50 (cellule C6)
  • 100 (cellule C8 )
  • 20 (cellule C12)

Ce qui fait bien 245 😃👍

Fonction SOMME.SI qui retourne la quantité vendu pour l'objet analysé

Additionner le chiffre d'affaire

Maintenant, si on cherche le montant des commandes des crayons, on va simplement changer le 3ème paramètre de la formule. Ici, on va remplacer la colonne C par la colonne E.

=SOMME.SI(B3:B12;G4;E3:E12)    =>357,5

Faire la somme sur plusieurs critères

Maintenant, si vous devez effectuer une somme sur plusieurs critère (nom du produit et couleur du produit), la fonction SOMME.SI ne pourra pas être utilisée⛔⛔⛔

Dans ce cas de figure, il faut utiliser la fonction SOMME.SI.ENS qui a été conçue pour effectuer un calcul sur 255 critères 😮😃😍


Articles complémentaires

Voici une liste d'articles qui pourrait également vous intéresser sur le même thème.

Lien Permanent pour cet article : https://www.excel-exercice.com/somme-si/


(14 commentaires)

Passer au formulaire de commentaire

    • Harounian Herve on 19/06/2019 at 06:53
    • Répondre

    bonjour j'ai une somme de temps heure:min que je dois additionner
    je dois revenir à 0 toutes les 4 heures cumulée dans cette colonne d'addition
    comment puis je faire
    merci urgent

    1. Bonjour, très difficile de vous répondre et je ne pense pas que la fonction SOMME.SI soit à utiliser dans votre situation. Un SI avec un test si le temps cumulé est supérieur ou égale à 4 serait plus approprié.

  1. Bonjour,
    Peut-on mettre dans une cellule produit =Crayon+Gomme, et retrouver dans le tableau des totaux : 50% du montant affecté au Crayon et 50% du montant affecté au total gomme ?
    Merci par avance pour votre retour,
    Cordialement,

  2. Bonjour,

    La formule suivante fonctionne dans mon tableau : =SOMME.SI('gd livre dépenses'!B$2:B$76;"=Publicité";'gd livre dépenses'!F$2:F$76)
    Mais j'aimerais remplacer le critère par la cellule B3 contenant ce même texte.
    J'ai tenté ceci : =SOMME.SI('gd livre dépenses'!B$2:B$76;"=B3";'gd livre dépenses'!F$2:F$76), mais le résultat est toujours de 0 dans ce cas.
    Qu'est ce qui m'échappe?
    En espérant être clair.

    1. Pas de guillemets. Juste ;B3;

  3. BONJOUR
    JE VOUDRAIS ADDITIONNER QUE LE NBRES >0 COMMENT UTILISER LA FORMULE?

    MERCI

  4. Comment mettre la condition d'une couleur?
    Ex: Quand j'emmets une facture, j'entre le montant et j'ai une case "statut" qui est rouge tant que la facture n'est pas payée et verte quand elle l'est. Je voudrais calculer le total qui reste à me faire payer.

    Donc ce que je cherche c'est une formule qui ressemble à =SOMME.SI(B3:B12;"COULEUR ROUGE";C3:C12)
    Je fonctionne avec la version anglophone d'Excel, si possible fournir la formule en anglais.

    * J'ai tenté : =SUMIF(A2:A29,"REDCOLOR",D2:D29) mais ça ne fonctionne pas, il cherche les mots, pas la couleur en tant que telle.

  5. Il y'a une erreur non? "Si vous voulez connaître la quantité de gommes vendues" alors que l'on parlait de crayons. Et que l'on additionne les crayons :)

    Merci pour l'explication sinon

  6. Bonjour,

    Si je veux calculer un bénéfice ou une perte, je veux mettre dans la case : si "charges" > "produit" alors Charge-produit --> pour les pertes.
    Et pour les bénéfices : si "bénéfices" > "charges" alors bénéfices-charges

    Comment l'écrire dans excel ?

    Je vous remercie

    Fiona

    1. Ce n'est pas la fonction SOMME.SI qu'il faut utiliser mais la fonction SI. =SI(cellule contenant les charges>cellule contenant les produits;Charges-produites;Benefice-Charge)

  7. Bonjour,
    J'ai un soucis véritable lorsque plusieurs dates se répètent dans le tableau:
    01/08/2015 02
    01/08/2015 12
    02/08/2015 14
    ...

    Faire la somme exclusivement du 01/08/2015, j'ai tout essayé sur les forum et tout en vain
    Pourriez vous m'aider svp

    Merci
    Cordialement

    1. Poser votre question dans le nouveau forum prévu à cet effet et j'y répondrai
      Merci
      https://www.excel-exercice.com/forums/

  8. Exercice parfait pour comprendre la fonction Somme.si
    Merci!

  9. Parfait, merci !!

Laisser un commentaire

Your email address will not be published.

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.