Fonction SOMME.SI.ENS

La fonction SOMME.SI.ENS vous permet d'additionner certaines cellules selon des critères.

C'est un peu comme si vous aviez à faire des filtres sur plusieurs colonnes puis d'additionner les valeurs d'une colonne particulière ; mais là, c'est une formule qui fait le travail 😉

La fonction SOMME.SI.ENS

Pour rappel, la fonction NB.SI.ENS calcule le nombre de lignes correspondant à des critères.

=NB.SI.ENS(Plage de critères 1;Critère 1;Plage de critères 2;Critère 2;...)

La fonction SOMME.SI.ENS se construit exactement comme la fonction NB.SI.ENS.

Vous avez juste à ajouter en premier paramètre la colonne où sont les valeurs à additionner. Tous les autres paramètres sont identiques à ceux d'une fonction NB.SI.ENS.

=SOMME.SI.ENS(Plage à additionner;Plage de critères 1;Critère 1;Plage de critères 2;Critère 2;...)

Quelle est la quantité en stock en fin de mois ?

Nous souhaitons déterminer la quantité de rouge à lèvres en stock à la fin du mois.

1. Nous allons commencer par construire une fonction NB.SI.ENS qui va comptabiliser le nombre de lignes qui contiennent le mot rouge à lèvres (c'est très simple).

=NB.SI.ENS(B2:B21;"Rouge à lèvres")

2. Nous allons maintenant remplacer le terme NB par SOMME et nous rajoutons la colonne que nous voulons additionner en première position.

=SOMME.SI.ENS(G2:G21;B2:B21;"Rouge à lèvres")

Le stock fin de mois des rouges à lèvres est de 80 unités.

Combien de ventes réalisées dans le mois ?

Maintenant, si vous voulez connaître le nombre de rouge à lèvres que vous avez vendu dans le mois, il vous suffit de changer les références du premier paramètre et de conserver les critères de votre formule.

=SOMME.SI.ENS(F2:F21;B2:B21;"Vernis à ongle")

Comme vous le voyez il est extrêmement simple de retourner une somme sur seulement certaines cellules de votre feuille de calcul 😃😎😍

Rajouter de nouveaux critères

Le gros avantage de la fonction SOMME.SI.ENS c'est que vous pouvez rajouter autant de critères les uns derrières les autres sans casser votre fonction.

Nous cherchons à connaitre le nombre de vente de produits de couleur Rose pour le fournisseur A.

=SOMME.SI.ENS(G2:G61;D2:D61;"A";C2:C61;"Rose")

Vidéo explicative

Articles complémentaires


Voici une liste d'articles qui pourrait également vous intéresser sur le même thème.

Lien Permanent pour cet article : https://www.excel-exercice.com/somme-si-ens/


(13 commentaires)

Passer au formulaire de commentaire

  1. Merci trop bien l'explication

    • Michael Ipert on 18/03/2016 at 17:06
    • Répondre

    Bonjour,
    Pour les dates vous demandez à excel de chercher les dates supérieures à la dates de début et inférieures à la date de fin mais cela ne risque pas d’additionné toutes les dates supérieures au début c'est à dire même celles supérieures à la date de fin et toutes les dates inférieures à la date de fin c'est à dire même celles antérieures à la date de début. ou la fonction fait en sorte que toutes les conditions soit réunies sinon elle n'effectue pas l’addition?

  2. vraiment top. merci !

  3. Bonjour. j'utilise pour ma part depuis longtemps la fonction "sommeprod()" et j'ai du mal à voir la différence de comportement entre ces deux fonctions. Pourriez-vous m'éclairer ?

    Merci de votre aide.

    • Cacaille76 on 23/09/2015 at 12:26
    • Répondre

    Bonjour, Le tuto est bon toute fois une petite question: est-il possible de nommer les plages?
    =somme.si.ens(chemin_repertoire\Nom_fichier'!nom_feuille(mon_calcul);(chemin_repertoire\Nom_fichier'!nom_feuille(ma_plage1)critère1;(chemin_repertoire\Nom_fichier'!nom_feuille(ma_plage2)critère2
    Merci de votre reponce

    1. Bonjour,
      C'est possible mais il faut que le classeur qui contiennent les données soit ouvert ; c'est impératif.

  4. c'est mieux si les entetes sont dans les exemples colonnes et lignes

    • Alain Roussel on 09/07/2015 at 00:23
    • Répondre

    dans la formule Somme.si.ens est-ce possible d’insérer un critère avec une comparaison d’une valeur qui se retrouve sur une autre feuille. Voici un exemple :
    La formule Somme.si.ens est dans une cellule de la Feuille1, mais une valeur de comparaison pour un critère se retrouve dans la Feuille2.

    =SOMME.SI.ENS(B1:B5;C1:C5;"=LABELLE";D1:D5;"=Feuil2!A1")

  5. Bonjour

    Merci pour ce tutoriel. De mon côté j'aimerai savoir si il est possible d'utiliser à deux reprises la même plage de critère. Je vous montre mon cas: voici ma base

    A B C D E
    Groupe Spécial Coût unitaire Quantité Coût total
    Fruits En spécial $0,50 502 $251,00
    Poisson En spécial $0,70 426 $298,20
    Fruits Prix réguliers $2,50 583 $1 457,50
    Poissons En spécial $2,00 254 $508,00
    Légumes Prix réguliers $1,40 532 $744,80
    Fruits Prix réguliers $1,90 628 $1 193,20
    Légumes En spécial $1,20 502 $602,40
    Légumes Prix réguliers $2,30 498 $1 145,40
    Fruits En spécial $1,00 504 $504,00
    Légumes En spécial $1,40 555 $777,00
    Légumes Prix réguliers $1,70 467 $793,90
    Poisson En spécial $2,80 611 $1 710,80
    Fruits Prix réguliers $3,20 289 $924,80
    Légumes En spécial $2,00 420 $840,00

    J'aimerai donc savoir le coût total pour les fruit et de légumes dans la même cellule sachant que mes deux critères se trouve dans la colonne A.
    Quelqu'un aurait-il une solution adéquate ,la j'ai donné un exemple , mais dans mon cas réel en entreprise ( contrôle de gestion) il s'agit d'un fichier avec plus de 3000

    1. Bonjour Jessy, avez vous trouvé une solution pour utiliser la même plage de cellules avec plusieurs critères ? car moi aussi je souhaite faire somme.si.ens avec un critère dans une plage A et plusieurs critères dans une plage B.

      Merci de votre réponse

    2. Vous pourriez utiliser un controle qui se met à vrai ou faux selon vos critères et utiliser ce dernier dans votre somme.si.ens.

  6. cool

    1. merci de ton intervention mimmimimimimi

Laisser un commentaire

Your email address will not be published.