Condition

Fonction SOMME.SI.ENS

Temps de lecture 2 minutes

La fonction SOMME.SI.ENS vous permet d'additionner certaines cellules selon des critères que vous allez sélectionner.

C'est un peu comme si vous aviez à faire des filtres sur plusieurs colonnes puis d'additionner les valeurs d'une colonne particulière ; mais là, c'est une formule qui fait le travail 😉

La fonction SOMME.SI.ENS

Pour rappel, la fonction NB.SI.ENS calcule le nombre de lignes correspondant à des critères.

=NB.SI.ENS(Plage de critères 1;Critère 1;Plage de critères 2;Critère 2;...)

La fonction SOMME.SI.ENS se construit exactement comme la fonction NB.SI.ENS.

Vous avez juste à ajouter en premier paramètre la colonne où sont les valeurs à additionner. Tous les autres paramètres sont identiques à ceux d'une fonction NB.SI.ENS 😃😉

=SOMME.SI.ENS(Plage à additionner;Plage de critères 1;Critère 1;Plage de critères 2;Critère 2;...)

Quelle est la quantité en stock en fin de mois ?

Nous souhaitons déterminer la quantité de rouge à lèvres en stock à la fin du mois.

1. Nous allons commencer par construire une fonction NB.SI.ENS qui va comptabiliser le nombre de lignes qui contiennent le mot rouge à lèvres (c'est très simple).

=NB.SI.ENS(B2:B21;"Rouge à lèvres")

Utilisation de la fonction NB.SI.ENS pour gérer ses stocks

2. Nous allons maintenant remplacer le terme NB par SOMME et nous rajoutons la colonne que nous voulons additionner en première position.

=SOMME.SI.ENS(G2:G21;B2:B21;"Rouge à lèvres")

Exemple de résultat retourné par la fonction SOMME.SI.ENS

Le stock fin de mois des rouges à lèvres est de 80 unités.

Combien de ventes réalisées dans le mois ?

Maintenant, si vous voulez connaître le nombre de rouge à lèvres que vous avez vendu dans le mois, il vous suffit de changer les références du premier paramètre et de conserver les critères de votre formule.

=SOMME.SI.ENS(F2:F21;B2:B21;"Vernis à ongle")

Comme vous le voyez il est extrêmement simple de retourner une somme sur seulement certaines cellules de votre feuille de calcul 😃😎😍

Rajouter de nouveaux critères

Le gros avantage de la fonction SOMME.SI.ENS c'est que vous pouvez rajouter autant de critères les uns derrières les autres sans casser votre fonction.

Nous cherchons à connaitre le nombre de vente de produits de couleur Rose pour le fournisseur A.

=SOMME.SI.ENS(G2:G61;D2:D61;"A";C2:C61;"Rose")

La fonction SOMME.SI.ENS retourne le résultat d'une addition d'après les critères de 3 colonnes différentes

Vidéo explicative

Related posts

Fonction FILTRE, filtrer sur plusieurs colonnes

Frédéric LE GUEN

NB.SI.ENS plus grand – plus petit

Frédéric LE GUEN

Conserver la dernière mise à jour des données

Frédéric LE GUEN

25 commentaires

Ben 08/01/2021 at 15:07

Bonjour,

je cherche un moyen de calculer automatiquement mes déplacements pro, pour des stats (et pour m'amuser un peu).
L'idée est de calculer le nombre de voyages en IDF et le nombre de voyages en province.

Colonne A : date
Colonne B : lieu
Colonne C : département (où je rentre le numéro)

Comment avoir une case où s'additionneraient automatiquement toutes les réponses IDF (75, 92, 93, etc) et une autre où s'additionneraient automatiquement toutes les réponses différentes ?

Un grand merci d'avance

Répondre
nguema 20/10/2020 at 14:43

Monsieur LEGUEN

je suis un fan de votre site, et de vos exploits.

je suis stagiaire dans une PME et je voudrais mettre en place une gestock compose de

une feuille inventaire
une feuille stock
une feuille entree
une feuille sortie
une feuille mouvement
le tout, sans macro, juste sur excel....
la difficulté que je rencontre ce trouve au niveau ou lorsque je saisi sur la feuille mouvement, je veux que que les calculs soient dynamique dans les autres feuilles.

merci beaucoup d avance monsieur

Répondre
zaz 07/08/2020 at 10:27

Comment puis-je demander à excel de calculer les CA de 2019 si 2020 est supérieur à 0
L'idée étant d'avoir un comparatif des deux années avec un CA arrété en juillet par exemple aout n'étant pas encore renseigné.

Répondre
Frédéric LE GUEN 07/08/2020 at 11:41

Si le besoin c'est de comparer 2 périodes, il faut utiliser les fonctions de Time Intelligence du language DAX. C'est un projet assez compliqué à mettre en place mais c'est le seul moyen de répondre exactement au besoin.
Maintenant, pour utiliser la fonction SOMME.SI.ENS pour les données supérieures à 0, il faut tout simplement écrire =SOMME.SI.ENS(Plage de recherche, ">0", Plage à additionner)

Répondre
KRIM Ali 24/07/2019 at 11:11

Bonjour

je souhaiterai additionner des plages qui ne se suivent pas forcément selon plusieurs critéres..
Pourriez-vous m'aider ?
Merci

Répondre
ali 16/07/2019 at 13:30

SALUT. comment calculer des cellules avec une cellule avec texte. ex: 12+09+absent= ?

Répondre
NEBIL JBALI 15/10/2020 at 21:14

Comment mettre un critère <à une cellule . Cette valeur change évidemment le long de la colonne d'une cellule à une autre.

Répondre
Frédéric LE GUEN 15/10/2020 at 21:33

De la même façon que pour une fonction NB.SI.ENS comme c'est indiqué dans cet article

Répondre
Arrabelle Chevallier-Sollier 25/06/2019 at 19:39

Bonsoir,

J'ai crée un fichier sur 3 années de réponses à des appels d'offres pharmaceutiques, avec Nom, quantité et prix (le reste des colonnes à peu d'intérêt dans ce qui me préoccupe ;)
J'ai des unités A à multiplier par un prix P, jusqu'à là rien de bien compliqué, mais j'ai 3 années avec parfois des prix parfois non.
J'aimerais que ma cellule de calcul, choisisse de multiplier les unités de préférence par le prix de l'année la plus récente et si celle-ci est vide, qu'elle calcule le CA avec la 2e année jusqu'à la 3e et là, j'ai essayé de multiples formules qui ne donnent rien, pourriez-vous m'éclairer?
Je vous remercie pour votre aide
Bonne soirée
Arrabelle

Répondre
chantal 20/04/2019 at 16:41

Bonsoir

quelqu'un peut-il m'aider svp ? j'en ai bien besoin urgent. merci beaucoup

Peut-on utiliser sommeprod() à la place de la plage à additionner (qui ne tient compte que d'une seule colonne) ? cela m'arrangerait beaucoup pour extraire du journal des entrées sorties, la valeur des entrées et ensuite celle des sorties
merci
chantal

Répondre
chantal 19/04/2019 at 21:14

bonsoir
Peut-on utiliser sommeprod() à la place de la plage à additionner ? cela m'arrangerait beaucoup pour extraire du journal des entrées sorties, la valeur des entrées et ensuite celle des sorties
merci
chantal

Répondre
Chantal Caron 14/01/2019 at 06:40

Bonjour, j'aurai besoin d'aide pour sélectionner des critères pour en faire des sommes. Je ne sais pas comment faire. Pourriez-vous m'aider?

Répondre
gigi 13/12/2018 at 18:33

Merci trop bien l'explication

Répondre
Michael Ipert 18/03/2016 at 17:06

Bonjour,
Pour les dates vous demandez à excel de chercher les dates supérieures à la dates de début et inférieures à la date de fin mais cela ne risque pas d’additionné toutes les dates supérieures au début c'est à dire même celles supérieures à la date de fin et toutes les dates inférieures à la date de fin c'est à dire même celles antérieures à la date de début. ou la fonction fait en sorte que toutes les conditions soit réunies sinon elle n'effectue pas l’addition?

Répondre
Anonyme 28/11/2015 at 09:47

vraiment top. merci !

Répondre
Anonyme 25/11/2015 at 10:57

Bonjour. j'utilise pour ma part depuis longtemps la fonction "sommeprod()" et j'ai du mal à voir la différence de comportement entre ces deux fonctions. Pourriez-vous m'éclairer ?

Merci de votre aide.

Répondre
Cacaille76 23/09/2015 at 12:26

Bonjour, Le tuto est bon toute fois une petite question: est-il possible de nommer les plages?
=somme.si.ens(chemin_repertoire\Nom_fichier'!nom_feuille(mon_calcul);(chemin_repertoire\Nom_fichier'!nom_feuille(ma_plage1)critère1;(chemin_repertoire\Nom_fichier'!nom_feuille(ma_plage2)critère2
Merci de votre reponce

Répondre
Frédéric LE GUEN 23/09/2015 at 13:23

Bonjour,
C'est possible mais il faut que le classeur qui contiennent les données soit ouvert ; c'est impératif.

Répondre
danbo52danbo 28/07/2015 at 08:44

c'est mieux si les entetes sont dans les exemples colonnes et lignes

Répondre
Alain Roussel 09/07/2015 at 00:23

dans la formule Somme.si.ens est-ce possible d’insérer un critère avec une comparaison d’une valeur qui se retrouve sur une autre feuille. Voici un exemple :
La formule Somme.si.ens est dans une cellule de la Feuille1, mais une valeur de comparaison pour un critère se retrouve dans la Feuille2.

=SOMME.SI.ENS(B1:B5;C1:C5;"=LABELLE";D1:D5;"=Feuil2!A1")

Répondre
Jessy 02/06/2015 at 06:45

Bonjour

Merci pour ce tutoriel. De mon côté j'aimerai savoir si il est possible d'utiliser à deux reprises la même plage de critère. Je vous montre mon cas: voici ma base

A B C D E
Groupe Spécial Coût unitaire Quantité Coût total
Fruits En spécial $0,50 502 $251,00
Poisson En spécial $0,70 426 $298,20
Fruits Prix réguliers $2,50 583 $1 457,50
Poissons En spécial $2,00 254 $508,00
Légumes Prix réguliers $1,40 532 $744,80
Fruits Prix réguliers $1,90 628 $1 193,20
Légumes En spécial $1,20 502 $602,40
Légumes Prix réguliers $2,30 498 $1 145,40
Fruits En spécial $1,00 504 $504,00
Légumes En spécial $1,40 555 $777,00
Légumes Prix réguliers $1,70 467 $793,90
Poisson En spécial $2,80 611 $1 710,80
Fruits Prix réguliers $3,20 289 $924,80
Légumes En spécial $2,00 420 $840,00

J'aimerai donc savoir le coût total pour les fruit et de légumes dans la même cellule sachant que mes deux critères se trouve dans la colonne A.
Quelqu'un aurait-il une solution adéquate ,la j'ai donné un exemple , mais dans mon cas réel en entreprise ( contrôle de gestion) il s'agit d'un fichier avec plus de 3000

Répondre
Laurie 22/10/2015 at 09:52

Bonjour Jessy, avez vous trouvé une solution pour utiliser la même plage de cellules avec plusieurs critères ? car moi aussi je souhaite faire somme.si.ens avec un critère dans une plage A et plusieurs critères dans une plage B.

Merci de votre réponse

Répondre
Chico 14/05/2017 at 18:49

Vous pourriez utiliser un controle qui se met à vrai ou faux selon vos critères et utiliser ce dernier dans votre somme.si.ens.

Répondre
Anonyme 22/07/2013 at 22:43

cool

Répondre
Anonyme 10/03/2015 at 16:47

merci de ton intervention mimmimimimimi

Répondre

Laissez un commentaire

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.