Fonction NB.SI.ENS

Temps de lecture : 3 minutes

Utilité de la fonction NB.SI.ENS

La fonction NB.SI.ENS vous permet de compter le nombre de lignes correspondant à un ou plusieurs critères de sélection.

C'est un peu comme si vous effectuez un filtre sur vos données et que vous comptiez les lignes retournées.

Sauf que là, la fonction fait le calcul pour vous 👍😍😎

NB.SI vs NB.SI.ENS

En fait, dans Excel, il existe 2 fonctions presque similaires

  • NB.SI.ENS vous permet d'effectuer de compter les lignes pour 1 et jusqu'à 255 critères.
  • La fonction NB.SI compte les lignes correspondant à un seul critère.

La fonction a été développée à partir de la version d'Excel 2007 et il est préférable de l'utiliser à la place de NB.SI 😎

Construction de NB.SI.ENS avec 2 critères

Pour fonctionner, la fonction NB.SI.ENS a besoin :

  1. De la sélection d'une plage de données où se fera la recherche.
  2. Le critère de sélection pour cette plage de données
  3. et ainsi de suite pour les 254 autres critères ...

Par exemple, nous allons partir du classeur suivant où vous souhaitez connaître le nombre d'hommes et célibataires.

Tableau de notre clientele
  1. Nous allons donc commencer par écrire le début de la formule.

=NB.SI.ENS(

  1. Ensuite, sélectionnez la plage de cellules pour y effectuer une sélection.

=NB.SI.ENS(C2:C20;

  1. Puis, vous allez saisir l'élément que vous voulez rechercher ; le terme "Homme".

=NB.SI.ENS(C2:C20;"Homme";

Le mot "Homme" s'écrit entre guillemets car il s'agit d'une chaîne de caractères et toutes les chaînes de caractères doivent être écrites entre guillemets dans Excel.

  1. Pour terminer, nous ajoutons la plage de cellules qui contient la situation maritale et le critère "Célibataire".

=NB.SI.ENS(C2:C20;"Homme";E2:E20;"Célibataire")

Utiliser des références comme critères

Il est tout à fait possible de remplacer le critère écrit en toutes lettres par la référence d'une cellule.

En reprenant exactement le même exemple, nous remplaçons le mot Homme par la référence de la cellule qui contient ce mot et ça fonctionne parfaitement. 😃😎

=NB.SI.ENS($C$2:$C$20;H2;$E$2:$E$20;"Célibataire")

NB.SI.ENS et référence cellule

Les $ indiquent que les références sont verrouillées. Ce qui va permettre de recopier la formule tout en restant toujours positionné sur les mêmes plages à comptabiliser.

Critère partiel

Vous pouvez créer des critères de sélection plus complexes en basant votre critère sur une partie d'un mot.

Trouver les noms qui commence par un S

Utiliser un nombre comme critère

La fonction NB.SI.ENS fonctionne également en utilisant des valeurs numériques comme critères de sélection.

Pour compter le nombre d'hommes qui ont 1 enfant, nous allons écrire le chiffre sans le mettre entre guillemets.

=NB.SI.ENS(C2:C20;"Homme";F2:F20;1)

NB.SI.ENS et valeurs numériques

Plus grand ou plus petit que

La fonction NB.SI.ENS peut aussi compter le nombre de cellules qui correspondent à un test de type plus grand que ou plus petit que.

Ecriture du critere de selection des salaires plus grand que 50000

Pourquoi la fonction NB.SI.ENS retourne une erreur

Si vous renseignez des plages de cellules de tailles différentes, la fonction NB.SI.ENS retournera toujours une erreur.

Dans l'exemple suivant, même si les critères sont justes, la fonction retournera #VALEUR! car les plages de sélection n'ont pas le même nombre de cellules.

=NB.SI.ENS(C2:C20;"Homme";E2:E21;"Célibataire")

Différentes techniques pour compter les lignes

Découvrez plusieurs techniques qui vous permettent de compter les lignes (plusieurs fonctions expliquées).

Vous trouverez des informations complémentaires sur la fonction NB.SI.ENS sur le site de Microsoft.

68 Comments

  1. Ghita
    12/12/2021 @ 14:11

    Bonjours on m as demander les hôtels dont le nom commence par T et se termine par A mais je ne sais pas comment le calculer

    Reply

    • Frédéric LE GUEN
      13/12/2021 @ 16:31

      Faites un filter "commence par" et "se termine par" tout simplement

      Reply

  2. RAVAIL
    20/06/2021 @ 17:07

    Bonjour, sur une plage de cellules données, je souhaite quantifier les unités au-delà de 2. C'est-à-dire que je vais par exemple de k2 à k65, remplies avec des unités de 1 à 6 mettons, mais que ma formule SI. ne calcule les unités qu'au delà de 2. La première formule que j'ai insérée, ne tient compte que des cellules qui ont des unités >2 mais calcule toutes les unités des cellules trouvées: je voudrai que cela ne calcule que le nombre d'unités au-delà de "2"......

    Reply

  3. pacal eicher
    12/04/2021 @ 00:09

    Bonjour, peut etre pourriez vous m'aider avec une formule excel.

    exemple: J'ai un capital de x qui change toutes les semaines je veux donner un % à qqun mais je veux que ce montant de dépasse pas une somme choisit.
    capital 100'000.- (qui change) je décide de donner 5% de cette somme mais elle ne doit pas dépasser 8'000.- sachant que le capital lui va augmenter. Ce qui m'intéresse c de ne pas changer le % que je veux donner mais que cette somme ne dépase pas un certains montant choisi.
    Merci

    Reply

    • Mohamed
      15/04/2021 @ 12:02

      Je réponds peut-être un peu tard mais voilà ce que vous pouvez écrire dans la case de donation :
      =SI((0,05*A1)>8000;8000; (0,05*A1))

      Dans ce cas-ci "A1" est la case capital (qui est variable). A vous d'adapter cette case selon votre Excel.

      Reply

  4. Claire
    16/12/2020 @ 11:53

    Bonjour,

    J'ai une feuille qui contient une base de données et un tableau avec une trame spécifique dans un autre classeur avec la fonction NB.SI.ENS en lien avec la base pour renseigner automatiquement le tableau.
    Jusque là, tout va bien, sauf que le critère de l'année s'ajoute. Donc je souhaite que quand je filtre l'année souhaitée dans la base, les résultats s'adaptent dans le tableau, ou alors ajouter le critère de l'année dans la formule NB.SI.ENS du tableau.
    Je n'arrive pas à trouver la solution, car NB.SI.ENS va chercher les données dans l'ensemble de la colonne sans tenir compte des filtres de la base.
    Pourriez-vous m'aider ?

    Merci,
    Cordialement

    Reply

    • Claire
      16/12/2020 @ 12:31

      J'ai trouvé la solution après vous avoir écrit ! Il suffisait à priori d'ajouter le critère année dans la formule NB.SI.ENS en créant une cellule dédiée d'année de référence dans la base.
      Désolée et merci

      Reply

      • Têtu
        27/03/2022 @ 13:22

        Bonjour,
        J ai besoin d aide svp
        J ai une colonne C qui peut contenir :SP/F/SC sur plusieurs lignes
        Et des colonnes D à H qui contiennent des noms ou pas ...
        Ex ligne 1 : C:SC ,D: Jacques, E: Maurice,F: Jean, G: Sébastien, H:vide
        Et ainsi de suite avec C qui peut changer et D à H aussi
        Je voudrais dans un autre tableau savoir combien de fois Jacques a fait SC,combien il a fait F ,combien il a fait SP....
        J ai essayé cette formule nb.si.ens
        Mais ça ne fonctionne pas ...
        Pouvez vous m aider svp?
        En vous remerciant d'avance

    • Chris
      04/03/2021 @ 20:44

      Il y a la fonction SOUS.TOTAL qui permet de faire la somme, moyenne, le nombre de valeur, le minimum, etc, de la zone qui est filtrée. Mais la réponse change dépendamment du filtre. Il y a aussi la nouvelle fonction AGREGAT qui fonctionne un peu dans le même genre mais plus poussé.

      Reply

  5. kader
    18/10/2020 @ 13:28

    Je vous remercie pour la vidéo. Je galérais avec le #VALEUR qui était du effectivement un problème de séléction.

    Reply

  6. OGB
    06/08/2020 @ 15:02

    Bonjour,

    J'ai un fichier Excel qui se présente comme suit :

    Nom mercredi 1 août 2020 jeudi 2 août2020 vendredi 3 août 2020
    Pierre 1 5 8
    Claude 2 3 1
    Sophie 7 1 2
    Charles 8 9 5

    Critères : 1 ; 2 ; 3 ; 4 ; 5 ; 6 ; 7 ; 8 ; 9

    Je souhaite avoir une synthèse qui calcule ne nombre de fois que j'ai un critère donné pour chaque nom, comme suit :

    1 2 3 4 5 6 7 8 9
    Pierre 2 0 0 0 1 0 0 0 0
    Claude 1 1 1 0 0 0 0 0 0
    Sophie 1 1 0 0 0 0 1 0 0
    Charles 0 0 0 0 1 0 0 1 1

    Merci d'avance pour votre aide.

    Cordialement.

    Reply


  7. 06/08/2020 @ 11:53

    Bonjour,
    Dans un tableau Excel, j'ai une liste de personne et des critères (allant de 1 à 9).

    Exemple :
    Colonne A : Nom (Jean ; Sophie ; Amy ; Carole)
    Colonne B : Critère 1
    Colonne C : Critère 2
    Ainsi de suite.

    Je cherche une formule qui me permet de trouver le nombre de fois que j'ai un critère (1) pour une personne donnée.

    Merci d'avance.

    Reply

  8. Nathalie
    20/04/2019 @ 09:19

    bonjour,

    je cherche a faire un tirage aléatoire pour un petit club de pétanque mais je coince
    je n arrive pas a trouver la fonction qui faut pour mettre un nombre d'équipe dans une cellule et que dans la colonne à coté me détaille se nombre
    (exemple de 1 à 20) pour que je puisse reprendre une fonction aléa dessus.

    désolé si je ne m'explique pas très bien mais merci pour votre aide

    Reply

  9. ma
    13/04/2019 @ 13:57

    Bonjour,

    j'ai lu toutes les explications précédentes mais n'y aie pas trouvé de réponse…

    A partir d'une date de naissance ( par exemple enfant né le 12/04/2016 + 3ans = 12/04/2019)
    Je souhaite faire apparaitre une mise en forme conditionnelle suivante:
    =SI(date de naissance<3ans;"Votre enfant a moins de 3 ans";"Votre enfant a plus de 3 ans")
    mais je ne sais pas comment faire car cette phrase n'est pas reconnue par excel!??

    Cela implique bien sur qu'Excel calcule, à partir d'une date initiale et d'une date finale en temps réelle, si l'enfant a moins ou plus de 3 ans.
    J'ai besoin de cette première information, car en fonction de si l'enfant a moins ou plus de 3 ans, des calculs suivants seront différents.

    merci pour votre aide.
    ma

    Reply

  10. RENEL Joel
    06/03/2019 @ 17:33

    Bonjour,
    J'ai cette fonction pour compter tous mes ouvrages qui sont livre CD ou DVD :
    =NB.SI($F$8:$F1623;"*CD*")+NB.SI($F$8:$F$1623;"DVD*")

    Mais je voudrais également aller voir sur une autre colonne la H si c'est OK donc je voulais rajouter AND NB.SI($H8:$H1623;"OK") à la suite mais erreur !
    Quelqu'un a une solution ?

    D'avance merci
    Je suis bénévole dans une bibliothèque municipale que je suis en train d'informatisée.

    Reply

    • Frédéric LE GUEN
      06/03/2019 @ 19:17

      C'est la fonction NB.SI.ENS qu'il faut utiliser avec plusieurs critères et pas du bidouillage de plusieurs fonctions NB.SI

      Reply

  11. Mathias
    24/07/2018 @ 12:12

    Bonjour
    Je cherche à obtenir les numéros des lignes correspondant a chacune des occurrences trouvées par le NB.SI ou NB.SI.ENS
    ex si NB.SI me retourne 3 : je voudrais avoir comme résultat 92, 217, 465... apres avec des equiv et des indirect je pourrai ressortir les informations de chaque ligne..
    Merci beaucoup
    Mathias

    Reply

  12. hakem
    23/06/2018 @ 17:53

    =nb.si.ens(d8:d1000;"3m";e8:fp8;"fr") le résultats message valeur et ceci pour calculer la somme des absences dans le mois de chaque classe

    Reply

  13. Mickaël
    13/02/2018 @ 16:26

    Bonjour,

    Je vous écris car j'aimerais plus de précision sur l'utilisation de nb.si.ens avec des dates.
    En effet, j'aimerais compter le nombre de valeurs d'une colonne, si les valeurs sont comprises entre dateA et dateB.

    J'imaginais donc écrire
    NB.SI.ENS(A3:A500;">= " & dateA ; A3:A500;"= " & dateA) fonctionne chez moi.
    Mais si j'écris
    NB.SI.ENS(A3:A500;">= 01/01/2017") ça ne fonctionne pas. Sauriez-vous me dire pourquoi?

    J'ai l'impression qu'il y a une syntaxe très précise avec les dates et les espaces à respecter, mais je ne trouve pas.

    Merci d'avance pour votre aide

    Reply

    • Frédéric LE GUEN
      14/02/2018 @ 15:41

      Ca devrait. Il ne faut pas mettre d'espaces entre la date et les signes logiques.

      Reply

  14. Fabrice
    26/01/2018 @ 16:02

    Bonjour ,

    j'ai un tableau excel avec des noms en colonne de gauche , des horaires de travail pour le mois pour chaque personne et un compteur en bas de chaque jours qui me donne le nombre de personne effectuant le mème horaire de travail.
    Je souhaite avoir un tableau qui me donne le nom des personne travaillant dans un horaire de travail donné.

    Merci pour votre aide

    Reply

  15. Debard
    20/01/2018 @ 11:47

    Bonjour,

    Je n'arrive pas à faire une formule. Je suis prof d'EPS et je voudrais créer une formule qui me permet de connaître sur la 2eme mi temps d'un match combien il y a eu de nouveaux tireurs dans une équipe... mais je bloque !

    Je pensais que la formule suivante pouvais fonctionner mais non :

    =SI(plage=0;NB.SI(autre plage;">0")) mais j'ai un message d'erreur ....

    Est ce que quelqu'un peut m'aider !?

    D'avance merci

    Reply

    • Laurent
      13/08/2018 @ 13:36

      Bonjour

      Un petit coup de pouce tardif entre collègues.... je suis sur les nouvelles évaluation Bad

      NB.SI() ne vérifie qu'un critère
      =NB.SI.ENS(A14:A21;0;B14:B21;">"&0) ou comme tu l'as écrit =NB.SI.ENS(plage;0;autreplage;">"&0)
      Attention les 2 plages doivent êtres equivalentes

      Pour une valeur fixe tu n'es pas obligé de mettre égale entre guillemet "=0"
      Ta forme ">0" est équivalente à ">"&0 mais ne marche pas avec un appel à une cellule ">"&A3 par exemple

      Cordialement

      Reply

  16. ACHACHI
    08/01/2018 @ 21:04

    Bonjour,

    Pourriez-vous m'aider svp?

    dans mon tableau j'ai une colonne intitulée C6/NF et une autre avec le montant
    soit on renseigne le code C6 soit le Code NF
    sur chaque ligne on renseigne donc soit C6 soit NF et donc le montant attribué sera pour l'un ou pour l'autre
    jusque là tout va bien ;-)

    mais je dois renseigner dans un autre tableau une autre réf à savoir j'ai le montant global C6 / et le montant global NF alors
    dans la cellule objectif C6 = si la ligne 3 = C6 alors on prend on compte le montant si non (donc NF) on ne prend rien donc 0
    à l'inverse dans la cellule objectif NF si la ligne 4 = NF elle sera comptabilisée sinon 0
    Je ne sais pas si vous pouvez m'aider (si je suis claire ) ??
    Merci d'avance

    Reply

  17. p.ducommun
    04/05/2017 @ 16:48

    Monsieur,
    j'ai 8 cellules de F17 à M17
    Dans ces colonnes, j'ai des prix différents.
    Dans la cellule N17, je souhaite afficher le prix le plus bas.
    Jusque là, pas de problèmes, la formule =MIN(F17;M17) me convient.
    Cela se gâte au moment ou une colonne, qui n'a pas de prix ou = à CHF 0.-, car la cellule N17 affiche 0.- plutôt que, le prix le plus bas
    des 7 autres cellules comportant un prix supérieur à 0.-

    Une solution me comblerait.

    Patrick

    Reply

  18. Anonyme
    05/02/2016 @ 23:55

    Bonjour,
    J'ai un problème pour lequel je demande si quelqu'un a une solution qu'il m'aide.

    J'ai un tableau contenant :
    -une liste de travailleurs journaliers
    -Les dates de recrutement de chaque personnes. Chaque personne peut être recrutée à plusieurs reprises.

    J'aimerais avec une formule pouvoir compter le nombre de personnes (sans doublons) qui sont recrutées pour chaque mois (Janvier, Février, Mars...)

    Merci de votre aide.

    Reply

  19. TRAORE
    25/01/2016 @ 17:23

    inpecable de toutes les informations sur ces deux fonctions en Excel. courage

    Reply

  20. MFrance
    24/01/2016 @ 04:21

    Bonjour Frédéric, j'ai un tableau avec une colonne contenant beaucoup de dates (date de production) - dont des doublons; une autre colonne avec le nom du mois (texte) (les mois ne correspondent pas exactement aux dates, certaines exceptions s'appliquent à l'aide d'une fonction RECHERCHEV). Dans une troisième colonne je dois connaître le nombre de jours de production du mois corrigé en question (ne doit pas inclure les doublons). Ce chiffre me servira à calculer plusieurs autres données. Mais là là je suis bloquée! Est-ce possible de mettre vos lumière sur ce problème? Je vous remercie,

    Reply

  21. HAFID AIT TALB
    20/12/2015 @ 18:56

    bsr stp une solution pour cette formule
    soit une nombre des unites M
    si M est entre 1 et 5 alors resultat est M *3
    si M est entre 6 et 17 alors resultat sera 5*3 plus le reste (M-5) multiplier 4
    si M egale 18 ou plus alors resultat sera 5*3 plus 17*4 et le reste multiplier sur 5

    Reply

  22. creveladalle
    24/11/2015 @ 10:43

    Bonjour
    merci beaucoup pour la clareté des explications. Juste une petite coquille dans la formule dénombrer sur une période de temps je crois qu'il faut manque quelques points virgules (;) pour séparer les critères et plages car on voit des virgules.

    Reply

  23. krimopoulos
    17/11/2015 @ 17:50

    Bonjour j'ai un fichier avec la date et l'heure d'entrée et la date et l'heure de sortie de patients aux urgences sur 1 mois.
    je souhaiterais savoir combien de patient sont présents en moyenne par tranche horaire sur 24h.
    est ce que la fonction NB.SI.ENS est la bonne formule ?

    Reply

  24. Nico
    04/11/2015 @ 18:19

    Bonjour,

    je voudrai integrer la possibilité de multiplier ma matrice résultante de la fonction NB.SI.ENS par une autre matrice.
    Je m'explique; j'ai une colonne assez simple, dont je peux vérifier facilement le critere, j'ai une autre colonne, sur laquelle je dois rechercher la presence de caractere pour chaque cellule. Jusqu'ici, la fonction NB.SI.ENS le gère bien. Mais je veux, avant d'additionner ce croisement, multiplier le résultat de chaque ligne par une 3eme matrice. Je veux en fait additionner les valeurs de la 3eme colonne si je respecte les conditions 1 et 2...
    J'ai essayer de passer par la fonction sommeprod, mais la, c'est la condition sur les caractere que je n'ai pas reussi à faire resortir sous format matriciel...

    Voici ma formule sous format NB.SI.ENS mais qui ne prend pas en compte ma 3eme colonne (AI)
    =NB.SI.ENS($AL$10:$AL$209;(C14&D14);$AD$10:$AD$209;"*19" & E14 & "*")

    Voici la formule sous format sommeprod, mais ma condition sur ma seconde colonne (AD) représentée en NB.SI me renvoie une valeur et pas une matrice
    =SOMMEPROD(($AL$10:$AL$209=(C15&D15))*NB.SI($AD$10:$AD$209;"*19" & E15 & "*");($AI$10:$AI$209))

    Si quelqu'un a une idée...

    Reply

  25. Julien
    28/10/2015 @ 15:24

    Bonjour,

    J'ai créer une matrice de contrôle pour mon travail, pour détecter le nombre d'erreur.

    La matrice fonctionne correctement, toutefois dans le but d'optimiser celle-ci, je souhaite savoir si il existe une formule ou une macro permettant de retrouver les références comptabilisées par la formule NB.SI.ENS.

    Je pourrais passer par un tableau croisé dynamique, mais cette matrice est utilisée par plusieurs utilisateurs et je souhaite l'automatisé le plus possible.

    Pouvez-vous m'aider sur le sujet ?

    Julien

    Reply

  26. Arno
    29/07/2015 @ 16:37

    Bonjour, merci pour toutes ces indications sur la fonction NB.SI.ENS
    De mon côté je me heurte au problème suivant :
    Si on part du premier tableau d'exercice de la page, comment compter par exemple : le nombre d'hommes célibataires OU mariés ?
    La difficulté vient de ce que j'ai trois critères : "homme", "mariés" et célibataire" et deux plages. Ainsi "célibataires" et "mariés" font référence à une seule et même plage. Comment faire ? Merci pour votre aide. A

    Reply

  27. Ray_78
    28/07/2015 @ 11:08

    Bonjour, est il possible de combiner cette fonction avec une critère de recherche de type "cherche" ??

    Reply

  28. Pat54
    05/06/2015 @ 05:20

    Bonjour,
    Je cherche une formule qui me permettrait de calculer le nombre de personnes présentes durant une plage horaire (par exemple entre 17h et 22h).
    Merci par avance.
    Pat

    Reply

    • Frédéric LE GUEN
      05/06/2015 @ 05:36

      Bonjour,
      Oui, c'est bien la fonction NB.SI.ENS qu'il faut utiliser mais après il faut faire attention à ce que vos données des heures soient correctes. Si vous mettez 17, Excel comprendra qu'il s'agit de 17 jours. Pour indiquer que ce sont des heures il faut convertir vos données en divisant par 24

      Reply

    • krimopoulos
      17/11/2015 @ 17:53

      avez vous reussi votre formule ? ça m'interesse ?
      Bonjour j’ai un fichier avec la date et l’heure d’entrée et la date et l’heure de sortie de patients aux urgences sur 1 mois.
      je souhaiterais savoir combien de patient sont présents en moyenne par tranche horaire sur 24h ?

      Reply

  29. marie-josee
    19/04/2015 @ 14:49

    bonjour j'ai fait un tableau afin de calculer les heures pour des maladies des congé ou du temps repris... cela fonctionne par couleur je voudrais faire un calcule de toute les cases rouges dans lequel j'aurais inscrit le nombre d'heures que la personne a pris...
    rouge= maladie
    jaune= vacances
    vert= temps repris

    je ne trouve pas de formule... Merci de bien vouloir m'aider

    Reply

    • Frédéric LE GUEN
      20/04/2015 @ 09:10

      Il n'y a pas de fonction pour dénombrer le nombre de couleur dans une colonne.

      Reply

  30. bea
    30/03/2015 @ 18:29

    Bonjour,
    J'ai un tableau avec une plage de cellule correspondante à des trevenus moyens par pays.
    Dans certains cellules j'ai pas des valeur mais du text (n.d). Dans un autre tableau il faut que je trouve le taux de répartition (le revenu d'un pays sur la totalité de tous les pays)
    =SOMME(C58;1/(C58:C85) mais par tout je recois la même valeur de 1 ou ca donne une valeur. Comment faire obtenir une valeur correcte en comptant les cellules où il n'y a pas de valeur numérique?
    Merci d'avance pour votre réponse!

    Reply

  31. melleprincesse
    09/03/2015 @ 16:05

    Bonjour,

    Je souhaite faire une formule NB.SI pour des ensembles de nombre :
    Par exemple, je souhaite avoir le nombre de cellules comportant des chiffres compris entre 10 et 15, j'ai essayé d'insérer ceci :
    NB.SI.ENS(E33:E51); 10<E:33:E51<15)
    Ca n'a bien sur pas marché, pouvez-vous m'aider ?
    Merci à vous

    Reply

    • Frédéric LE GUEN
      09/03/2015 @ 18:49

      Erreur dans les parenthèses et dans l'écriture
      =NB.SI.ENS(E33:E51;">=10";E33:E51;"<15")

      Reply

  32. Anonyme
    29/01/2015 @ 15:52

    Dans la fonction NB.SI.ENS, est-il possible de remplacer un symbole (> = etc par la référence de la cellule correspondante Par exemple <30 s'écrirait &B28&C28 sachant que B28 contient < et C28 contient 30

    Reply

    • Frédéric LE GUEN
      29/01/2015 @ 17:48

      Oui c'est tout à fait possible :)

      Reply

      • Bernard
        29/01/2015 @ 19:21

        MERCI la formule fonctionne et va bien me faciliter le travail

  33. zramos
    26/01/2015 @ 14:45

    Bonjour,

    Je souhaite utiliser cette fonction sauf que j'arrive pas.

    J'ai les numéros de commandes depuis le mois de janvier a Décembre.

    j'ai des commandes qui commencent de janvier et finissent en Mars ou Avril.

    Ce que je souhaite faire est de prendre en considération que le 1er mois de la signature de la commande et de ne pas prendre en considération les autres mois.

    Merci de m'aider ou plus d'info si je ne suis pas claire

    Reply

  34. Christelle Paniagua
    23/01/2015 @ 20:32

    Bonsoir,

    Je souhaite utiliser la fonction =NB.SI.ENS dans une "Validation de Données", afin d'obtenir le message (Doublon)
    Mon problème :
    Colonne A = 10032002 (je l'appelle n° de section)
    Colonne B = (valeur à ne pas chercher)
    Colonne C = (valeur à ne pas chercher)
    Colonne D = (valeur à ne pas chercher)
    Colonne E = 57850 (je l'appelle n° de facture)

    Dans la colonne A on retrouve toujours les même nombre (10032002 ; 10032003 ; 10032004)
    Sauf que dans la colonne E, j'impute les numéro de facture sur chaque section.
    En règle générale, il y a 1 n° de facture pour 1 n° de section, dans ce cas je peux utiliser la formule : =NB.SI($E$2:$E$99999;E2)=1
    pour que Excel m'empeche de saisir 2 fois la même facture dans la colonne E.

    Mais sachant que je suis amener à saisir 2 fois la meme facture en colonne E sur 2 section différente en colonne A, comment puis-je demander à Excel de vérifier les doublons sur 2 colonnes différentes ?

    Je m'explique, je souhaite que Excel me dise :

    Colonne A Colonne B Colonne C Colonne D Colonne E

    10032002 57801
    10032002 57802
    10032003 57803
    10032002 57804 DOUBLON VALIDE
    10032003 57804 DOUBLON VALIDE
    10032004 57805
    10032002 57806
    10032002 57801 ERREUR DOUBLON

    C'est pourquoi j'ai pensé à la fonction =NB.SI.ENS puisqu'il y a plus d'un critère à rechercher.

    Pouvez-vous m'aider ?

    Reply

  35. Frédéric LE GUEN
    23/12/2014 @ 10:29

    Bonjour,
    Il faut faire un SI imbriqué. Vous en avez un exemple ici https://www.excel-exercice.com/fonction/condition/fonction-si/#Cas_pratique_Match_de_football pour gérer 3 événements. C'est exactement le même fonctionnement dans votre cas

    Reply

  36. M.F
    17/12/2014 @ 09:34

    Bonjour,

    Je n'arrive pas à faire la formule d'après vos exemples pourtant clair ....
    En colonne C j'ai l'âge de personnes, et en colonne G un quartier, j'aimerai compter le nombre de personnes par tranches d'âge et par quartier. Avec comme tranche d'âge 12-16 ans, 17-25 ans, 26-60 ans et + de 60 ans.

    Par exemple avoir le total de personnes dans la tranche 17-25 ans dans le quartier "Toukin"

    Merci d'avance pour votre aide.

    Reply

  37. NB
    25/11/2014 @ 13:16

    Bonjour,
    Je cherche désespérément le moyen de réaliser cette opération pour une même case (par exemple B2) mais pour plusieurs pages?
    J'ai donc une série d'onglets de même structure où dons chaque onglet, on a répondu à une question par OUI ou NON. Je voudrais pouvoir compter facilement le nombre de OUI...
    La formule "basique" =NB.SI("nom du premier onglet":"nom du dernier onglet"!B2;"oui") ne fonctionne pas :-(
    Des idées??
    Merci beaucoup.
    NB

    Reply

    • Frédéric LE GUEN
      08/12/2014 @ 20:00

      Bonjour,
      Il est tout à fait possible de faire cela mais il faut passer par une formule un peu plus complexe qui utilise les fonctions SOMMEPROD, NB.SI et INDIRECT
      En reprenant votre exemple de la cellule B2, il faut au préalable copier les noms de feuille dans des cellules (ici A12 jusqu'à A14) et appliquer la formule suivante
      =SOMMEPROD(NB.SI(INDIRECT("'"&A12:A14&"'!B2");"OUI"))
      La solution provient du site de mrexcel.com http://www.mrexcel.com/forum/excel-questions/806004-count-x-survey-1-across-mulitple-sheets.html

      Reply

  38. yaro
    21/11/2014 @ 10:20

    je voudrais ajouter un total de lettres a un total en chiffre.. nombre de P pour présent et 4.5 pour les temps partiel, je pensais utiliser NB SI est ce possible ou bien quelle est la solution

    Reply

  39. Alexandra
    17/06/2014 @ 13:54

    Bonjour,
    Comment faire pour utiliser NB.SI.ENS si on a largement plus de 255 valeurs ? J'en ai plus de 600 000...
    Penser-vous que l'on doive passer par un code type MatLab et faire un batch ?
    Merci beaucoup

    Reply

    • Frédéric LE GUEN
      17/06/2014 @ 14:39

      En lisant votre question, je comprends que vous confondez les critères de sélection avec le nombre de lignes á traiter. Vous pouvez tout á fait faire la fonction pour 600 000 lignes mais c'est certains que vous allez avoir des lenteurs pour traiter autant de lignes.

      Reply

  40. Michel
    06/04/2014 @ 09:09

    Bonjour,
    Je cherche la fonction ou la formule qui synthétise dans un tableau à part le résultat d'un NB.SI.ENS. Par exemple je veux savoir dans un autre tableau les noms des hommes mariés, ou en concubinage ou autre sans faire de filtre car le résultat, je l'exploite dans un autre onglet.
    Merci de m'aider.
    Cordialement

    Reply

    • Frédéric LE GUEN
      06/04/2014 @ 15:24

      Bonjour,
      L'exemple que je donne est exactement le problème que vous évoquer. Il suffit juste de construire votre tableau dans un onglet séparer et ça fonction. Mais attention, si vous faîtes le tableau de synthèse dans un autre classeur, cela ne marchera pas. NB.SI.ENS ne fonctionne pas avec un classeur fermé (la fonction a été conçu comme cela, volontairement)

      Reply

  41. Gildas
    13/01/2014 @ 10:03

    Bonjour Frederic,
    Jai en H5 une cellure contenant un mois de l'annee, disons Mars
    En I5 une cellure contenant un montant, disons $20
    De J4 a J16 les douzes mois de l'annee
    Ma question ; comment remplir les cases J5 a J16 , sachant que chaque case doit tenir compte du mois en H5, que les cases avant Mars doivent etre egales a 0 mais que les cases de Mars a Decembre doivent etre egale a $20??

    Merci d avance

    Reply

  42. Rachid
    21/10/2013 @ 17:48

    Je vous adore, Merci beaucoup pour ces informations ils m'ont étaient très utiles.

    Reply

  43. KOUEGO
    29/07/2013 @ 20:57

    bonjour

    j'ai ce fichier dans lequel j'aimerai utiliser la fonction somme.si.ens dans la formule: =SOMME.SI.ENS($G$2:$G$59;$B$2:$B$59;"Communicación";$F$2:$F$59;"28-09-12")
    Elle est partiellement correcte pour ce que je veut faire. Mon problème se situe au niveau de la date. Je voudrai remplacer le "jour 28" par "quelque soit" de telle sorte que la dans la plage de cellule F2 à F59 que tous les élements qui ont trait à septembre 2012 soient sélectionnés.
    Parce que dans l'état où est la formule cela ne sélectionne que les éléments du 28 septembre or je voudrai tous les éléments "Communicación" de septembre dans le cas où il y en aurait plusieurs.

    Reply

  44. Anonyme
    15/05/2013 @ 08:14

    =NB.SI.ENS(E33:E51;OU("Célibataire";"Divorcé"))
    Est ce normal que le ou de cette formule ne marche pas

    Reply

  45. menardeau
    24/04/2013 @ 08:42

    Bonjour,

    j'ai un tableau avec une plage de donnée correspondant aux mois de prélevement d'un produit

    j'ai fais un autre tableau plus synthétique où j'aimerai faire apparaître le mois que le service prélève.

    Merci de m'aider ou plus d'info si je ne suis pas clair

    Reply

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.

MICROSOFT MVP

RECHERCHE D’EMPLOI AVEC