NB.SI.ENS plus grand – plus petit

Temps de lecture 2 minutes

Rappel de l'utilisation de NB.SI.ENS

Dans l'article sur la fonction NB.SI.ENS, nous avons vu comment compter le nombre de lignes qui correspondent à un ou plusieurs critères dans différentes colonnes.

NB.SI.ENS utilise le contenu des cellules comme critère

Mais dans certaines situations, le critère de filtrage que vous souhaitez créer correspond à un test plus grand / plus petit que. Cet article va vous montrer toutes ces astuces 😃

Pour rappel, dans une fonction NB.SI.ENS, un critère s'écrit

  • entre guillemets pour du texte, comme "Homme"
  • juste en valeur pour les nombres

NB.SI.ENS Plus grand que / Plus petit que

Pour réaliser une fonction NB.SI.ENS avec un critère plus grand que, il faut écrire les critères de manières un peu différente.

  • Le signe logique du test est obligatoirement entre guillemets.

Prenons l'exemple de trouver le nombre d'hommes avec un revenu supérieur ou égal à 50000, nous écrirons la formule suivante

=NB.SI.ENS(C2:C20;"Homme";D2:D20;">=50000")

Même si le chiffre est entre guillemets, la fonction NB.SI.ENS comprend ce que vous faîtes et vous retourne le résultat dans la cellules

Mais il est aussi possible d'écrire la valeur numérique en dehors des guillemets et liant le test logique et le chiffre avec le symbole &

=NB.SI.ENS(C2:C20;"Homme";D2:D20;">="&50000)

Le critère dans une cellule

Maintenant, si la valeur que vous voulez tester est dans une cellule, vous allez écrire uniquement le test entre guillemets et la référence de la cellule hors des guillemets.

=NB.SI.ENS(C2:C20;"Homme";D2:D20;">="&J2)

La recherche NB.SI.ENS retourne les valeurs supérieurs à une valeur

NB.SI.ENS : Sélection entre 2 valeurs

Pour effectuer un critère entre 2 valeurs, vous devez écrire 2 fonctions NB.SI.ENS

  • un premier critère plus grand que
  • un deuxième critère plus petit que

Par exemple, si vous voulez connaître le nombre de personnes (hommes et femmes) qui ont un salaire compris entre 50000 et 70000, vous allez écrire :

=NB.SI.ENS(D2:D20;">=50000";D2:D20;"<=70000")

Créer un test OU avec NB.SI.ENS

Dans une fonction NB.SI.ENS tous les critères sont des opérateurs logiques ET. Pour pouvoir retourner le résultat de l'équivalent d'un OU, il faut en fait écrire deux fois la formule NB.SI.ENS pour chacun des cas à traiter.

Si nous voulons connaître le nombre d'hommes célibataires ou divorcés, nous allons d'abord faire une fonction pour dénombrer le nombre d'hommes célibataires puis une seconde fonction pour dénombrer le nombre d'hommes divorcés.

L'addition des 2 fonctions va nous donner le nombre d'hommes célibataires ou divorcés.

=NB.SI.ENS(C2:C20;"Homme";E2:E20;"Célibataire")+NB.SI.ENS(C2:C20;"Homme";E2:E20;"Divorcé")


Articles complémentaires

Voici une liste d'articles qui pourrait également vous intéresser sur le même thème.

Lien Permanent pour cet article : https://www.excel-exercice.com/nb-si-ens-plus-grand-plus-petit/


Laisser un commentaire

Your email address will not be published.

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.