NB.SI.ENS plus grand – plus petit

Temps de lecture : 2 minutes

Vous pouvez enrichir l'utilisation des fonctions NB.SI.ENS et SOMME.SI.ENS en utilisant les symboles plus grand que et plus petit que. Voici la technique.

Rappel de l'utilisation de NB.SI.ENS

La fonction NB.SI.ENS compte le nombre de lignes selon à un ou plusieurs critères dans plusieurs colonnes.

Dans l'exemple ci-dessous, nous comptons le nombre de lignes correspondant aux hommes célibataires.

NB.SI.ENS utilise le contenu des cellules comme critère

Comment construire une fonction NB.SI.ENS Plus grand que / Plus petit que

Toute l'astuce consiste à utiliser les symbols logiques.

  • = pour les égalités.
  • > plus grand que.
  • >= plus grand ou égal à.
  • < plus petit que.
  • <= plus petit ou égal à.
  • <> différent de.

Exemple 1 - Ecrire tout le critère entre guillemets

Prenons l'exemple de trouver le nombre d'hommes avec un revenu supérieur ou égal à 50000 (fichier ici)

  1. La première partie de la fonction s'écrit simplement comme ceci

=NB.SI.ENS(C2:C20;"Homme";

  1. Ensuite, on sélectionne la deuxième colonne où s'exercera le second critère

=NB.SI.ENS(C2:C20;"Homme";D2:D20;

  1. Enfin, on écrit le critère avec le symbole logique >= (plus grand ou égal à)

=NB.SI.ENS(C2:C20;"Homme";D2:D20;">=50000")

Même si le chiffre est entre guillemets, la fonction NB.SI.ENS comprend ce que vous faîtes et vous retourne le résultat dans la cellule.

Ecriture du critere de selection des salaires plus grand que 50000

Exemple 2 - Ecrire seulement le symbole entre guillemets

Mais il est aussi possible d'écrire la valeur numérique en dehors des guillemets et liant le test logique et le chiffre avec le symbole &

=NB.SI.ENS(C2:C20;"Homme";D2:D20;">="&50000)

Seul le test est ecrit entre guillemets pas la valeur

Exemple 3 - Utiliser une référence comme critère

Vous pouvez aussi réutiliser le contenu d'une cellule dans la construction de votre critère.

=NB.SI.ENS(C2:C20;"Homme";D2:D20;">="&H5)

Reference dune cellule comme critere

Sélection entre 2 valeurs

Pour effectuer un critère entre 2 valeurs, vous devez écrire 2 critères mais sur la même colonne.

  1. un premier critère plus grand que
  2. un deuxième critère plus petit que sur la même colonne

Par exemple, si vous voulez connaître le nombre de personnes (hommes et femmes) qui ont un salaire compris entre 50000 et 70000, vous allez écrire :

=NB.SI.ENS(D2:D20;">=50000";D2:D20;"<=70000")

Deux criteres sur la meme colonne

5 Comments

  1. Fred
    09/08/2022 @ 14:21

    Bonjour et merci Fred, c'est parfaitement expliqué !!
    @++
    Fred

    Reply

  2. Niamké
    16/06/2022 @ 19:10

    Merci pour l'aide... J'étais bloqué sur nb.si.ens à cause des guillemets que je ne l'avais pas mis.

    Reply

  3. Ophélie
    12/05/2022 @ 09:56

    Bonjour,

    En reprenant votre exemple, comment faire si je cherche le nombre d'homme célibataires qui ont un salaire compris entre 50000 et 70000€?

    Merci beaucoup!

    Ophélie

    Reply

    • Frédéric LE GUEN
      12/05/2022 @ 11:17

      Allez, un peu d'effort, c'est pas si dur de trouver la réponse. Prenez les éléments 1 par 1 d'abord les hommes, puis célibataires, puis un salaire >=50000 et enfin un salaire a >=70000

      Reply

  4. Emile
    28/10/2021 @ 13:31

    Bonjour,
    Bon article !
    Peut-être préciser pour le cas du OU qu"il faut que les critères ne puissent pas être vrais en même temps pour que ça se résume à un +
    Exemple : nombre de personnes hommes ou célibataires
    (je reste sur nb.si.ens même si nb.si suffirait)
    =NB.SI.ENS(E2:E20;"Célibataire")+NB.SI.ENS(C2:C20;"Homme")
    va compter 2 fois les hommes célibataires
    donc ça serait plutôt
    =NB.SI.ENS(E2:E20;"Célibataire")+NB.SI.ENS(C2:C20;"Homme")-NB.SI.ENS(C2:C20;"Homme";E2:E20;"Célibataire")

    Reply

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.

MICROSOFT MVP

RECHERCHE D’EMPLOI AVEC