«

»

Fonction MOD (Modulo)

La fonction MOD renvoie le reste d’une division.

Son utilisation est adaptée aux tests, aux formats conditionnels pour afficher des valeurs spécifiques, ou bien pour des tests de validation de données.

Si la fonction modulo ne convient pas à vos tests, peut-être que les fonctions QUOTIENT ou PGCD seront plus adaptées (voir à la fin de cet article).

Présentation de la fonction MOD

Si vous cherchez à diviser 24 par 3, le résultat “traditionnel” est de 8. Comme le résultat est juste, sans décimale, le reste est égal à 0. Dans Excel, nous écrivons la fonction de la façon suivante

 

=MOD(24;3)

 

Si maintenant nous divisons 24 par 5, le résultat de cette division n’est pas un nombre entier. Le reste de la division – ou encore le modulo – donnera comme résultat

 

 




Exemple d’application

Appliquée à des cas concrets, cette fonction s’utilise lorsque vous souhaitez tester si des nombres sont pairs (ou impairs) ou bien encore multiples de (pour des dizaines, douzaines, ….).

Par exemple, si vous voulez détecter dans une liste, les valeurs paires ou impaires, il vous suffira d’écrire

Détecter les nombres pairs

=MOD(A2,2)=0

Détecter les nombres impairs

=MOD(A2,2)<>0

 

 

Et en associant cette fonction avec la fonction SI, vous pouvez afficher le résultat dans la feuille de calculs ci-contre. (Double-cliquez dans la colonne B pour afficher les formules).

 

 

=SI(MOD(A2,2)=0, “Est Pair”, “Est Impair”)

 

 

 

 

Fonction QUOTIENT




La fonction QUOTIENT renvoie la partie entière d’une division. Ce qui revient aussi à réaliser une division à l’intérieur de la fonction TRONQUE

QUOTIENT(–14;3)=–4

TRONQUE(–14/3)=–4

Que les valeurs soient positives ou négatives, les 2 fonctions donnent des résultats similaires.

Fonction PGCD

La fonction PGCD retourne le Plus Grand Commun Diviseur (ou encore le plus grand dénominateur commun) entre plusieurs valeurs. Vous pouvez aller jusqu’à 255 valeurs mais généralement PGCD est utilisé pour comparer 2 valeurs.

Par exemple, vous voulez savoir quel est le plus grand nombre qui multiplie à la fois 120 et 48. Vous allez écrire :

=PGCD(120;48) => 24

  • 24 * 2 = 48
  • 24 * 5 = 120



Lien Permanent pour cet article : https://www.excel-exercice.com/modulo-mod/

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *