«

»

Fonction MOD (Modulo)

La fonction MOD (modulo) renvoie le reste d'une division.

Son utilisation est adaptée aux tests, aux formats conditionnels pour afficher des valeurs spécifiques, ou bien pour des tests de validation de données.

Si la fonction modulo ne convient pas à vos tests, peut-être que les fonctions QUOTIENT ou PGCD seront plus adaptées (voir à la fin de cet article).

Présentation de la fonction MOD

=MOD(nombre,diviseur)

Si vous cherchez à diviser 12 par 3, le résultat est 8. Comme le résultat est juste, sans décimale, le reste est égal à 0.

C'est ce que la fonction modulo retourne

=MOD(12;3) =>0

Si maintenant nous divisons 12 par 5, le résultat de cette division n'est pas un nombre entier.

Le reste de la division, ou encore le modulo, donnera comme résultat

=MOD(12;5) =>2

Nombre pair ou impair ?

Appliquée à des cas concrets, vous pouvez par exemple tester si des nombres sont pairs ou impairs

Test pour détecter les nombres pairs
=MOD(A2,2)=0

Test pour détecter les nombres impairs
=MOD(A2,2)<>0


Et en associant cette fonction avec la fonction SI, vous pouvez afficher le résultat dans la feuille de calculs ci-contre. (Double-cliquez dans la colonne B pour afficher les formules).

=SI(MOD(A2,2)=0, "Est Pair", "Est Impair")

Autre cas d'utilisation

La fonction MOD est très utile dans les cas suivants

  • Contrats mensuels arrivent à échéance (test sur la valeur 12)
  • Quantité atteinte pour le conditionnement (test sur le nombre d'unités par lot)
  • Anniversaire

Fonction QUOTIENT

A l'inverse, pour connaître la partie entière d'une division, il faut utiliser la fonction QUOTIENT renvoie la partie entière d’une division.

=QUOTIENT(15;2) =>7

En fait, c'est la même chose que de retourner la partie entière d'une division.

=ENT(15/2) =>7

Fonction PGCD

La fonction PGCD retourne le Plus Grand Commun Diviseur (ou encore le plus grand dénominateur commun) entre plusieurs valeurs. Vous pouvez aller jusqu’à 255 valeurs mais généralement PGCD est utilisé pour comparer 2 valeurs.

Par exemple, vous voulez savoir quel est le plus grand nombre qui multiplie à la fois 120 et 48. Vous allez écrire :

=PGCD(120;48) => 24

  • 24 * 2 = 48
  • 24 * 5 = 120

Articles complémentaires


Voici une liste d'articles qui pourrait également vous intéresser sur le même thème.

Lien Permanent pour cet article : https://www.excel-exercice.com/modulo-mod/


Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *