«

»

Intersection ligne et colonne sans formule

Il existe une astuce très peu connue, qui vous permet de trouver la cellule d’intersection d’une ligne et d’une colonne, sans formule 😎😍. Pour cela, nous allons utiliser des plages de cellules nommées.

Utiliser des cellules nommées depuis des Tables ou depuis de simples cellules, améliorent énormément la lisibilité de vos formules.

Regardez, ça marche ! 😃

Dans le classeur suivant, changez simplement les valeurs du mois (en C16) ou de l’équipement (en C17).

A chaque changement de valeur dans les menus déroulants, la formule en E16 va vous retourner la cellule de l’intersection



Nommer rapidement vos plages

Cellule_Nommee_7Pour commencer, nous devons nommer toutes les colonnes et toutes les lignes.

Ce n’est ni long ni difficile à faire 

En fait, comme toutes les lignes et colonnes du tableau ont des entêtes, un outil d’Excel va vous permettre d’utiliser ces valeurs comme nom pour vos plages.



 

 

Pour nommer rapidement vos données

  • Commencez par sélectionner tout votre tableau (avec les entêtes de vos lignes et de vos colonnes inclus)
  • Ensuite, activez le menu Formules>Depuis Sélection

Cellule_Nommee_8

  • Puis, sélectionnez les options Ligne du haut et Colonne de gauche
  • Terminez en validant.

Cellule_Nommee_9

Pour vérifier que les noms ont bien été créés, ouvrez le menu Formules > Gestionnaire de noms.

Cellule_Nommee_10



Comment utiliser ces noms dans une formule ?



Si vous ne connaissez pas bien l’utilité des cellules nommées, regardez les 2 exemples qui suivent

Pour commencer, pour connaître la somme des ventes de Janvier, il suffit d’écrire la formule suivante :

=SOMME(janvier)

Ensuite, pour trouver la moyenne des ventes de skis vous écrirez simplement :

=MOYENNE(Ski)

Comme vous le voyez, sans jamais mentionner une plage de référence (comme A1:D1), il est très facile de construire une formule avec une plage nommée

Comment trouver l’intersection ?

Maintenant que nous avons nommé toutes les colonnes et toutes les lignes, il est très facile de trouver la cellule d’intersection.

Pour savoir combien de Rollerblade ont été vendus en juillet, nous allons écrire ces 2 plages nommées séparées uniquement par un espace (c’est trop simple )

=Rollerblade juillet

Cellule_Nommee_11

Evidemment, sur un petit tableau comme celui ci, il n’est pas nécessaire de passer par des cellules nommées pour trouver la valeur qui est à l’intersection d’une ligne et d’une colonne.

Mais si vous travaillez sur très grand tableau, cette astuce peut vous faire gagner un temps précieux dans la recherche d’information.



Utilisez des menus déroulants

Pour simplifier la saisie des mois et des équipements, nous avons intégrés ces données dans 2 menus déroulants.

Seulement, avec des menus déroulants, l’astuce de l’espace ne fonctionne plus

Pour autant, il est possible de contourner le problème en insérant les noms des plages nommées dans une fonction INDIRECT, comme ceci (toujours avec l’espace entre les 2)

=INDIRECT(C16) INDIRECT(C17)



Lien Permanent pour cet article : https://www.excel-exercice.com/intersection-ligne-colonne-sans-formule/

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Vous pouvez utiliser ces balises et attributs HTML : <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

Advertisment ad adsense adlogger