Créer une somme dynamique

Temps de lecture 3 minutes

Deux méthodes pour créer une somme dynamique

Pour créer une somme dynamique avec Excel, deux méthodes sont possibles.

  • La méthode la plus simple c'est d'intégrer vos données dans un Tableau
  • L'autre méthode consiste à concevoir une formule plus complexe mais qui calcule la somme des données à la cellule près.

Insérer vos données dans un Tableau

L'outil Tableau est un outil assez peu utilisé au quotidien et c'est bien dommage car il possède beaucoup de fonctionnalités très utiles

C'est ce dernier point qui nous intéresse ici et cela se construit très simplement en intégrant le nom de la colonne a additionner dans la fonction SOMME.

=SOMME(NomTableau[NomColonne])

Somme dynamique dans un Tableau

La mise en oeuvre de cette formule est extrêmement simple

  1. Insérer vos données dans un Tableau
  2. Créer une fonction SOMME
  3. Utilisez comme paramètre le nom de la colonne de votre Tableau

Et c'est tout 😃😎👍 L'ajout de toute nouvelles données va automatiquement adapter la dimension du Tableau et donc votre fonction SOMME additionnera toutes les cellules de la colonne.

Somme dynamique avec la fonction INDEX

Vous pouvez également construire une somme dynamique qui va vous permettre d'additionner précisément une plage de données à la cellule près.

La méthode avec un Tableau fonctionne parfaitement mais elle fait nécessairement la somme de toutes les données contenues dans une colonne.

Si vous désirez créer une somme en choisissant vous-même la plage à additionner, la construction de la formule est plus complexe.

La fonction INDEX peut retourner une référence

Dans sa forme normale, la fonction INDEX s'utilise comme la fonction RECHERCHEV, dans le sens où elle vous permet de retourner la valeur d'une cellule dans un Tableau.

Mais la fonction INDEX a une autre caractéristique c'est de renvoyer, non pas une valeur, mais la référence d'une cellule. La difficulté ici c'est d'être sûr et certain que l'écriture de sa formule INDEX est juste car il n'est pas possible de visualiser le résultat de la référence.

Retrouver la position d'une valeur

Dans notre exemple, nous souhaitons retourner de la somme en fonction de la date sélectionnée en D5.

Tout d'abord, nous devons donc trouver la position de la date dans la liste des dates de la colonne A. C'est en tout point le rôle de la fonction EQUIV.

=EQUIV($D$5;$A$2:$A$13;0)

EQUIV retourne la position d'un élément dans une liste

Intégrer EQUIV dans une fonction INDEX

Maintenant que nous sommes capable de repérer la position d'une date dans la liste, nous allons intégrer cette information dans la fonction INDEX. Pour rappel une fonction INDEX se code de la façon suivante :

=INDEX(Plage de données,position en ligne, position en colonne)

Donc pour récupérer la valeur correspondant à une date précise, il faut

  1. Appeler la fonction INDEX
  2. Sélectionner la colonne qui contient les données à récupérer (colonne B)
  3. Inscrire comme 2 paramètres de la fonction la fonction EQUIV précédente
La fonction EQUIV est incluse dans la fonction INDEX

INDEX retourne une référence

Maintenant, pour retourner non pas la valeur 3 mais la référence de la cellule, il n'y a aucune modification à apporter à la formule.

Il suffit d'intégrer exactement la même formule en tant que partie de la fonction SOMME et Excel interprétera la fonction INDEX comme référence et plus comme valeur.

=SOMME(B2:INDEX($B$2:$B$13;EQUIV($D$5;$A$2:$A$13;0)))

Maintenant, à chaque sélection d'une date, la fonction précédente retourne la somme des valeurs entre la première cellule et celle correspondant à la date sélectionnée.

Somme dynamique avec les fonction INDEX et MATCH

Articles complémentaires

Voici une liste d'articles qui pourrait également vous intéresser sur le même thème.

Lien Permanent pour cet article : https://www.excel-exercice.com/creer-une-somme-dynamique/


Laisser un commentaire

Your email address will not be published.

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.