Compter le nombre de fois qu’une lettre est présente

Temps de lecture : 2 minutes

Cet article va vous expliquer comment compter le nombre de fois qu'une lettre est présente dans une cellule

Décomposer le contenu de la cellule

En combinant la fonction STXT avec la fonction SEQUENCE, il est facile de découper une chaîne de caractères en rangeant chaque élément dans une cellule.

=STXT(A2;SEQUENCE(;NBCAR(A2));1)

Decoupage de chaque element dans une cellule

Cette technique nous a déjà servi pour comparer 2 chaînes de caractères ou pour inverser une chaîne de caractères

Effectuer un test sur chaque lettre

Maintenant, nous allons tout simplement réaliser un test logique sur chaque lettre afin de savoir si chaque élément est égale à la lettre U.

=(STXT(A2;SEQUENCE(;NBCAR(A2));1)="U")

Effectuer un test logique sur chaque lettre

Convertir VRAI FAUX en 1 et 0

Là, nous allons utiliser l'astuce du double-tiret pour convertir les résultats VRAI et FAUX en 1 et 0

Ajouter 2 tirets pour transformer le resultat de la formule

Nous aurons pu également multiplier par 1 le test logique pour obtenir le même résultat

Multiplication par 1 pour transformer le test logique

Faire la somme des 1

Et maintenant c'est tout simple, il suffit de faire la somme de la formule pour connaître le nombre de fois que la lettre est présente.

=SOMME(--(STXT(A2;SEQUENCE(;NBCAR(A2));1)="U"))

Nombre de fois que la lettre est trouvee dans la chaine de caractere

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.

MICROSOFT MVP

RECHERCHE D’EMPLOI AVEC