Date et Heure Mise en forme conditionnelle

Changer la couleur des jours fériés

Temps de lecture 3 minutes

Grâce aux mises en forme conditionnelles et à la fonction NB.SI.ENS, il est très facile de changer la couleur des jours fériés dans un calendrier.

Compter la présence de jours fériés

La technique pour afficher les jours fériés d'une couleur différentes consiste à compter le nombre de jours fériés dans une liste. Ceci s'obtient facilement avec la fonction NB.SI.ENS

La fonction NB.SI.ENS est l'une des fonctions les courantes d'Excel car elle permet de compter le nombre d'éléments contenus dans une liste.

La fonction NB.SI.ENS retourne le nombre de fois qu'un élément est trouvé dans une liste

Dans notre situation, nous allons compter si un jour férié est comptabilisé (soit 1) ou pas (soit 0).

Les jours fériés

Il y a 2 façon pour gérer une liste de jours fériés

Jours fériés fixes français

Création du test sur les jours fériés

Prenant le cas du mois de Mai en France où il y a de nombreux jours férié

Calendrier du mois de Mai 2020

Nous allons commencer par construire la formule qui va nous permettre de savoir si l'un des jours du mois de Mai appartient à la liste des jours fériés.

=NB.SI.ENS($E$3:$E$15;A4)

Quand un jour appartient à la liste des jours fériés, la valeur 1 est renvoyée.

Quand un jour appartient à la liste des jours fériés la valeur 1 est renvoyée

Maintenant, il ne nous reste plus qu'à transformer cette formule en test pour retourner VRAI quand la valeur est égale à 1.

=NB.SI.ENS($E$3:$E$15;A4)=1

Le test retourne VRAI quand le jour est férié

Créer une règle de mise en forme conditionnelle

Les mises en forme conditionnelles permettent de modifier les couleurs des cellules ou de police de caractères quand un test logique retourne VRAI.

Donc ce que nous allons faire, c'est de copier la formule qui retourne VRAI ou FAUX et de la coller comme règle.

  1. Sélectionnez les cellules contenant vos dates (A4:A14 dans notre exemple)
  2. Ouvrez le menu Accueil > Mise en forme conditionnelle > Nouvelle règle ...
Nouvelle règle de mise en forme conditionnelle
  1. Puis dans la boite de dialogue, vous sélectionnez l'option Utiliser une formule ... Puis dans la zone de texte, vous collez la formule que nous avons écrite.
Règle de mise en forme conditionnelle pour les jours fériés
  1. Pour terminer il faut attribuer une mise en forme particulière quand le test est VRAI (ici on va choisir la couleur de fond rouge)

Les jours fériés sont en orange

Maintenant, quand la date dans les cellules appartient à la liste des jours férié, la couleur de fond est orange automatiquement 😎😀

Application de la règle sur les jours fériés

Related posts

Calcul des dixièmes, centièmes et millièmes

Frédéric LE GUEN

Créer un calendrier par semaine

Frédéric LE GUEN

Nuancier de couleurs dans Excel

Frédéric LE GUEN

Laissez un commentaire

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.

Ce site utilise des cookies pour améliorer votre expérience et vos recherches. Nous pensons que vous êtes dʼaccord sur ce principe mais vous pouvez refuser cette option. Accepter Continuer

Privacy & Cookies Policy