«

»

Les cellules nommées

Les cellules nommées sont extrêmement pratiques quand vous faites référence à de nombreuses cellules ou à de nombreuses plages de calcul dans un classeur.

Grâce aux cellules nommées, vous pouvez également faire des manipulations spécifiques comme trouver la valeur d’une intersection entre une ligne et une colonne et ce, sans formule.

Principe d’une cellule nommée

Une cellule nommée est le fait d’attribuer un nom unique à la référence d’une cellule ou d’une plage de cellules.

Ainsi, plutôt que d’appeler des cellules avec leur référence (comme J45 ou encore $D$2:$D$10), il vous suffit d’appeler le nom de la cellule ou de la plage de cellules.

Votre formule marchera tout aussi bien et sera plus lisible 👍😉😎

Autre remarque importante : les explications de cet article s’appliquent également avec l’outil Table d’Excel. Ainsi, vous n’aurez pas à créer vos noms vous même, Excel le fera pour vous.



Remplacer les références absolues aux cellules

Prenons l’exemple suivant. Nous avons eu une commande en Euro et notre client a besoin de connaître la valeur en Dollar.

Le calcul de conversion est très simple à réaliser avec Excel avec les références absolues.

=E5*$C$2

cellules_nommees_0

Maintenant, plutôt que de bloquer la référence de la cellule C2 par des $, nous allons attribuer un nom unique à cette cellule.

Ainsi, c’est ce nom qui sera utilisé dans la formule et non plus la référence.

Créer des cellules nommées

Pour nommer une cellule il faut aller dans le menu Formule>Définir un nom

Cellule_Nommee_1

Ensuite, vous lui donnez un nom facilement identifiable (ici Dollar) et la cellule à laquelle il fait référence (la cellule C2).

La référence de la cellule ne suffit pas, il faut aussi indiquer le nom de la feuille de calcul car une cellule nommée est unique pour tout le classeur.

Cellule_Nommee_2

C’est maintenant que le fait de nommer des cellules prend tout son sens.



Pour intégrer la cellule nommée dans votre formule, il vous suffit de saisir les premières lettres du nom de votre cellule nommée pour voir l’aide en ligne vous présenter le nom à sélectionner. Appuyer sur la touche Tab pour compléter le nom.

Cellule_Nommee_3

Exercez-vous ! 😃

Le résultat dans la cellule est correct.

Maintenant, essayez de refaire les formules avec le classeur ci-dessous.

Nommer plusieurs cellules



De la même façon qu’avec une seule cellule, vous pouvez également nommer une plage de cellules.

A titre d’exemple, nous allons nommer toutes les ventes hors taxe avec le nom Vente_Hors_TVA

  1. Cellule_Nommee_5Activez le menu Formules > Définir Noms
  2. Dans la zone nom inscrivez Vente_Hors_TVA
  3. Dans la zone fait référence à, inscrivez la plage de cellules =’Cellule nommée’!$D$5:$D$9
  4. Validez

 

 

 

Ensuite, pour calculer la somme de vos ventes hors taxes, il vous suffit d’écrire la formule suivante:

=SOMME(Vente_Hors_TVA)

Cellule_Nommee_6

Les plages nommées sont surtout intéressantes quand vous travaillez avec de grandes plages de données.

Lien Permanent pour cet article : https://www.excel-exercice.com/cellules-nommees/

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *