Statistiques

Trouver la valeur la plus fréquente

Temps de lecture 3 minutes

Parmi les 520 fonctions d'Excel, la fonction MODE n'est pas la plus connue mais elle est parfaite pour trouver la plus fréquente dans vos données

Fonction pour trouver la valeur la plus fréquente

Prenons le cas d'un sondage que vous avez réalisé avec Forms auprès de votre clientèle.

Questionnaire avec choix unique

Les réponses sont collectées dans un fichier Excel et présentées sous la forme suivante.

Résultat du questionnaire dans Excel

Bien sûr, il est impossible au premier coup d’œil de trouver quelle est la réponse la plus fréquemment données. Mais simplement en écrivant la fonction suivante, vous trouvez la réponse la plus fréquente.

=MODE.SIMPLE(Sondage[Question 1])

ou avec des références qui ne sont pas dans un tableau

=MODE.SIMPLE(B2:B13)

Valeur la plus fréquente

Et s'il y a 2 réponses ou plus?

Mais quand le nombre de réponses est réduit (comme ici seulement 5 réponses), il y a une forte possibilité que la valeur la plus fréquente soit présente plus d'une fois.

Dans une telle situation, il est préférable d'utiliser la fonction MODE.MULTIPLE. Si vous utilisez Microsoft 365 ou Excel Online, la fonction va automatiquement s'adapter au nombre de résultats car ces 2 versions savent gérer les fonctions matricielles dynamiques.

=MODE.MULTIPLE(B2:B13)

MODE.MULTIPLE retourne 3 réponses

Si vous travaillez avec une autre version, il faut faire une validation matricielle avec les touches Ctrl + Shift + Entrée

Ne pas confondre MODE et MOYENNE

Maintenant, prenons l'exemple du nombre d'articles achetés par des clients dans un supermarché.

Nombre darticles dans un caddie

Nous pouvons très facilement connaître le nombre d'articles moyens achetés par nos clients avec la fonction MOYENNE.

=MOYENNE(B2:B201) => 33,02

Mais pour savoir quel est le plus grand nombre d'articles achetés le plus souvent pour cette journée, on peut voir que le résultat est très différent.

=MODE.SIMPLE(B2:B201) => 28

Différence entre une moyenne et le mode

Comme vous le voyez, il y a une différence significative entre la moyenne et la valeur la plus fréquente (le MODE.SIMPLE). Mais on peut encore améliorer l'analyse

Combien de fois la valeur la plus fréquent est retrouvée ?

Mais combien de fois la valeur la plus élevée a été trouvée dans la liste de nombre ? Et bien pour cela, il faut utiliser la fonction NB.SI.ENS pour trouver cette information

=NB.SI.ENS(B2:B201;F3) => 8

La plus grande valeur trouvée 8 fois

Répartition des données

Mais quand le nombre de données à étudier est très éparpillé, il est préférable d'étudier la répartition des données avec la fonction FREQUENCE.

Répartitiion des valeurs sur un grand nombre de valeur

Et là, on voit que la tranche 30-40 articles correspond bien à la moyenne mais que le nombre le plus fréquent est bien présent dans la tranche 20-30.

Related posts

Somme cumulative dans Excel

Frédéric LE GUEN

Comprendre l’Ecart-Type ?

Frédéric LE GUEN

Statistique à 2 variables

Frédéric LE GUEN

Laissez un commentaire

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.