Trouver la position d’un caractère dans une cellule

Pour trouver la position de caractères dans une cellule, vous pouvez utiliser la fonction CHERCHE ou TROUVE

Paramètres de la fonction CHERCHE

La fonction CHERCHE retourne la position d'une chaîne de caractères à l'intérieur d'une cellule. La fonction nécessite 2 paramètres (et un troisième optionnel)

  • La chaîne de caractères à rechercher
  • La cellule de recherche
  • [optionnel] La position de départ de recherche

Exemple d'utilisation

Dans l'exemple suivant, vous souhaitez extraire tous les numéros de téléphone qui sont à gauche du premier caractère "/".

La plupart ont 8 caractères mais d'autres en ont davantage à cause de l'indicatif. L'important est de repérer la position du caractère "/" dans la cellule pour extraire tous les caractères à gauche de celui-ci.

Vous allez donc écrire comme formule suivante en colonne B

=CHERCHE("/";A2)

Résultat donné par la fonction CHERCHE

Pour extraire la partie gauche, nous allons utiliser la fonction GAUCHE en colonne C :

=GAUCHE(A2;CHERCHE("/";A2)-1)

Pourquoi il y a des erreurs ?

Le problème avec la fonction CHERCHE c'est que si les caractères à recherché ne sont pas dans la cellule, la fonction retourne une erreur 😤🙁

Pour contourner le problème, c'est d'inclure la fonction CHERCHE dans une fonction SIERREUR.

=SIERREUR(CHERCHE("/";A2);NBCAR(A2))

  • Si la recherche ne renvoie pas d'erreur, alors la fonction retourne le résultat de la fonction CHERCHE
  • S'il y a une erreur, alors nous affichons le nombre de caractères dans la cellule

Méthode moderne

La fonction CHERCHE est très ancienne (d'ou l'erreur en cas de recherche infructueuse). Si vous travailler avec Excel 2013, il est bien plus simple d'utiliser

  • Le remplissage instantané (Excel trouve pour vous votre sélection
  • Ou Power Query avec l'option Fractionner la colonne par délimiteur
Extraction de données avec le remplissage instantané

Différence entre CHERCHE et TROUVE ?

La fonction CHERCHE a une fonction quasiment équivalente dans Excel. Il s'agit de la fonction TROUVE.

  • TROUVE est sensible à la casse (différence entre les majuscules et minuscules)
  • CHERCHE ne fait pas de différence entre les caractères

Lien Permanent pour cet article : https://www.excel-exercice.com/trouver-la-position-dun-caractere-dans-une-cellule/


(2 commentaires)

  1. =GAUCHE(A2;CHERCHE("/";A2))-1
    sinon on a le / avec le numéro de téléphone

      • Clovis Rabut on 23/01/2019 at 10:26
      • Répondre

      Merci beaucoup.
      je me creusais la tête pour palier à cela 🙂

Laisser un commentaire

Your email address will not be published.

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.