«

»

Tableau dynamique

Nous avons présenté plusieurs fonctions pour créer des tableaux de bord. Seulement à chaque fois nous avons dû modifier manuellement les paramètres des fonctions afin d’afficher de nouveaux résultats. Dans cet article nous allons voir comment transformer ces fonctions pour qu’elles utilisent des données variables et ainsi rendre notre tableau dynamique.

Utiliser des variables comme critères

Dans tous les articles précédents nous avons écrit nos critères directement dans les paramètres de nos formules. Seulement, c’est source d’erreur si nous ne respectons pas exactement l’orthographe des critères mais de plus, si nous avons un grand nombre de données – et donc de critères possibles – nous n’allons pas tous les réécrire à la main, cela prendrait trop de temps.

Pour toutes les fonctions que nous avons vues (NB.SI.ENS, SOMME.SI.ENS, …), vous pouvez tout à fait remplacer les valeurs des critères par le contenu d’une cellule. Ainsi, si j’ai le mot “Rouge à lèvres” dans une cellule et que je veuille comptabiliser le nombre de rouges à lèvres que j’ai en stock (comme cela a été vu dans l’article sur SOMME.SI.ENS) je vais avoir l’écriture suivante

=SOMME.SI.ENS($H$2:$H$41;$B$2:$B$41;J2)

tableau-dynamique-1

Utilisation du contenu d’une cellule comme paramètre de la fonction

De même si nous avons un critère numérique, nous pouvons récupérer sa valeur directement depuis une cellule. Si par exemple nous souhaitons compter le nombre d’articles dont le stock est supérieur à 35 unités nous allons écrire la formule suivante.

=NB.SI.ENS($H$2:$H$41;”>=”&J2)

tableau-dynamique-2

Notez que le symbole logique est entre guillemets et pour joindre le symbole logique avec le contenu de la cellule, nous avons utilisé le symbole &

Extraction sans doublon

Pour construire un tableau qui va récupérer l’ensemble des noms des articles nous allons effectuer une manipulation afin de nous éviter de faire ce travail manuellement. Pour commencer, nous allons dupliquer la colonne des noms de produits. Vous pouvez vous référer à la vidéo de démonstration pour voir comment faire la manipulation à la souris (accès gratuit).

Une fois la colonne dupliquer vous pouvez aller dans le menu Données>Supprimer les doublons en indiquant que votre colonne contient des en-têtes.

tableau-dynamique-3

tableau-dynamique-4

tableau-dynamique-5

Vous récupérez ainsi la liste de tous vos produits de façon unique. Pour connaître la quantité en stock pour chacun d’eux il vous faut écrire dans la première cellule la formule suivante et de la recopier pour les autres produits

=SOMME.SI.ENS($H$2:$H$41;$B$2:$B$41;J2)

Nous sommes obligés de verrouiller les références des colonnes du stock et du nom du produit pour éviter qu’elles ne se modifient lors de la recopie vers le bas.

tableau-dynamique-7

Choisir le critère dans une liste

Vous avez également la possibilité d’intégrer comme critère des données sous forme de listes déroulantes. Pour cela nous allons utiliser le menu Données>Validation des données>Validation des données…

tableau-dynamique-8

Puis vous sélectionnez dans le menu déroulant l’option Liste. Dans notre exemple, nous avons saisi manuellement la liste de nos fournisseurs mais vous pouvez très bien récupérer cette information depuis une plage de données dans votre feuille de calcul.

tableau-dynamique-9

Il ne vous reste plus qu’à transformer votre formule pour y intégrer le nouveau critère des fournisseurs et ainsi transformer votre classeur en un tableau dynamique 🙂

tableau-dynamique-10




Lien Permanent pour cet article : https://www.excel-exercice.com/tableau-dynamique/

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Vous pouvez utiliser ces balises et attributs HTML : <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

Advertisment ad adsense adlogger