«

»

Rendre anonyme vos données

Si vous avez des données sensibles que vous souhaitez transmettre à quelqu’un pour qu’il vous aide dans l’analyse mais sans que les noms ou les adresses des personnes ne soient identifiables, vous pouvez rendre vos données anonymes facilement en utilisant la technique suivante.

Document initial

Imaginons que vous êtes journaliste et que vous recevez un jour un fichier semblable à celui-ci dans votre boite mail (toutes les données suivantes sont fictives).

Donnees_Anonyme_1

Comme vous n’êtes pas familier de l’analyse de données, vous souhaitez transmettre ces données à un tiers qui va se charger de faire l’analyse à votre place. Mais avant cela vous devez coder vos données (ou bien les rendre anonymes) pour éviter que la personne qui va travailler sur votre fichier ne connaisse la réelle identité des personnes concernées.

Extraire les données sans doublon

Tout d’abord, nous allons commencer par dupliquer la colonne contenant les noms vers la colonne H. Vous pouvez le faire avec un traditionnel copier-coller ou en utilisant la technique du déplacement de la souris avec la touche ctrl comme cela a été présenté dans cette vidéo.

Donnees_Anonyme_2

Puis, vous allez appliquer une suppression des doublons pour ne conserver qu’une seule fois le nom des personnes. Vous pouvez regarder la vidéo suivante pour voir la manipulation complète (duplication de la colonne et suppression des doublons).

Donnees_Anonyme_3

 

Le résultat devient alors le suivant :

 

 

Dans notre exemple, seul 2 noms ont été retirés de la liste mais sur une liste plus conséquente, nous aurions à coup sûr retiré beaucoup plus de doublons. D’un autre coté, nous pouvons voir que nous avons toujours 2 fois Jacky Chin car le prénom est orthographié de 2 manières différentes. Il serait tentant de corriger l’erreur dans le fichier source mais en analyse de données, il faut toujours laisser les données brutes comme elles sont. En tout état de cause, cela n’influencera pas notre travail pour rendre anonyme les données.

Rajouter les codes

En colonne I, nous allons rajouter les codes qui vont remplacer les noms d’origine.




Nous allons tout simplement écrire dans la cellule I2 la valeur NOM001. Ensuite, il nous suffira de tirer sur la poignée de recopie pour qu’automatiquement Excel augmente la valeur des chiffres. Le résultat devient alors

Donnees_Anonyme_4

Remplacer les noms par les codes

Dans les faits, nous n’allons pas réellement remplacer les noms par leur code un par un (ça serait trop long) mais nous allons utiliser la fonction RECHERCHEV pour nous aider dans cette tâche.

Nous venons de créer un tableau de référence qui associe les noms d’origine avec les codes que nous souhaitons leur attribuer. Nous allons utiliser ce tableau comme 2ème paramètre de la fonction RECHERCHEV pour retourner les données que nous attendons.




Nous allons commencer par insérer une nouvelle colonne dans notre tableau initial en colonne B (clic-droit>Insérer)

Ecrivons ensuite la formule suivante et recopions la à l’aide de la poignée de recopie :

=RECHERCHEV(A2;$I$2:$J$11;2;0)

 

Le résultat devient alors

Donnees_Anonyme_5

Remplacer les formules par les valeurs

La colonne B contient actuellement le résultat d’une formule. Il faut maintenant convertir ce résultat en valeur. Cette opération se fait très facilement à un collage spéciale en valeur.

  • Sélectionnez vos cellules de la colonne B et effectuez un simple copier.Donnees_Anonyme_6
  • Ne changez surtout pas votre sélection et activez le menu collage spécial en cliquant sur la petite flèche en dessous de l’icône Coller.
  • Dans les options proposées, sélectionnez l’icône suivante pour faire un collage en valeur

Donnees_Anonyme_8

De cette façon, toutes les formules ont été remplacées par leur valeur respective dans les cellules.

Suppression de la colonne des noms

Maintenant que la colonne contenant les noms codés n’est plus liée à la colonne des noms d’origine, nous pouvons en toute tranquillité supprimer la colonne A. Ainsi, notre document est complètement anonyme et nous pouvons l’envoyer à qui nous le souhaitons sans risque de fuite.

Pour supprimer une colonne il vous suffit de

  • Sélectionner la colonne A et de faire un clic-droit>Supprimer
  • Sélectionner la colonne A et d’appliquer le raccourci clavier Ctrl + –

L’occasion de se replonger dans les raccourcis clavier avec la touche Control

Donnees_Anonyme_9bis

Revenir au document original

Votre interlocuteur a fini son travail et il vous a restitué le document complété des informations statistiques qui vous manquaient (comme par exemple le nombre de pays concernés, le nombre moyen de compte par client, la moyenne des avoirs détenus, …). Il est donc important maintenant de faire le processus inverse à savoir remplacer les noms codés par les noms d’origine.

Donnees_Anonyme_10

 

Là encore, nous allons utiliser la fonction RECHERCHEV pour effectuer ce travail mais au préalable, nous devons permuter les colonnes du tableau contenant les noms d’origine et les noms codés. En effet, pour pouvoir fonctionner correctement, les données à lire (le nom codé) doivent toujours être dans la première colonne du tableau de référence.

=RECHERCHEV(A2;$I$2:$J$11;2;0)
Donnees_Anonyme_11

La formule renvoie bien les données du tableau de référence qui se trouve en I2:J12

Pour finir, il ne vous reste plus qu’à convertir des données de la colonne B en valeur (collage spécial valeur) comme nous l’avons fait précédemment et de supprimer la colonne A pour revenir à votre document original.




Lien Permanent pour cet article : https://www.excel-exercice.com/rendre-anonyme-vos-donnees/

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Vous pouvez utiliser ces balises et attributs HTML : <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

Advertisment ad adsense adlogger