RECHERCHEX, la formule 1

Temps de lecture 3 minutes

RECHERCHEX est la nouvelle fonction de recherche dans Excel. Cette fonction n'est accessible qu'avec la version d'Office 365.

Présentation de la fonction RECHERCHEX

Cette fonction a pour objectif de combiner les avantages des fonctions RECHERCHEV et INDEX. D'où le nom RECHERCHEX

  • RECHERCHE pour RECHERCHEV
  • X pour INDEX

Tableau comparatif des 2 fonctions

RECHERCHEVINDEX
AvantageFacile à construireRecherche vers la gauche
InconvénientRecherche Exacte n'est pas l'option par défautRecherche par position et non pas par valeur

Comme vous le constatez, chacune des fonctions à ses avantages et ses inconvénients. La fonction RECHERCHEX conserve les avantages des 2 fonctions et gomme les inconvénients.

Comment s'écrit une RECHERCHEX

La fonction RECHERCHEX peut s'écrire avec 6 paramètres mais les 3 premiers sont les plus important.

  • Valeur recherchée
  • Colonne de recherche
  • Colonne à retourner
  • Valeur à retourner en cas d'erreur
  • Type de recherche (Exacte, approchante sens croissant, approchante sens décroissante)
  • Retourner la plus petite ou la plus grande valeur.

Ecrire une recherche exacte

Avec cette nouvelle fonction, il suffit seulement de 3 paramètres pour retourner une données dans un tableau de référence

  • La valeur recherchée (C2)
  • La colonne de recherche ([EmailAddress])
  • La colonne où se trouve la valeur à retourner ([Ville])

=RECHERCHEX(C2,tb_Client[EmailAddress],tb_Client[Ville])

Construction de la fonction RECHERCHEX

Ici, nous avons volontairement intégrer les données dans un tableau pour que les références des colonnes reprennent le nom des entêtes de colonne. C'est plus facile pour voir les colonnes utilisées 😉

Faire une recherche vers la gauche

Normalement, pour faire une recherche vers la gauche, il faut utiliser la fonction INDEX associée à la fonction EQUIV.

Mais avec la fonction RECHERCHEX, peu importe la position de la colonne de recherche. La fonction retournera toujours la valeur de la colonne en 3e paramètre.

Toujours à partir de l'email, pour retourner le nom de famille, il suffit d'écrire la formule suivante.

=RECHERCHEX(C2,tb_Client[EmailAddress],tb_Client[Nom]))

Recherche vers la gauche avec la fonction RECHERCHEX

Sécuriser les résultats

Cette facilité de ne sélectionner que la colonne à retourner permet de garantir l'intégrité des vos résultats. Vous pouvez librement permuter les colonnes ou rajouter des colonnes vides, sans altérer le résultat 👏😍

Message en cas d'erreur

Que vous utilisiez RECHERCHEV, INDEX ou RECHERCHEX, si la valeur recherchée n'existe pas, le résultat sera #N/A.

La fonction RECHERCHEX retourne NA quand la recherche naboutit pas

Mais laisser #N/A dans une cellule n'est pas un résultat acceptable. Mais en renseignant le 4e paramètre de la fonction, vous pouvez indiquer le résultat à renvoyer en cas d'erreur dans la recherche.

Le quatrième paramètre de RECHERCHEX gère le message en cas derreur

Retourner plus d'une colonne

RECHERCHEX fait partie des nouvelles fonctions de Microsoft 365. Et parmi ces fonctions, il y a les fonctions matricielles dynamiques. Une fonction matricielle c'est une fonction qui retourne un résultat dans plusieurs cellules.

Appliqué à la fonction RECHERCHEX, il vous suffit d'indiquer plusieurs colonnes contiguës pour retourner plusieurs résultats avec la même formule.

=RECHERCHEX(C2;tb_Client[EmailAddress];tb_Client[[Nom]:[Prénom]])

REXHERCHEX retourne peut retourner plus dune colonne

Articles liés

Voici une liste d'articles qui pourrait également vous intéresser sur le même thème.

Lien Permanent pour cet article : https://www.excel-exercice.com/recherchex-la-formule-1/

Laisser un commentaire

Your email address will not be published.

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.