Courantes Nouveautés Recherche

RECHERCHEX, la formule 1

Temps de lecture 3 minutes

RECHERCHEX est la nouvelle fonction de recherche dans Excel. Cette fonction n'est accessible qu'avec la version d'Office 365.

Présentation de la fonction RECHERCHEX

Cette fonction a pour objectif de combiner les avantages des fonctions RECHERCHEV et INDEX. D'où le nom RECHERCHEX

  • RECHERCHE pour RECHERCHEV
  • X pour INDEX

Tableau comparatif des 2 fonctions

RECHERCHEVINDEX
AvantageFacile à construireRecherche vers la gauche
InconvénientRecherche Exacte n'est pas l'option par défautRecherche par position et non pas par valeur

Comme vous le constatez, chacune des fonctions à ses avantages et ses inconvénients. La fonction RECHERCHEX conserve les avantages des 2 fonctions et gomme les inconvénients.

Comment s'écrit une RECHERCHEX

La fonction RECHERCHEX peut s'écrire avec 6 paramètres mais les 3 premiers sont les plus important.

  • Valeur recherchée
  • Colonne de recherche
  • Colonne à retourner
  • Valeur à retourner en cas d'erreur
  • Type de recherche (Exacte, approchante sens croissant, approchante sens décroissante)
  • Retourner la plus petite ou la plus grande valeur.

Ecrire une recherche exacte

Avec cette nouvelle fonction, il suffit seulement de 3 paramètres pour retourner une données dans un tableau de référence

  • La valeur recherchée (C2)
  • La colonne de recherche ([EmailAddress])
  • La colonne où se trouve la valeur à retourner ([Ville])

=RECHERCHEX(C2,tb_Client[EmailAddress],tb_Client[Ville])

Construction de la fonction RECHERCHEX

Ici, nous avons volontairement intégrer les données dans un tableau pour que les références des colonnes reprennent le nom des entêtes de colonne. C'est plus facile pour voir les colonnes utilisées 😉

Faire une recherche vers la gauche

Normalement, pour faire une recherche vers la gauche, il faut utiliser la fonction INDEX associée à la fonction EQUIV.

Mais avec la fonction RECHERCHEX, peu importe la position de la colonne de recherche. La fonction retournera toujours la valeur de la colonne en 3e paramètre.

Toujours à partir de l'email, pour retourner le nom de famille, il suffit d'écrire la formule suivante.

=RECHERCHEX(C2,tb_Client[EmailAddress],tb_Client[Nom]))

Recherche vers la gauche avec la fonction RECHERCHEX

Sécuriser les résultats

Cette facilité de ne sélectionner que la colonne à retourner permet de garantir l'intégrité des vos résultats. Vous pouvez librement permuter les colonnes ou rajouter des colonnes vides, sans altérer le résultat 👏😍

Message en cas d'erreur

Que vous utilisiez RECHERCHEV, INDEX ou RECHERCHEX, si la valeur recherchée n'existe pas, le résultat sera #N/A.

La fonction RECHERCHEX retourne NA quand la recherche naboutit pas

Mais laisser #N/A dans une cellule n'est pas un résultat acceptable. Mais en renseignant le 4e paramètre de la fonction, vous pouvez indiquer le résultat à renvoyer en cas d'erreur dans la recherche.

Le quatrième paramètre de RECHERCHEX gère le message en cas derreur

Retourner plus d'une colonne

RECHERCHEX fait partie des nouvelles fonctions de Microsoft 365. Et parmi ces fonctions, il y a les fonctions matricielles dynamiques. Une fonction matricielle c'est une fonction qui retourne un résultat dans plusieurs cellules.

Appliqué à la fonction RECHERCHEX, il vous suffit d'indiquer plusieurs colonnes contiguës pour retourner plusieurs résultats avec la même formule.

=RECHERCHEX(C2;tb_Client[EmailAddress];tb_Client[[Nom]:[Prénom]])

REXHERCHEX retourne peut retourner plus dune colonne

Related posts

RECHERCHEV retourne plusieurs lignes

Frédéric LE GUEN

Devenir Office Insider

Frédéric LE GUEN

Taux de change monétaire dans Excel

Frédéric LE GUEN

4 commentaires

Charles Tosi 03/10/2020 at 22:46

Bonjour
Aprés avoir transpiré sur Recherchev qui m'a rendu d'énormes services, je découvre Recherchex qui doit me permettre de faire enfin ce que je voulais faire.
Courbe d'apprentissage un peu raide mais on y arrive.
la fonction d'expansion qui doit permettre de retrouver plusieurs cellules à la fois serait certainement la plus intéressante si elle marchait. Toutes mes tentatives se sont soldées par un #EPARS! .
Il semble que personne sur le web soit en mesure de donner une explication et/ou une solution à ce message. j'ai pris la précaution de tester la formule sur un tableau vierge avec donc plein d'espace mais rien n'y fait.
je me retourne donc vers vous dans l'espoir qur vous m'apportiez une réponse à ce problème.
voici une de mes formules qui devrait me permettre de retrouver le contenu de 2 colonnes
:
=RECHERCHEX($B143;$A$2:$A$133;B$2:C$133;;)
Merci d'avance pour votre aide

Répondre
Frédéric LE GUEN 04/10/2020 at 10:07

Bonjour,
Alors pour EPARS, j'ai déjà écrit un article sur ce sujet depuis plusieurs mois car je sais que c'est un problème pour bcp de personnes. Mais c'est aussi une bonne nouvelle car cela indique que vous travaillez avec une version d'Excel qui comprends les fonctions matricielles dynamiques. Et pour renvoyer plusieurs lignes comme vous le souhaitez, il y a la fonction FILTRE qui fait ça très facilement

Répondre
PRUM Mara 23/10/2020 at 10:19

Bonjour
après avoir eu des difficultés avec mes rechercheV
voici ce que j'ai trouvé sur le net après beaucoup de recherche
exemple :
=recherchev(@xxxxx;xxxxx;2;0)
lorsque je ne mets pas le @ j'ai l'erreur EPARS

Répondre
Frédéric LE GUEN 23/10/2020 at 11:32

Je ne comprends pas trop votre message, ça concerne RECHERCHEX, RECHERCHEV ou l'Erreur EPARS ?

Répondre

Laissez un commentaire

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.

Ce site utilise des cookies pour améliorer votre expérience et vos recherches. Nous pensons que vous êtes dʼaccord sur ce principe mais vous pouvez refuser cette option. Accepter Continuer

Privacy & Cookies Policy