Matricielles Power Query Recherche

RECHERCHEV sur 2 colonnes

Temps de lecture 2 minutes

Cet article va vous présenter 2 techniques pour réaliser une recherche en se basant sur le contenu de 2 colonnes.

RECHERCHEV n'est pas conçu pour

Pour effectuer une recherche en se basant sur un identifiant présent dans une seule colonne, comme un code produit, un code employé, ... vous pouvez utiliser, soit la fonction RECHERCHEV ou encore RECHERCHEX.

Le principe de la fonction RECHERCHEV c'est de se baser sur le contenu de la première colonne, toujours, pour repérer la ligne recherchée.

Donc, compte-tenu de sa construction, RECHERCHEV ne permet pas une rechercher sur 2 colonnes. Le seul moyen serait de "bricoler" une colonne intermédiaire pour concaténer le contenu de 2 colonnes. Cette solution n'est vraiment pas bonne car ON NE TOUCHE JAMAIS A UN TABLEAU DE REFERENCE.

Pourquoi RECHERCHEX est mieux

La fonction RECHERCHEX fait partie des nouvelles fonctions accessibles seulement avec Microsoft 365 et Excel Online.

Cette fonction améliore grandement les manques de la fonction RECHERCHEV. Comme notamment la possibilité de construire une recherche sur 2 colonnes 😉

Exemple d'identifiant sur 2 colonnes

Nous allons prendre la situation suivante ou nous avons le tableau avec

  • les codes employés
  • les dates de présence et le temps travaillé pour chaque journée.

Nous voulons retourner le temps travaillé sur une journée pour un employé. Donc nous devons nous faire la recherche sur les colonnes Code Employé et Date.

Tableau de données sans identifiant unique 1

Construction de la formule RECHERCHEX pour rechercher sur 2 colonnes

Etape 1 : Construire le premier paramètre avec 2 cellules

Nous allons tout d'abord construire notre identifiant en prenant le contenu des cellules G2 et G3 avec le symbole de concaténation &

=RECHERCHEX(G2&G3;

Le premier paramètre de la fonction RECHERCHEX est constitué de 2 cellules

Etape 2 : Construire le tableau de recherche

Maintenant, nous allons construire notre "tableau de référence" en concaténant les colonnes C et A 😮👍

=RECHERCHEX(G2&G3;$C$2:$C$31&$A$2:$A$31

Construction du tableau de recherche avec 2 colonnes

Seulement, ici, il faut bien respecter l'ordre de construction de la clé et du tableau de recherche

  • L'ordre de la clé c'est Date + Code Employé
  • La construction du tableau doit aussi respecter le même ordre. D'où l'association des colonnes C et A (dans cet ordre).

La construction du tableau de référence en mémoire n'est possible qu'avec l'interprétation des fonctions matricielles dynamiques. C'est pour cela que cette technique n'est possible qu'avec Microsoft 365.

Etape 3 : Ajouter la colonne à retourner.

Il ne reste plus qu'à indiquer la colonne à retourner et la fonction est terminée 😀👍

=RECHERCHEX(G2&G3;$C$2:$C$31&$A$2:$A$31;$D$2:$D$31)

Ajout de la colonne à retourner par la fonction RECHERCHEX

Related posts

Formule pour séparer un texte sur un délimiteur

Frédéric LE GUEN

RECHERCHEV retourne plusieurs lignes

Frédéric LE GUEN

Menu déroulant avec saisie semi-automatique

Frédéric LE GUEN

Laissez un commentaire

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.