Matricielles Recherche

Rechercher sur plusieurs colonnes comme critère

Temps de lecture 2 minutes

La fonction RECHERCHEX est la seule fonction qui vous permette de faire une recherche sur plusieurs colonnes comme critère de recherche dans Excel.

C'est quoi la fonction RECHERCHEX ?

La fonction RECHERCHEX fait partie des nouvelles fonctions accessibles seulement avec Microsoft 365 et Excel Online.

Cette fonction corrige certains des problèmes de la traditionnelle fonction RECHERCHEV. Comme par exemple le fait d'être obligé de faire une recherche sur la première colonne de votre table de référence.

Recherche vers la gauche avec la fonction RECHERCHEX

Mais aussi cette fonction peut se construire pour faire une recherche avec plusieurs colonnes comme critère de recherche.

Tableau sans identifiant unique

Nous allons prendre la situation suivante ou nous avons le tableau des employés avec leur date de présence et le temps travaillé pour chaque journée.

Nous voulons retrouvé pour le couple Code Employé et Date, le temps travaillé.

Tableau de données sans identifiant unique 1

Construction de la formule RECHERCHEX pour rechercher sur plusieurs colonnes

Etape 1 : Construire le premier paramètre avec 2 cellules

Nous allons tout d'abord construire un identifiant en prenant le contenu des cellules G2 et G3 avec le symbole de concaténation &

=RECHERCHEX(G2&G3

Le premier paramètre de la fonction RECHERCHEX est constitué de 2 cellules

Etape 2 : Construire le tableau de recherche

Comme nous devons effectuer une recherche sur 2 colonnes, nous allons pouvoir construire notre tableau de recherche toujours avec le symbole &

=RECHERCHEX(G2&G3;$C$2:$C$31&$A$2:$A$31

Construction du tableau de recherche avec 2 colonnes

Seulement, ici, il faut bien respecter l'ordre de construction de la clé et du tableau de recherche

  • L'ordre de la clé c'est Date + Code Employé
  • La construction du tableau doit aussi respecter le même ordre. D'où l'association des colonnes C et A (dans cet ordre).

La construction d'un tableau en mémoire n'est possible qu'avec l'interprétation des fonctions matricielles dynamiques. C'est pour cela que cette technique n'est possible qu'avec Microsoft 365.

Etape 3 : Ajouter la colonne à retourner.

Il ne reste plus qu'à indiquer la colonne à retourner et la fonction est écrite 😀👍

=RECHERCHEX(G2&G3;$C$2:$C$31&$A$2:$A$31;$D$2:$D$31)

Ajout de la colonne à retourner par la fonction RECHERCHEX

Remplacer les données à saisir par des menus déroulants

Nous pouvons améliorer la présentation de notre tableau en remplaçant les cellules G2 et G3 par des menus déroulants.

Et tant qu'à faire, comme nous travaillons sur une version de Microsoft 365, nous pouvons construire des menus déroulants avec la fonction UNIQUE

Menu déroulant avec une liste de valeurs disctinctes sans vide

Related posts

Accélérer la fonction RECHERCHEV

Frédéric LE GUEN

Créer un calendrier par semaine

Frédéric LE GUEN

Menu déroulant dépendant

Frédéric LE GUEN

Laissez un commentaire

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.

Ce site utilise des cookies pour améliorer votre expérience et vos recherches. Nous pensons que vous êtes dʼaccord sur ce principe mais vous pouvez refuser cette option. Accepter Continuer

Privacy & Cookies Policy