Plusieurs taux de TVA

Temps de lecture : 2 minutes

Cet article va vous expliquer comment gérer un rapport avec plusieurs taux de TVA.

Pourquoi il y a plusieurs taux

Selon la nature des produits, la taxe à appliquer peut être différente

  • Taxe sur les biens courants
  • Taxe sur les produits alimentaires
  • Taxe sur les biens culturels
  • .....

Donc, selon la nature de votre activité, vous serez peut-être amené à gérer plusieurs taux de TVA.

Calcul de TVA simple

Dans la plus part des cas, vous n'aurez qu'un seul taux de TVA à gérer (facile 😁👍). Ce point a été vu dans cet article ou encore dans l'exercice en ligne suivant.

Exercice

La formule qui permet de calculer un prix avec taxe s'obtient avec la formule suivante

=prix*(1+taux)

Comment gérer plusieurs taux de TVA

Maintenant, si nous devons gérer plusieurs taux de TVA, il faut remplacer la variable du taux par une formule qui va récupérer le taux dans un tableau de référence.

Dans le document suivant, nous avons un tableau qui retrace les différents taux de TVA. Chaque taux est identifié par un code unique (1, 2 ou 3 dans notre exemple).

Tableau a plusieurs niveau de TVA

Avec la fonction RECHERCHEV nous allons rechercher l'identifiant du taux de TVA et l'incorporer dans le tableau principal.

La formule dans notre exemple est :

=RECHERCHEV(B2;$G$3:$I$5;3;0)

Formule pour recuperer le taux de TVA selon la categorie

Ou bien, avec la fonction RECHERCHEX (qui est plus simple à manipuler 😉)

=RECHERCHEX(B2;$G$3:$G$5;$I$3:$I$5)

Formule RECHERCHEX pour etourner le taux de TVA

Maintenant pour calculer le prix TTC de nos produits en fonction des différents niveaux de taxe, la formule devient :

=C2*(1+RECHERCHEX(B2;$G$3:$G$5;$I$3:$I$5))

Formule du prix TTC avec plusieurs niveaus de TVA

Vous trouverez des informations complémentaires sur le calcul de pourcentages sur le site de Microsoft.

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée.

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.

MICROSOFT MVP

RECHERCHE D’EMPLOI AVEC

Back to top