Fonction NB.SI

La fonction NB.SI vous permet de compter le nombre de fois qu'un mot, une date, une valeur est présent dans une colonne.

Présentation de la fonction NB.SI

La formule NB.SI ne nécessite que 2 paramètres pour pouvoir fonctionner

  • Une plage de données où se trouve la donnée que vous cherchez à comptabiliser
  • La donnée (ou encore le critère) à rechercher.
=NB.SI(Plage de cellules;Valeur cherchée)

La fonction NB.SI.ENS

La fonction NB.SI vous permet de faire un dénombre sur une seule colonne ce qui est vraiment très peu. Depuis la version d'Excel 2007, la fonction NB.SI.ENS a été introduite pour pouvoir effectuer un dénombrement sur 255 colonnes 😍😮😃

Le fonctionnement des 2 fonctions est rigoureusement le même. Tout dépend du nombre de colonnes sur lesquels vous voulez faire votre dénombrement.

Exemple d'application


Dans le tableau suivant, vous avez une liste d'achat de matériel et vous voulez savoir combien de fois vous avez acheté des crayons.

 

 

 

 

 

 

 

Comme vous le constatez sur l'image, nous avons 4 fois le mot Crayon dans la liste ; c'est cette valeur que nous souhaitons voir s'afficher en B15. Nous allons alors écrire la formule suivante

 

=NB.SI(B3:B12;"Crayon")

 

 

 

 

 

Utilisation d'une référence comme critère

Maintenant si au lieu de saisir le nom de la donnée à rechercher vous préférez récupérer la valeur d'une cellule, vous écrirez alors une formule comme ceci.

Ici nous récupérons la valeur en réutilisant la référence de la cellule.

=NB.SI(B3:B12;A15)

 

Il est impératif que la valeur recherchée dans le tableau soit identique à celles du tableau. ⚠⚠⚠

Dans l'exemple ci-contre, le premier mot "Crayon" commence par un espace et n'est donc pas comptabilisé 😣😡

Par contre, le dernier ne commence pas par une majuscule et pourtant, il a été compté. La fonction NB.SI ne tient pas compte de la casse.

 


 

 

 

 

Exercez-vous sur l'exercice ci-dessous en écrivant la formule en B15 pour trouver le nombre de Gomme présente en colonne B (saisie directement dans la feuille de calculs Excel ci-contre 😉😎)

=NB.SI(B3:B12;A15)


 

 

 

 

 

 

 

Plus grand que / Plus petit que

Si vous souhaitez compter le nombre d'éléments plus grand (ou plus petit) qu'une certaine valeur, il vous suffit d'écrire comme second paramètre un test logique (comme >100, >=100, <50, ...).

Pour connaître l'ensemble des tests logiques, reportez-vous à la page suivante.

Par exemple, si vous voulez connaître le nombre de commande d'une quantité supérieure à 80 unités, vous écrirez en cellule B15 la formule suivante

=NB.SI(C3:C12;">=80")

 

 

Comme vous le constatez, tout comme pour du texte, le test doit être mis entre guillemets si vous écrivez la valeur en dur.

NB_SI_6Si vous souhaitez mettre la valeur à tester en paramètre, il faut cette fois, écrire le test avec le symbole & pour séparer le test, écrit entre guillemets, et la valeur en cellule A15

=NB.SI(C3:C12,">="&A15)

 

 

 

 

 

 

Articles complémentaires


Voici une liste d'articles qui pourrait également vous intéresser sur le même thème.

Lien Permanent pour cet article : https://www.excel-exercice.com/nb-si/


(13 commentaires)

Passer au formulaire de commentaire

  1. Bonjour et merci pour ces explications car je fais ce calcul sur mon jeu de donnée mais j'ai vu dans un mémoire une personne à utiliser cette fonction : NB.SI($E218:$ET218;"<200") et moi je pense que cette cette personne veut compter le nombre de fois où il a obtenu des valeurs inférieur à 200. Est ce bien le cas? Merci d'avance de votre réponse

    1. Colonne ET, vous êtes sûre ?
      Sinon allez voir l'exemple sur la fonction NB.SI.ENS, j'explique exactement ce point

  2. E n'arrive pas à faure NB.SI(B2-B11;"<"&2001/10)

  3. j'ai essayé ceci mais ça ne marche pas =NB.SI( O2:O134; SI(A134="";I134=""))

  4. bonjour, pourrai savoir quel formule utilisé pour compter le nombre de 0 sur une colonne a (qui contient ou 1 ou 0) en isolant les lignes vierges qui affiche 0 à cause d'une formule qui est en rapport avec deux autres colonnes.

  5. Je rencontre un problème avec la formule suivante:

    =SI(NB.SI(C11;"*HAHA*");"GOOD";"BAD")

    Cette formule permet d'afficher "GOOD" ou "BAD" si le texte "HAHA" est présent dans une cellule C11.
    Par exemple: Si dans C11 on a "HAHA c'est très drôle", alors ma cellule avec ma formule sortira "GOOD".

    Le problème c'est que je suis obligé d'indiquer dans la formule le terme exacte ("HAHA") que souhaite rechercher.
    Comment modifier cette formule pour rechercher un terme présent dans une autre cellule, sans avoir besoin d'indiquer "HAHA" dans la formule ?

    Exemple: J'ai une cellule A1 qui contient me mot "HAHA".

    J'aimerais faire une formule comme ceci:

    =SI(NB.SI(C11;"*valeur dans la cellule A1*");"GOOD";"BAD")

    Cette formule ne marche pas...comment faire ?

    1. Il ne faut pas utiliser la fonction NB.SI mais seulement la fonction SI !

      =SI(C11=A1;"GOOD";"BAD")

  6. Bonjour
    L'exemple =NB.SI(B3:B12;A15) montre comment faire référence à la valeur d'une cellule mais la recette ne marche pas avec l'exemple suivant ou le test se fait avec l'opérateur "<" Y a-t-il une solution et laquelle ?
    Merci d'avance

    1. Bonjour,
      Je viens de compléter l'article avec un exemple qui vous explique comment faire un test en utilisant une valeur inscrite dans une cellule au lieu de la mettre en dur dans la formule.

    • bial excel on 09/01/2015 at 21:56
    • Répondre

    merci je vai les cour advance

  7. le plus grand avec la formule max par exemple : =Max(c2:c20)
    le plus petit avec la formule Min par exemple : =Min(c2:c15)

  8. Peut-on faire un "Plus grand que / Plus petit que" avec le nombre inscrit dans une cellule?
    Si oui comment?
    Merci

  9. c'est genial merci

Laisser un commentaire

Your email address will not be published.