NB.SI.ENS – Critère partiel

Quand vous utilisez les fonctions NB.SI.ENS ou SOMME.SI.ENS, généralement vous spécifiez comme critère, un nom ou une valeur précise.

Mais il est également possible d'indiquer comme critère de recherche une partie d'un nom grâce aux méta-caractères.

Utilisation des méta-caractères

En informatique, pour effectuer une recherche partielle sur un terme, on utilise des métacaractères. Et il y en a 2 :

  • L'* pour remplacer tout ou partie d'une chaîne de caractère
  • Le ? pour remplacer un seul caractère

Pour être honnête, le symbole ? n'est jamais utilisé par contre, le symbole * est vraiment très utile.

Le symbole * permet de remplacer tout ou partie d'une chaîne de caractères comme nous allons le voir dans les exemples.

Application dans NB.SI.ENS

Critère sur le début d'un mot

Si vous voulez compter le nombre d'hommes qui ont un nom de famille qui commence par la lettre S, vous allez écrire la formule

=NB.SI.ENS(C2:C20;"Homme";A2:A20;"S*")

Dans notre document, les noms Same, Satake et Simpson correspondent aux critères. Sara commence par un S mais c'est une femme donc cette donnée est exclue du résultat.

Critère sur la fin d'un mot

Pour connaître le nombre de personnes qui ont un nom qui se termine par Y, vous allez écrire le critère en commençant par le symbole *

=NB.SI.ENS(A2:A20;"*Y")

Critère contenant une partie d'un mot

Pour connaitre le nombre de personnes dont le nom contient la lettre H (au début, au milieu ou à la fin du nom), la formule s'écrit de la façon suivante en utilisant 2 fois le symbole *

=NB.SI.ENS(A2:A20;"*H*")

Dans notre exemple, il y en a 3 :

  • JANJUAH (H à la fin)
  • CHAMPNEY (H au milieu)
  • CHAP (H au milieu)

Articles complémentaires


Voici une liste d'articles qui pourrait également vous intéresser sur le même thème.

Lien Permanent pour cet article : https://www.excel-exercice.com/nb-si-ens-critere-partiel/


Laisser un commentaire

Your email address will not be published.