Astuces Graphiques

Minimum et Maximum dans un graphique

Temps de lecture 3 minutes

Cet article va vous expliquer comment faire ressortir le maximum et minimum dans un graphique avec une couleur différente

Graphique avec minimum et maximum

Données de base

Pour illustrer cet article, nous allons partir des relevés de température de la ville de Grenoble puis d'insérer un graphique en barre verticale.

Graphique en barre sans minimum ni maximum

Méthodologie

La technique pour afficher le minimum et le maximum d'une couleur différente dans un graphique, c'est de construire 2 nouvelles séries de données.

Ajout de 2 series au donnees initiales

Pour chacune de ces colonnes, nous n'allons inscrire qu'une seule valeur

  • Le minimum quand cette valeur est trouvée
  • Le maximum quand cette valeur est trouvée

Formule pour la série du minimum

Pour ramener le minimum quand cette valeur est trouvée, il suffit de construire un test logique de la façon suivante

=B2=MIN($B$2:$B$31)

Et quand ce test retourne VRAI, ça signifie que le minimum de la série a été trouvée. Dans ce cas, on retourne juste la valeur qui correspond au minimum, sinon, on indique 0. Avec la fonction SI, cela s'écrit de la façon suivante

=SI(B2=MIN($B$2:$B$31);B2;0)

Formule pour construire la serie minimum

Formule pour la série du maximum

De la même façon, nous allons construire un autre test dans une autre colonne pour retourner seulement la valeur maximale.

=SI(B2=MAX($B$2:$B$31);B2;0)

Formule pour construire la serie maximum

Ajout des séries dans le graphique

Maintenant que nous avons construit ces 2 séries, il faut les rajouter dans le graphique en barre. Et pour cela, il suffit de suivre la technique suivante par copier-coller pour chacune des séries

Astuce Copier une série dans un graphique

Changer le paramètre de superposition des barres

Mais il y a un problème, les barres de ces 3 séries ne sont pas superposées mais les unes à coté des autres

Barres non superposees

Pour corriger cela il suffit

  • De double-cliquer sur l'une des barres des séries pour ouvrir le panneau des options
  • Et changer la valeur de la superposition à 100% de superposition
Superposition des series

De cette façon, vos courbes se trouvent superposées les unes au-dessus des autres (fichier). Ce qui donne l'illusion de que le minimum et maximum ont une couleur différente😉👍

Graphique avec minimum et maximum

Télécharger la solution ici

Related posts

Visualisation des données sur une carte – 3D Maps

Frédéric LE GUEN

Le secret du raccourci Ctrl + D

Frédéric LE GUEN

Créer une liste de nombre automatiquement

Frédéric LE GUEN

Laissez un commentaire

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.