Les moyennes mobiles

Temps de lecture 3 minutes

Les Moyennes Mobiles sont des outils d'analyses très simples à mettre en place et qui vous permettent d'anticiper les retournements de tendances.

Importation des températures à Paris

Prenons les températures mesurées à Paris en 2018.

Pour importer facilement le fichier CSV dans Excel, le plus simple c'est d'utiliser l'outil Power Query.

Facilement, vous obtenez la liste des températures jour par jour.

Température Paris

Représentation graphique en courbe

Pour des données quotidiennes - comme des températures, des cours de bourses, les prix de l'essence - la meilleure représentation c'est un graphique en courbe.

D'ailleurs, grâce à l'outil Graphique Recommandée, le premier choix proposé, c'est un graphique en courbe qui est proposé

Graphique température Paris

Analyse de la courbe

Au premier coup d’œil, la courbe présente des valeurs basses pour les mois de Janvier, Février, Mars et à partir d'Avril, les températures remontent.

Mais quand on regarde dans le détail, on voit que sur des périodes de temps très courtes, de grosses variations peuvent intervenir. Par exemple, entre le 28 Février et 11 Mars, il y a eu une hausse de 18 degrés.

Hausse de 18 degrés

Et cette variation est tout à fait visible sur le graphique

Forte variation de température en peu de jours

Lissage des données

A chaque fois que des données sont collectées jour après jours, il est nécessaire de "gommer" les variations qui peuvent intervenir sur des courtes périodes.

C'est le cas pour des valeurs comme

  • Cours de bourse
  • Température
  • Précipitation pluviométrique
  • Prix des carburants
  • ...

Créer la première MOYENNE

Pour gommer les pics de variations quotidiennes, il faut créer une moyenne mobile. En fait, il s'agit tout simplement de faire une MOYENNE sur une période de jours donnée.

Disons que nous souhaitons lisser les pics de variations sur 10 jours. Nous allons juste créer une MOYENNE sur les 10 jours précédents

Il suffit de maintenant de créer une fonction MOYENNE sur les 10 dernières jours de températures. Et le résultat est de 6,8 degrés entre le 1er Janvier et le 10 Janvier 2018

=MOYENNE(B2:B11) => 6,8

Moyenne sur les 10 jours précédents

Astuce : Pour s'assurer de sélectionner exactement les 10 précédentes cellules, il suffit de lire le nombre de lignes sélectionnées dans l'info-bulle.

Créer les Moyennes Mobiles

Maintenant que la première moyenne a été construite, il suffit d'étendre la formule pour les autres cellules juste en effectuant un copie-coller.

Copier la Moyenne Mobile

Donc, comme la formule MOYENNE prend systématiquement les 10 dernières journées, le fait de recopier la formule pour chacune des cellules, c'est ce qu'on appelle une moyenne mobile (la moyenne change par période de 10 jours).

Le résultat sur le graphique montre une nouvelle courbe qui lisse les pics des températures sur 10 jours

Graphique avec des moyennes mobiles

Faire une moyenne sur 20 jours

Maintenant, si le nombre journées de la moyenne mobile passe de 10 à 20, cette nouvelle courbe lisse encore plus les variations

=MOYENNE(B2:B21)

Moyennes mobiles sur 20 jours

Et le résultat affiche une nouvelle courbe qui lisse encore plus les variations

Moyenne mobile 10 jours et 20 jours

Donc plus le nombre de jours (le nombre de cellules) est important, plus la moyenne mobile va "lisser" les variations quotidiennes.

Analyse chartiste

En analyse chartiste (l'analyse des courbes des cours de bourse), les moyennes mobiles sont des indicateurs élémentaires pour détecter des retournements de tendances.

Analyse chartiste moyennes mobiles

Quand une moyenne mobile de courte durée (20 jours) coupe la courbe de moyenne mobile de longue durée (50 ou 100 jours), un mouvement haussier ou baissier est à prévoir.

La moyenne mobile est également utilisée pour tracer les bandes de Bollinger.

Signaux dachat et de vente Bandes de Bollinger

Articles liés

Voici une liste d'articles qui pourrait également vous intéresser sur le même thème.

Lien Permanent pour cet article : https://www.excel-exercice.com/les-moyennes-mobiles/

Laisser un commentaire

Your email address will not be published.

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.