«

»

Fonction OUX

La fonction OUX est une nouvelle fonction conditionnelle qui correspond au OU exclusif en logique.

Son emploi est assez limité pour être honnête mais quand le besoin s’en fait sentir, elle est très utile. La fonction a été introduite depuis la version d’Excel 2013.

Présentation de la fonction OUX

En logique, il existe 2 façons de concevoir un OU

  • le OU inclusif. Un ou plusieurs de ses paramètres est vrai pour que l’ensemble du test soit vrai, c’est la fonction OU traditionnelle d’Excel
  • le OU exclusif. Un et un seul paramètre doit être VRAI pour que l’ensemble du test soit vrai, c’est la fonction OUX

La fonction OUX n’est présente dans Excel que depuis la version d’Excel 2013

Exemple

Pour mieux comprendre dans quel cas s’applique la fonction OUX, nous allons prendre l’exemple suivant.

Nous voulons embaucher des candidats qui ont au moins 4 années d’étude après leur diplôme de fin de lycée ou qui ont 4 ans, ou plus, d’expérience dans le même milieu professionnel. Par contre, nous ne pouvons pas nous permettre d’embaucher des candidats qui ont à la fois 4 années d’études, ou plus, et 4 années, ou plus, d’expérience professionnelle car ils coûteraient trop chers à la société.

Nous pouvons résumer ce problème par le schéma suivant.

  • Si le candidat à moins de 4 ans d’étude ou moins de 4 ans d’expérience (partie grise hachurée), il n’est pas retenu.
  • Si le candidat à moins de 4 ans d’expérience et plus de 4 ans d’étude (partie bleue), il est retenu
  • Si le candidat à moins de 4 ans d’étude et plus de 4 ans d’expérience (partie rouge), il est retenu
  • Si le candidat à plus de 4 ans d’étude ou plus de 4 ans d’expérience (partie mauve), il n’est pas retenu.




En colonne D, nous avons construit notre test avec la fonction OU traditionnelle. Partout où le test renvoie VRAI cela signifie que nous devrions embaucher les candidats.

=OU([@Etude]>=4,[@Experience]>=4)

(avec les références d’un tableau)

=OU(C2>=4,D2>=4)

(avec les références relatives )

Cependant, nous pouvons constater pour les lignes 6 et 9, nous ne devrions pas employer ces personnes car elles cumulent à la fois de l’expérience et un niveau d’étude trop élevés.




Voilà pourquoi, dans le cas notre exemple, nous devons utiliser la fonction OUX (ou exclusif) pour trouver les individus qui ne répondent qu’à un seul critère de validité mais pas aux deux.

=OUX(C2>=4,D2>=4)

Dans le document suivant, nous voyons maintenant que les lignes 6 et 9 sont maintenant en statut FAUX (non retenu selon nos critères).

Et donc, en écrivant ce test dans une fonction SI, nous obtenons le résultat suivant dans notre classeur.

=SI(F2;”Entretien”;”Refusé”)

A noter qu’il n’a pas été nécessaire de préciser la valeur du test dans la fonction SI. En effet, comme la colonne F contient soit VRAI, soit FAUX, en écrivant juste =SI(F2 signifie si la valeur de F2 est VRAI. Cela simplifie énormément l’écriture.




Lien Permanent pour cet article : https://www.excel-exercice.com/fonction-oux/

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Vous pouvez utiliser ces balises et attributs HTML : <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

Advertisment ad adsense adlogger