«

»

Fonction OUX

La fonction OUX est une nouvelle fonction logique qui correspond au OU exclusif

Présentation de la fonction OUX

En logique, il existe 2 façons de concevoir un OU

  • le OU inclusif. Un ou plusieurs de ses paramètres est VRAI pour que l’ensemble du test soit vrai, c’est la fonction OU traditionnelle d’Excel
  • le OU exclusif. Un et un seul paramètre doit être VRAI pour que l’ensemble du test soit vrai, c’est la nouvelle fonction OUX

La fonction OUX n’est présente dans Excel que depuis la version d’Excel 2013



Exemple d’illustration

Pour mieux comprendre dans quel cas s’applique la fonction OUX, nous allons prendre l’exemple suivant.

Nous voulons embaucher des candidats qui ont au moins 4 années d’étude après leur diplôme de fin de lycée ou qui ont 4 ans, ou plus, d’expérience dans le même milieu professionnel.

Par contre, nous ne pouvons pas nous permettre d’embaucher des candidats qui ont à la fois 4 années d’études, ou plus, et 4 années, ou plus, d’expérience professionnelle ⛔ car ils coûteraient trop chers à la compagnie.

 



 

 

 

Nous pouvons résumer ce problème par le schéma suivant.

  • 1er cas : si le candidat à moins de 4 ans d’étude ou moins de 4 ans d’expérience (partie grise hachurée), il n’est pas retenu.
  • 2e cas : si le candidat à moins de 4 ans d’expérience et plus de 4 ans d’étude (partie bleue), il est retenu
  • 3e cas : si le candidat à moins de 4 ans d’étude et plus de 4 ans d’expérience (partie rouge), il est retenu
  • 4e cas : si le candidat à plus de 4 ans d’étude ou plus de 4 ans d’expérience (partie mauve), il n’est pas retenu.


Test avec la fonction OU

Premièrement, en colonne D, nous avons construit notre test avec la fonction OU traditionnelle.

Partout où le test renvoie VRAI cela signifie que nous devrions embaucher des candidats.

=OU([@Etude]>=4,[@Experience]>=4)

(pour les références d’un tableau)

=OU(C2>=4,D2>=4)

(pour les références relatives )

Cependant, nous pouvons constater que pour les lignes 6 et 9, nous ne devrions pas employer ces personnes ⛔.

En effet, elles cumulent à la fois de l’expérience et un niveau d’étude trop élevés.

Test avec la fonction OUX

C’est pourquoi, dans notre exemple, nous devons utiliser la fonction OUX (ou exclusif). De cette façon, nous construirons un test pour trouver les individus qui ne répondent qu’à un seul critère mais pas aux 2.

=OUX(C2>=4,D2>=4)

Avec cette nouvelle formule, le résultat est différent. Nous voyons maintenant, pour les lignes 6 et 9 que le résultat est FAUX. C’est exactement ce que nous voulons.



Pour finir, en écrivant ce test dans une fonction SI, nous obtenons le résultat suivant dans notre classeur.

=SI(F2;”Entretien”;”Refusé”)

Avez-vous vu ? Il n’a pas été nécessaire de préciser la valeur du test. Si le contenu d’une cellule est VRAI ou FAUX, Excel comprend de lui-même comment interpréter le test.



Lien Permanent pour cet article : https://www.excel-exercice.com/fonction-oux/

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *