Fonction EQUIV – RECHERCHEV Dynamique

Pour rendre dynamique vos formules RECHERCHEV ou INDEX, la fonction EQUIV va vous permettre de trouver la position de vos colonnes.

Présentation de la fonction EQUIV

La fonction EQUIV est relativement simple à comprendre. Elle va retourner la position d'une valeur dans une plage de données.

Elle a besoin des éléments suivants

  • La valeur cherchée
  • Le tableau de données.  Tableau nécessairement à 1 dimension (une seule ligne ou une seule colonne)
  • Valeur exacte ou valeur approchante (valeur possible 0, 1 ou -1), exactement comme pour la fonction RECHERCHEV

Illustration : Les jours de la semaine

La façon la plus simple pour comprendre l'intérêt de la fonction EQUIV c'est de prendre la liste des jours de la semaine.

Pour tout le monde, lundi est le premier jour de la semaine, mardi le deuxième et ainsi de suite.

Mais comment le faire comprendre à Excel ? Et bien tout simplement en lui passant en paramètre le tableau complet des jours de la semaine et de lui demander quelle est la position d'un jour particulier.

=EQUIV(C1;$A$1:$A$7;0)

De cette façon, à chaque sélection d'un jour, la fonction EQUIV vous indique sa position dans la liste.

 

 

 

Maintenant si la liste des jours a un tout autre ordre, la fonction continuera de renvoyer 1 pour le premier mot de la liste.

 

 

Et ce qui marche en colonne marche avec une table en ligne également

Cas pratique : RECHERCHEV Dynamique

En soi, la fonction EQUIV seule n'est pas très intéressante. Mais en l'utilisant comme paramètre avec d'autres fonctions, on peut améliorer leur fonctionnement. C'est le cas pour la fonction RECHERCHEV

Par exemple, nous avons construit une RECHERCHEV suivante pour récupérer des informations sur la vente de nos produits

=RECHERCHEV($A8;$A$2:$E$5;3;0)

Nous allons remplacer le troisième paramètre par une fonction EQUIV pour que la recherche dépende du nom de la colonne (cellule B7). La fonction EQUIV qui va retourner la position de l'entête est :

=EQUIV(B$7;$A$1:$F$1;0)

Maintenant si nous remplaçons le troisième paramètre par cette fonction, nous avons créé une recherche dynamique.

=RECHERCHEV($A8;$A$2:$E$5;EQUIV(B$7;$A$1:$F$1;0);0)

Maintenant, il nous suffit d'écrire le nom de l'entête de colonne que nous voulons retourner et la fonction RECHERCHEV s'adapte 😃😎

Vidéo explicative

Dans la vidéo suivante, vous trouverez un nouvelle exemple d'utilisation de la fonction EQUIV.

Articles complémentaires


Voici une liste d'articles qui pourrait également vous intéresser sur le même thème.

Lien Permanent pour cet article : https://www.excel-exercice.com/fonction-equiv-recherchev-dynamique/


(2 commentaires)

  1. Bonjour,

    Comment faire de la recherche multicritère avec EQUIV

    Avec l'exemple suivant :
    une liste de produit :pomme, poire, poivron d'un coté
    leur couleur de l'autre
    et une quantité ou un prix différent

    comment faire pour retrouver la quantité ou le prix des pommes vertes par exemple

    question subsidiaire : est-ce que cela fonctionne avec un 3ème critère ?

    merci

    1. Il faut plutot passer par Power Query pour faire une recherche sur plusieurs colonnes. Il n'y a aucune fonction dans Excel qui permet de faire une recherche comme vous le souhaitez

Laisser un commentaire

Your email address will not be published.