Condition Matricielles

Extraire les éléments présents qu’une seule fois

Temps de lecture 2 minutes

Dans cet article, vous allez voir avec quelle facilité il est possible d'extraire les éléments présents d'une seule fois dans une liste de données.

La fonction UNIQUE

Si vous travaillez avec Excel 365 or Excel Online, vous avez des fonction particulières ; les fonctions matricielles dynamiques. Ces fonctions ont la particularités de retourner le résultat dans plus d'une cellule.

Parmi ces fonctions, il existe la fonction UNIQUE. Cette fonction extrait sans doublon toutes les valeurs présentes dans une colonne.

=UNIQUE(A2:A10)

Fonction UNIQUE

Mais écrite comme cela, la fonction UNIQUE renvoie aussi bien les valeurs présentes une seule fois que les valeurs en double.

Extraire les éléments présents qu'une seule fois

Maintenant, pour extraire les éléments présents qu'une seule fois, nous allons utiliser la même formule 🤨🤔

En effet, la fonction UNIQUE propose une option pour ne se focaliser QUE sur les valeurs uniques. C'est option, c'est le 3e paramètre qu'il faut positionner à VRAI.

=UNIQUE(A2:A10;;VRAI)

Extraire les elements presents quune seule fois

Résoudre le problème avec la fonction NB.SI.ENS

Si vous n'avez pas la fonction UNIQUE dans votre version d'Excel, vous pouvez malgré tout trouver les valeurs présentes une seule fois. Il suffit d'utiliser la fonction NB.SI.ENS de la façon suivante.

=NB.SI.ENS($A$2:$A$10;A2)

Formule NB.SI .ENS pour trouver les valeurs uniques

Ensuite, il suffit d'appliquer un filtre

Et ne sélectionner que la valeur 1

Ne conserver que les valeurs egales a 1

Pour ne conserver que les valeurs présentes une seule fois dans la liste.

Valeurs presentes une seule fois avec le filtre

Related posts

NB.SI.ENS plus grand – plus petit

Frédéric LE GUEN

C’est quoi #EPARS!

Frédéric LE GUEN

Fonction SOMME.SI.ENS

Frédéric LE GUEN

Laissez un commentaire

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.