Exercices avec Fonction SI

Temps de lecture 3 minutes

Cet article va vous montrer 3 situations dans lesquels la fonction SI va vous aider à analyser vos documents.

Exercice 1 : La gestion de stock

Nous voulons trouver les articles qui n'ont pas été vendu au cours du mois. Pour cela, nous allons faire un test si les ventes sont à 0.

=G2=0

Le résultat du test nous retourne VRAI ou FAUX en colonne I mais le résultat ne saute pas aux yeux 😣😕😟

C'est là où la fonction SI va intervenir. Le test sur les ventes à 0 reste le même mais on va juste indiquer ce que nous voulons afficher quand le test est VRAI ou FAUX

  • Quand le test est VRAI, on veut afficher le message "Pas de vente" (avec les guillemets car c'est du texte).
  • Quand le test est FAUX (c'est-à-dire quand des ventes ont été réalisées) nous souhaitons laisser la cellule vide.

La formule va s'écrire de la façon suivante

=SI(F2=0;"Pas de vente";"")

Grâce à la fonction SI, seules les cellules pour lesquels les ventes sont = 0, affiche un message d'alerte

Exercice 2 : Les heures supplémentaires

Dans cet exemple, la partie VRAI de la fonction SI ne va pas retourner un texte, comme dans le précédent exemple, mais le résultat d'un calcul.

Construction du test pour les heures supplémentaires

Nous allons vérifier que le nombre d'heures travaillé dans une journée (colonne D) ne dépasse pas la durée légale du travail en cellule G3.

Donc le test c'est "Est-ce que la durée travaillée est plus grande que la durée légale ?"

=D2>$G$3

Il est obligatoire d'écrire la référence à G3 entre $ pour bloquer la référence de cette cellule lors de la recopie.

Résultat quand le test est VRAI

Si la valeur de la cellule D2 est supérieure à G3, l'employé a travaillé plus que la durée légale et donc nous devons déterminer le temps supplémentaire travaillé.

Dans un tel cas de figure nous calculons la différence entre le temps travaillé et la durée légale du travail.

=SI(D2>$G$3;D2-$G$3

L'écriture finale de la fonction SI

Si l'employé a travaillé moins que la durée légale, nous n'affichons rien dans la cellule (soit "") car cela ne va pas générer de frais salariaux supplémentaires.

La formule complète s'écrit alors :

=SI(D2>$G$3;D2-$G$3;"")

fonction_si_2

Exercice 3 : Remplir les blancs

L'exemple suivant n'est pas très difficile mais est très astucieux 🧐👍

Dans le document ci-dessous, la colonne B qui contient le nom des produits a beaucoup de cellules vides.

Nous voulons remplir les vides par le contenu de la cellule précédente qui n'est pas vide.

Comment faire le test ?

Le test est très simple à écrire

=B2=""

Le "double-accolade" indique une chaîne de caractères vide dans Excel.

Que faire quand le test est VRAI ?

C'est là toute l'astuce. Si la cellule est vide (donc test Vrai) alors on prend le contenu de la ligne juste au-dessus de notre formule.

=SI(B3="";I2;

Que faire quand le test est FAUX?

Si les tests est faux, donc la cellule n'est pas vide, alors on recopie le contenu de la cellule en colonne B

=SI(B3="";I2;B3)

Vidéo explicative

Tous les exemples qui sont dans cet article sont aussi dans la vidéo


Articles complémentaires

Voici une liste d'articles qui pourrait également vous intéresser sur le même thème.

Lien Permanent pour cet article : https://www.excel-exercice.com/exercices-avec-fonction-si/


(4 commentaires)

Passer au formulaire de commentaire

  1. comment calculer un nombre de date du meme mois sur une colonne entière représentant une année 12/03/2018
    14/03/2018
    19/03/2018
    01/04/2018
    01/04/2018
    23/04/2018
    10/04/2018
    10/04/2018
    12/04/2018
    02/05/2018
    25/04/2018
    01/05/2018
    22/05/2018
    15/05/2018
    21/05/2018
    22/05/2018
    28/05/2018
    01/09/2018
    01/06/2018
    01/06/2018
    01/07/2018
    12/06/2018
    15/06/2018

  2. En effet, il y a une erreur d'1 heure à chaque résultat.
    J'imagine que c'est :
    =C2-B2-1
    Soit -1 pour l'heure du repas

  3. Bonjour,

    Comment avez-vous fait pour arriver à 7 h 50 dans la colonne total sur l'exercice des heures supplémentaires. J'aimerais bien savoir.

    Merci

    1. C'est quoi précisément votre question ? Comment faire des calculs avec des heures ?

Laisser un commentaire

Your email address will not be published.

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.