Erreur d’arrondi – Méthode des banquiers

Temps de lecture : 3 minutes

Il existe deux méthodes d'arrondi et, selon la méthode utilisée, il peut y avoir des écarts dans les résultats.

Comment arrondi-t-on avec 0,5 ?

Tout le point de départ c'est de savoir comment on arrondi quand la valeur 0,5. Doit-on arrondir à 0 ou doit-on arrondir à 1 ?

En mathématique "traditionnelle" on va dire, la réponse est toujours la même, on arrondit à la valeur supérieure, soit 1 dans notre exemple.

Mais une autre méthode, appelée l'arrondi des banquiers (banker's rounding), apporte une approche quelque peu différente.

Je le dis honnêtement, jamais je n'avais entendu parler de cette méthode lors de mes études ni lors de mes missions de consultant. C'est après une conversation avec d'autres MVP d'Excel et des développeurs de Microsoft que j'ai appris l'existence de cette méthode. La différence est tellement notable qu'il est préférable d'utiliser l'arrondi des banquiers.

C'est quoi l'arrondi des banquiers ?

Le principe c'est d'arrondir au nombre pair le plus proche.

  • 0,5 sera arrondi à 0.
  • 1,5 sera arrondi à 2.

Dans cet exemple, vous voyez la différence entre l'utilisation de la fonction ARRONDI, et la méthode d'arrondi des banquiers.

Methode de larrondi des banquiers

La fonction ARRONDI d'Excel se base sur la règle mathématique de toujours arrondir vers le nombre supérieur.

Pour obtenir l'arrondi des banquiers, on peut utiliser la fonction suivante :

=SI(MOD(B6;1)=0,5;ARRONDI.AU.MULTIPLE(B6;2);ARRONDI(C6;0))

Différence entre les 2 méthodes

Le meilleur moyen de vérifier que la deuxième méthode est plus précise est la suivante.

  1. Créer une très grande liste de nombres.
  2. Faire la somme de cette liste.

=SOMME(B6:B1000006)

  1. Appliquer la formule ARRONDI dans une autre colonne.
  2. Puis la méthode d'arrondi des banquiers dans une autre colonne.
  3. Faites la somme de ces 2 autres colonnes.
  4. Faire la différence entre la somme des nombres non arrondis avec les colonnes ayant utilisé l'une ou l'autre méthode.

Le résultat montre un écart extrêmement faible avec la méthode d'arrondi des banquiers.

Difference au niveau du resultat entre les 2 methodes darrondis

Pourquoi c'est plus précis ?

La méthode d'arrondi des banquiers est plus précise et très facile à comprendre.

L'arrondi de 0,1 c'est 0 et l'arrondi de 0,9 c'est 1. Donc on peut dire que les décimales 0,1 sont compensées par celle de 0,9 car dans 1 cas, on retranche 0,1 et dans l'autre on ajoute 0,1. Et de même pour :

  • 0,2 compensé par 0,8.
  • 0,3 compensé par 0,7.
  • 0,4 compensé par 0,6.

Mais, pour 0,5, avec la méthode mathématique traditionnelle, on ajoute toujours 0,5 mais jamais on ne le retranche.

Donc l'idée ici c'est tout simplement de contrebalancer cette augmentation permanente quand la décimale est de 0,5 pour retrancher quand le nombre est pair et augmenter quand le nombre est impair.

Méthode utilisée en VBA

Vous l'avez certainement utilisée pour la fonction Round en VBA. Et bien croyez-le ou non, c'est la méthode des banquiers qui s'applique.

Sub Test_Arrondi()
Dim i As Long
    For i = 6 To 1000006
        Cells(i, 5) = Round(Cells(i, 2), 0)
    Next
End Sub

Et le résultat est similaire à la colonne de l'arrondi des banquiers.

Resultat obtenu en VBA similaire a la methode des banquiers

Méthode utilisée avec Power Query

Et également avec Power Query, c'est la méthode de l'arrondi des banquiers qui est utilisée avec l'instruction Ajout Colonne > Arrondi > Arrondi ...

Methode darrondi utilisee par Power Query

Vous trouverez des informations complémentaires sur l'arrondi aux décimales voulues sur le site de Microsoft.

3 Comments

  1. Arnaud joseph
    13/04/2021 @ 22:37

    Pas mal du tout
    Je ne connaissais pas, merci pour l’info.

    Reply

  2. Kasel
    25/03/2021 @ 16:13

    C'est bien mais j'aimerais avoir les formules d'excel

    Reply

    • Frédéric LE GUEN
      25/03/2021 @ 16:19

      La formule est donnée dans l'article. Juste avant le paragraphe "Différence entre les 2 dméthodes"

      Reply

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.

MICROSOFT MVP

RECHERCHE D’EMPLOI AVEC