«

»

Fonction EQUIV

Pour rendre dynamique vos formules RECHERCHEV ou INDEX, vous pouvez remplacer les paramètres de positionnement par l’une des trois formules suivantes LIGNES, COLONNES ou EQUIV.

Fonctions LIGNE / COLONNE

Présentation

Les fonctions LIGNE et COLONNE retournent la valeur de la ligne ou de la colonne de la cellule active ou de la formule.

equiv-1

Valeur des cellules actives

Si vous écrivez ces fonctions sans paramètre, la valeur retournée sera celle de la ligne de la colonne dans laquelle la formule a été écrite.

 

 

 

equiv-3

En recopiant la fonction LIGNE sur plusieurs lignes, nous avons le résultat suivant

C’est la même fonction pour toutes les lignes mais elle retourne des valeurs différentes et incrémentées.

 

 

 

equiv-2

Valeur de la cellule E5

Si vous indiquez en paramètre la référence d’une cellule, la fonction LIGNE renverra le numéro de ligne de la cellule sélectionnée est la fonction COLONNE renverra le numéro de la colonne de cette cellule.



Utilisation




Donc, l’idée c’est de remplacer le 3ème paramètre de la fonction RECHERCHEV par la fonction LIGNE ou COLONNE (selon l’orientation de vos données).

De cette façon, lors de la recopie, vous n’avez plus à changer manuellement le 3ème paramètre de la fonction RECHERCHEV.

=RECHERCHEV($B$5;$A$2:$F$3;LIGNE()-4;0)

Recopier la formule du classeur intégré ci-dessous (la date de garantie). Le 3ème paramètre étant relié à la valeur de la ligne courante, nous pouvons donc en déduire le numéro de la colonne à récupérer de notre tableau de référence (double-cliquez pour faire afficher les formules).

Limites

Si les données à récupérer ne sont pas dans le même ordre que votre source, les fonctions LIGNE et COLONNE ne sont pas les fonctions à utiliser.

Pour éviter ce (gros) écueil, il est préférable d’opter pour la fonction EQUIV.

Fonction EQUIV

Présentation

La fonction EQUIV va retourner la position d’une valeur à l’intérieur d’une plage de données (une ligne ou une colonne). Elle a besoin des éléments suivants

  • La valeur cherchée
  • Les données de référence ; tableau nécessairement à 1 dimension (une seule ligne ou une seule colonne)
  • [optionnel] Valeur exacte ou valeur approchante (valeur possible 0, 1 ou -1)

En fait, la fonction EQUIV s’écrit comme la fonction RECHERCHEV à l’exception du troisième paramètre.

Utilisation

Dans le document ci-contre, vous avez en colonne A les jours de la semaine (mais pas en commençant par le lundi) . Grâce à la liste de choix, vous allez choisir l’un des jours de la semaine, la fonction EQUIV en C2 va renvoyer la position de la valeur en C1 dans la liste de la colonne A.

Vous pouvez voir la formule en double-cliquant dans la cellule C2.
=EQUIV(C1;A1;A7;0)

Le 0 est nécessaire dans cet exemple car les jours ne suivent pas d’ordre alphabétique. Alors, pour être sûr que la fonction renvoie la position d’une valeur dans une plage non triée, il faut ajouter la valeur optionnelle 0 (ou recherche exacte)

Utilisation

Appliqué à notre classeur, nous pouvons créer une seule formule, avec la fonction EQUIV en 3ème paramètres, pour que notre formule RECHERCHEV puisse être recopiée sur l’ensemble des cellules tout en changeant le numéro de colonne à retourner.

Comme vous le constatez dans le document ci-dessous, l’ordre des colonnes à retourner n’est pas le même mais cela n’est pas un soucis car la fonction EQUIV va retrouver la position de la colonne dans le document initial.

=RECHERCHEV($A9;$A$2:$F$5;EQUIV(B$8;$A$1:$F$1;0);0)

 



Lien Permanent pour cet article : https://www.excel-exercice.com/equiv/

2 pings

  1. Comment faire une RECHERCHEV vers la gauche ?

    […] Fonction EQUIV […]

  2. Excel sur son téléphone portable

    […] Fonction EQUIV […]

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Vous pouvez utiliser ces balises et attributs HTML : <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

Advertisment ad adsense adlogger