Créer un échéancier de remboursement dynamique

Temps de lecture 2 minutes

Formules pour construire un échéancier

Nous avons vu dans cet article comment concevoir un échéancier de remboursement de prêt.

Échéancier bancaire pour un prêt

Pour réaliser un tel tableau, nous nous sommes servi des fonctions CUMUL.INTER et CUMUL.PRINCPER.

Maintenant, nous allons voir comment construire le même tableau mais en rendant les périodes dynamiques.

Utilisation de la fonction SEQUENCE

La fonction SEQUENCE fait partie des nouvelles fonctions intégrées seulement dans Microsoft 365.

Pour rendre notre tableau dynamique, nous allons remplir la colonne des périodes de remboursement avec la fonction SEQUENCE et de la cellule en B4

=SEQUENCE(B4)

Comme vous le constatez dans l'image précédente, la fonction SEQUENCE n'a été écrite que dans une seule cellule mais selon la valeur de son paramètre, elle retourne le résultat dans plusieurs cellules. C'est ce que l'on appelle des fonctions matricielles dynamiques.

Construction du test logique

Dans Excel, un grand nombre de situation repose sur la construction de tests logiques.

Il y a plusieurs façon d'écrire le test dans un cas de figure pareil. Soit on teste que la cellule n'est pas vide

=D2<>""

Ou

=NON(ESTVIDE(D2))

Ou encore, on peut écrire que le contenu de la valeur dans les cellules de la colonne D sont supérieurs à 0.

=D2>0

Il ne reste plus qu'à inclure ce test dans une fonction SI pour afficher le résultat si la cellule est renseignée.

Construction de la formule de remboursement mensuel

Nous avons vu dans cet article comment construire la formule qui retourne la mensualité d'un emprunt.

Appliquée à notre document, nous allons donc écrire la formule suivante

=SI(D4>0;CUMUL.PRINCPER($B$7;$B$5;$B$3;D4;D4;0)*-1;"")

Formule pour calculer les mensualités

Et maintenant, notre tableau de remboursement est dynamique en fonction du nombre de périodes.

Création dun tableau de remboursement dynamique

Articles liés

Voici une liste d'articles qui pourrait également vous intéresser sur le même thème.

Lien Permanent pour cet article : https://www.excel-exercice.com/creer-un-echeancier-de-remboursement-dynamique/

Laisser un commentaire

Your email address will not be published.

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.