«

»

Comparer 2 colonnes

La fonction RECHERCHEV, dans sa forme principale, va récupérer des informations dans une table de référence. Mais il est possible d’utiliser la fonction RECHERCHEV d’une seconde manière pour comparer les données contenues dans deux colonnes.

Comparer 2 colonnes

comparer_2_colonnes_1Jusqu’à présent quand la fonction RECHERCHEV retournait #N/A, nous considérions que c’était une erreur. Mais en fait #N/A signifie « je n’ai pas trouvé l’élément recherché« .

Dans le cas d’une comparaison entre 2 colonnes c’est donc la valeur #N/A qui va nous intéresser car c’est ce qui va nous permettre d’identifier les éléments manquants entre les deux colonnes.

 

comparer_2_colonnes_2Pour comparer deux colonnes l’une par rapport à l’autre nous allons construire une fonction RECHERCHEV qui va interroger l’un des éléments d’une colonne pour voir s’il est présent dans la seconde colonne. La fonction va donc s’écrire de la façon suivante

=RECHERCHEV(A1;$D$1:$D$4;1;0)

Dans cette écriture, la table de référence n’est constituée que d’une seule colonne (la colonne de comparaison) et donc le 3ème critère est nécessairement égal à 1.

comparer_2_colonnes_3En recopiant la formule, nous obtenons le résultat suivant (la valeur manquante c’est la lettre c)

 

 

La fonction ESTNA




La valeur manquante est immédiatement identifiée par l’indication #N/A. Seulement, 2 éléments sont à corriger

  • la valeur N/A qui doit être transformée en un message plus explicite
  • éviter la duplication des données existantes

Ces 2 problèmes peuvent peut-être corrigés grâce à la même fonction ESTNA. Cette instruction va tout simplement tester le résultat d’une fonction RECHERCHEV et indiquer

  • VRAI : la fonction RECHERCHEV retourne #N/A
  • FAUX : la recherche a abouti à un résultat

Donc, en écrivant notre précédente formule RECHERCHEV à l’intérieur d’une fonction ESTNA, nous affichons maintenant dans la colonne les résultats VRAI ou FAUX selon que la recherche a abouti ou non.

=ESTNA(RECHERCHEV(A1;$D$1:$D$4;1;0))

comparer_2_colonnes_4

Il ne nous reste plus qu’à intégrer ce test dans une fonction SI pour personnaliser le résultat afin de ne pas laisser VRAI/FAUX dans les cellules. Nous pouvons écrire la fonction SI suivante :

=SI(ESTNA(RECHERCHEV(A1;$D$1:$D$4;1;0)); »Manquant »; » »)

comparer_2_colonnes_5

Mise en forme conditionnelle

Beaucoup d’utilisateurs n’ont pas fait la relation entre un test logique et les mises en forme conditionnelles. Pourtant dès que vous avez créé un test dans une cellule, il vous suffit de le recopier en tant que critère d’une mise en forme conditionnelle pour que celle-ci fonctionne.

Par exemple, nous allons reprendre exactement le test VRAI/FAUX réalisé avec la fonction ESTNA pour le copier en tant que règle.

comparer_2_colonnes_6Dans notre exemple

  1. Sélectionnez la colonne A
  2. Ouvrez le menu Accueil>Mise en forme conditionnelle>Nouvelle règle.
  3. Choisissez l’option Utiliser une formule pour déterminer pour quelles cellules le format sera appliqué.
  4. Dans la zone de texte, coller la formule qui nous a permis de retourner VRAI ou FAUX
  5. Changer la mise en forme en cliquant sur le bouton Format …

 

 

 

 

comparer_2_colonnes_7Et le résultat dans votre feuille de calcul colorie en rouge les cellules qui n’ont pas de valeurs identiques dans la seconde colonne 🙂

 

 


Lien Permanent pour cet article : https://www.excel-exercice.com/comparer-2-colonnes/

(2 commentaires)

  1. Juliette DL

    Bonjour Frédéric,
    j’ai appliqué la formule sauf qu’en résultat je n’ai que des N/A ..;
    où est l’erreur ?

    merci d ‘avance pour votre réponse

    1. Frédéric LE GUEN

      Bonjour,
      Avez-vous fait un test d’égalité pour savoir si le problème vient de votre formule ou de vos données ?

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Vous pouvez utiliser ces balises et attributs HTML : <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

Advertisment ad adsense adlogger