Recherche

Comparer 2 colonnes

Temps de lecture 3 minutes

Pour comparer le contenu de 2 colonnes et  afficher les données qui sont communes ou celles qui sont absentes, nous allons tout simplement utiliser la fonction RECHERCHEV une pincée de fonction ESTNA et un soupçon de fonction SI

Démo live dans un classeur 😃😍😎

Dans le classeur ci-dessous, amusez-vous à changer les valeurs de la première colonne pour voir en rouge les valeurs absentes et en blancs les valeurs présentes

Comparer 2 colonnes

Comparer 2 colonnes ça se fait très facilement avec Excel.

Tout repose sur le fait que la fonction RECHERCHEV trouve, ou pas, une valeur dans une colonne. Si vous ne connaissez pas bien la fonction RECHERCHEV, vous trouverez toutes les explications utiles dans cet article.

Pour beaucoup d'utilisateurs d'Excel,quand la fonction RECHERCHEV retourne #N/A, c'est une erreur.

Non pas du tout !  #N/A signifie "je n'ai pas trouvé l'élément recherché".

Dans le cas d'une comparaison entre 2 colonnes c'est la valeur #N/A qui va nous intéresser 😃 Ainsi, nous serons capable d'identifier les éléments manquants entre les deux colonnes 😉😉.

Etape 1 : La fonction RECHERCHEV

Commençons par écrire notre fonction RECHERCHEV et le premier élément que vous voulons rechercher. Ici, nous voulons rechercher le contenu de la cellule A1.

=RECHERCHEV(A1;

Ensuite, Nous allons vérifier que cette valeur est présente dans la colonne $D$1:$D$4 (n'oubliez pas les $ pour verrouiller les références 😉)

=RECHERCHEV(A1;$D$1:$D$4;

Puis, il faut mettre le troisième paramètre à 1 (car nous n'avons sélectionner qu'une seule colonne en deuxième paramètre)

=RECHERCHEV(A1;$D$1:$D$4;1;

Enfin 0 (pour faire une recherche exacte).

=RECHERCHEV(A1;$D$1:$D$4;1;0)

comparer_2_colonnes_2

En recopiant la formule, nous obtenons le résultat suivant (la valeur manquante c'est la lettre c)

La valeur manquante est immédiatement identifiée par l'indication #N/A mais ce n'est vraiment pas joli de conserver cette indication dans votre classeur😱😱 💔

comparer_2_colonnes_3

Etape 2 : La fonction ESTNA pour faire un test

Pour personnaliser le résultat d'une comparaison, nous allons utiliser la fonction ESTNA. La fonction va nous retourner 2 valeurs

  • VRAI : la fonction RECHERCHEV retourne #N/A
  • FAUX : la recherche a abouti à un résultat

Donc, en écrivant notre précédente formule RECHERCHEV à l'intérieur d'une fonction ESTNA, nous affichons maintenant dans la colonne les résultats VRAI ou FAUX selon que la recherche a abouti ou non.

=ESTNA(RECHERCHEV(A1;$D$1:$D$4;1;0))

Création du test pour savoir si les valeurs sont présentes ou non

Etape 3 : Terminer avec la fonction SI

Laisser VRAI ou FAUX comme résultat n'est toujours pas très visible, surtout si vous devez présenter ce document à d'autres collaborateurs.

Voilà pourquoi, nous allons intégrer ce test dans une fonction SI pour personnaliser le résultat afin de ne pas laisser VRAI/FAUX dans les cellules.

Nous pouvons écrire la fonction SI suivante :

=SI(ESTNA(RECHERCHEV(A1;$D$1:$D$4;1;0));"Manquant";"")

Intégration du test dans une fonction SI pour n'afficher que les valeurs manquantes

Changer la couleur des valeurs manquantes

Pour améliorer le rendu, nous allons reprendre le test créé pour trouver les écarts entre les colonnes et l'intégrer dans une mise en forme conditionnelle

Dans notre exemple

  1. Commencez par sélectionnez votre colonne de comparaison (ici la colonne A)
  2. Ensuite, ouvrez le menu Accueil>Mise en forme conditionnelle>Nouvelle règle.
  3. Puis, choisissez l'option Utiliser une formule pour déterminer pour quelles cellules le format sera appliqué.
  4. Dans la zone de texte, coller la formule qui nous a permis de retourner VRAI ou FAUX
  5. Terminer par votre mise en forme personnalisée en cliquant sur le bouton Format ...

Finalement, le résultat dans votre feuille de calcul ce sont des cellules en fond rouge quand la valeur n'est pas trouvée dans la seconde colonne 😍😍😍

La valeur manquante s'affiche d'une couleur différente

C'est tout de même plus compréhensif de montrer les écarts par une couleur plutôt que de laisser une formule 😊😉

Vidéo explicative

Related posts

Pourquoi RECHERCHEV retourne #N/A

Frédéric LE GUEN

Intersection ligne et colonne sans formule

Frédéric LE GUEN

Rechercher sur plusieurs colonnes comme critère

Frédéric LE GUEN

20 commentaires

A. 03/07/2019 at 09:53

Excellent tutoriel, très clair et très bien illustré.
Merci beaucoup !

Répondre
Frédéric LE GUEN 03/07/2019 at 10:01

Merci bcp

Répondre
GHISLAINE 25/06/2019 at 08:15

Super, merci. Depuis le temps que je galère pour comparer les changements

Répondre
Ibrahim 30/05/2019 at 11:35

bravo et merci beaucoup. très pratique votre cours encore merci

Répondre
MANSOUR 16/05/2019 at 10:25

TROP PROPRE, MAGNIFIQUE COURS, VOUS M'AVEZ SAUVEZ LA VIE, MERCI MERCI MERCI ET ENCORE MERCI

Répondre
PESENTI ROSSI 12/02/2019 at 12:23

Bonjour,
La formule fonctionne à merveille, merci beaucoup.
Une question, voici la structure de mon fichier :

Noms cellule A
Donnée cellule B
"manquant" cellule C
Noms cellule D (Liste de comparaison)

J'aimerais ajouter une cellule dans la colonne D à chaque fois qu'il y a "manquant" en cellule C. Est-ce possible svp?
Car à l’instanté si je masque par un filtre mes données manquantes en C pour avoir celle présente, il me masque également les données en D de la même ligne.
Exemple :
A B C D
Ligne 1 : Mr Y Mr Y
Ligne 2 : Mme X Manquant Mr Z
Ligne 3 : Mr Z Mme K
Ligne 4 : Mme K

Merci de votre aide !
Aurore

Répondre
Diawara 23/01/2019 at 14:19

Bonjour,
J'ai utilisé la formule RechercheV dans le cadre d'une analyse de base de donnée. Lorsque j'exécute la fonction, j'ai des N/A dans la colonne de réponse.
A noté que dans la plage de cellule dans laquelle, la formule doit aller chercher la valeur, il existe un même nom pour certaines valeurs:
Exemple : 90000006 AT
60000009 AT

Comment résoudre cette problème?
Je vous remercie pour votre aide.

Répondre
philippe 29/11/2018 at 20:52

bonjour,

je viens de construire une base de donnée avec Excel en VBA.
je dispose de plusieurs formulaires qui interroge la base, cependant je souhaite qu'ils apparaissent tous en sembles, afin exploiter la base sur tous les formulaires en même temps.

cordialement

Répondre
Frédéric LE GUEN 07/12/2018 at 09:59

Bonjour,
Désolé pour la réponse tardive mais je n'avais pas vu le message avant.
Comme ça, il est impossible de vous répondre. Il faudrait faire une étude de votre existant pour faire une évaluation du travail à fournir
Contactez-moi via le formulaire accessible depuis le menu pour me contacter en privé si vous voulez que je traite votre problème
Cordialement

Répondre
habib 24/10/2018 at 12:48

bonjour , veillez m'expliquer le cas ou la taille de deux colonnes sont pas egaux et une partie l'une des colonne vide, ....pourrons nous appliquer cette formule de comparaison et que donne le test sur les cases vides?

Répondre
said 16/09/2018 at 12:20

mercii

Répondre
Roland 01/08/2018 at 18:01

Bonjour,
Merci pour toutes ces informations.

J'ai un besoin un peu différent :

Je dois vérifier que 2 cellules dans 2 lignes se suivant, comportent ou non les mêmes mots, mais dans le désordre et à ce moment là ce sont des doubles et je dois supprimer 1 des 2 lignes.

Par exemple :
Ligne 1 : cellule 1 : "VINTAGE POSTER REPRINT PARIS-ALMANACH"
Ligne 2 : cellule 1 : "PARIS-ALMANACH REPRINT VINTAGE POSTER "

Tous les mots sont communs aux 2 lignes ce sont donc des doubles.

Si quelqu'un a une solution, je le remercie par avance.

Cordialement
Roland

Répondre
Deya 08/06/2018 at 10:37

Bonjour,

Je n'arrive pas à faire apparaître le texte d'origine après avoir appliqué une mise en forme conditionnelle à la fonction ESTNA. J'ai VRAI ou FAUX avec VRAI en vert mais j'aimerais qu'apparaisse le texte (l'adresse email) à la place.

Merci d'avance!

Répondre
adams 17/04/2018 at 19:00

bonjour moi j'ai une liste de recouvrement ou certain client on régler leur crédit d'autre non, je veux comparer de sorte a n'obtenir que ceux qui n'ont pas encore régler leur crédit
exemple:
client prestation montant régler reste à payer
cli1 rep 1500 0 1500
cli2 ent 2000 0 2000
cli1 rep 1500 1500 0
cli2 rep 500 0 2500

Répondre
CP 20/03/2018 at 14:03

Bonjour,
Explications très claires qui m'ont beaucoup aidée.
C'était la solution que je cherchais.
Merci beaucoup

Répondre
NSENGUMUREMYI Emmanuel 06/10/2017 at 16:15

pour moi j'ai un autre pblm, si je doit comparer deux colonnes, excel compare avec la liste que j'ai donné-1, càd:

=SI(ESTNA(RECHERCHEV(G2:G45;B1:B70713;;0));"manquant";"present") pour le premier;
=SI(ESTNA(RECHERCHEV(G3:G46;B2:B70714;;0));"manquant";"present") pour le deuxieme.

remarquer que G2 est devenu G3, ce qui fait que si l'elément recherché se trouve dans G2, la réponse est que l'elément n'est pas présent alors qu'en réalité il est.

merci de vos commentaires.

Répondre
Vanessa 08/08/2017 at 16:20

Bonjour,
J'ai le même souci dès qu'1 élément est manquant dans une colonne, toutes les valeurs suivantes sont en #N/A. Je pense que ma formule tient compte de l'ordre alphabétique, mais puisque la valeur manque cela décale les suivantes... Je ne suis pas claire mais avez-vous comprit et surtout que dois-je modifier ?
MERCI !

Répondre
Frédéric LE GUEN 11/08/2017 at 08:17

L'ordre alphabétique n'a rien à voir avec la formule. Ce qui est probablement la cause ce sont des caractères invisibles (genre espace) qui font que les chaînes de caractères ne soient pas identiques.

Répondre
Juliette DL 19/07/2017 at 11:09

Bonjour Frédéric,
j'ai appliqué la formule sauf qu'en résultat je n'ai que des N/A ..;
où est l'erreur ?

merci d 'avance pour votre réponse

Répondre
Frédéric LE GUEN 20/07/2017 at 06:58

Bonjour,
Avez-vous fait un test d'égalité pour savoir si le problème vient de votre formule ou de vos données ?

Répondre

Laissez un commentaire

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.

Ce site utilise des cookies pour améliorer votre expérience et vos recherches. Nous pensons que vous êtes dʼaccord sur ce principe mais vous pouvez refuser cette option. Accepter Continuer

Privacy & Cookies Policy