X
    Categories: Débutant

AUJOURDHUI et MAINTENANT

Les deux fonctions AUJOURDHUI et MAINTENANT sont des fonctions extrêmement importante. Elles permettent de créer des classeurs dynamiques en utilisant la date système de votre ordinateur.

Nous allons nous servir de ces fonctions pour créer des classeurs comme des

Présentation des fonctions

Pour afficher la date du jour, il vous suffit d'écrire les fonctions de la façon suivante
=AUJOURDHUI()

Pour afficher la date et l'heure, vous allez écrire la formule :
=MAINTENANT()

Remarques :

  • Les parenthèses sont obligatoires même si vous n'y indiquez aucun paramètre
  • La cellule intègre automatiquement le format Date.

Extraire l'heure et la date

Pour ne retourner que l'heure, vous devez réaliser une opération de déduction comme cela est expliqué dans l'article pour séparer les dates des heures.

Pourquoi utiliser une fonction ?

En effet, pourquoi utiliser une fonction alors qu'il est plus simple de saisir directement la date dans une cellule. Et encore mieux avec le raccourci-clavier CTRL+; (touche control + point-virgule)

Seulement, cette date ne changera plus 😒😞☹😡 car elle est écrite en dure.

Alors qu'en écrivant soit AUJOURDHUI ou MAINTENANT, la date évoluera jour après jour automatiquement 😍😍😍

Exemple d'application avec AUJOURDHUI

Quel est l'intérêt d'utiliser cette fonction dans un classeur ?

Cette fonction est très utile pour calculer automatiquement des écarts de dates, comme :

  • Anniversaire
  • Echéance
  • Délai de remboursement
  • Retard de facturation

Dans le classeur suivant, vous avez certains clients qui n'ont pas encore payé leur facture (la date en colonne C est vide).

Donc, dans le cas où la cellule qui contient les dates de paiement est vide, nous allons utiliser la date du jour.

Nous allons d'abord faire un test sur le fait que la date de paiement est vide ou pas

=C5=""

Si c'est le cas, alors nous allons effectuer l'opération de soustraction entre la date du jour avec la date de la commande.

=AUJOURDHUI()-B5

Nous mettons ces deux éléments dans une fonction SI
=SI(C5="";AUJOURDHUI()-B5;"")

Vous pouvez essayer de reproduire cette formule dans le classeur ci-dessous ou simplement recopier la formule déjà présente en D4.

Que se passe-t-il demain ?

Et bien, comme notre formule utilise la fonction AUJOURDHUI, la valeur du jour sera différente les jours suivants.

Et donc de fait, le résultat des jours de retard seront recalculés automatiquement 😎😍👍

 

Frédéric LE GUEN :