«

»

AUJOURDHUI et MAINTENANT

Les deux fonctions AUJOURDHUI et MAINTENANT sont des fonctions extrêmement importante car elles permettent de créer des classeurs dynamiques en utilisant la date système de votre ordinateur.

Nous allons nous servir de ces fonctions pour créer des classeurs comme :

  • des calendriers dynamiques
  • des planning hedbomadaires
  • des suivi des règlements fournisseurs
  • des retards de livraison

Présentation des fonctions

Pour afficher la date du jour, il vous suffit d’écrire les fonctions de la façon suivante
=AUJOURDHUI()

Pour afficher la date et l’heure, vous allez écrire la formule :
=MAINTENANT()

Regardez dans le classeur intégré ci-dessus, vous voyez la date du jour renvoyée par les formules AUJOURDHUI et MAINTENANT.

Remarque :

  • Les parenthèses sont obligatoires même si vous n’y indiquez aucun paramètre
  • La cellule intègre automatiquement le format Date.

Pour ne retourner que l’heure, vous devez réaliser une opération de déduction comme cela est expliqué dans l’article pour séparer les dates des heures.

Utilisation

Quel est l’intérêt d’utiliser cette fonction dans un classeur ?

Cette fonction est très utile pour calculer des écarts de dates, comme :

Dans l’exemple suivant, vous voulez voir le nombre de jours d’écart quand la colonne C ne contient pas de dates. (soit le nombre de jours passés entre la date de la commande et aujourd’hui). Ainsi, vous allez faire la soustraction entre les dates en colonne B et la date du jour en utilisant la fonction SI (ici en B1, mais il est évident que dans un exercice réel il faut la remplacer par la fonction AUJOURDHUI). La formule en D5 est alors :
=SI(C5= » »$B$1-B5, » »)




Dans le classeur intégré ci-dessous, vous pouvez visualiser la formule utilisé pour calculer le nombre de jours d’écart et vous pouvez vous en inspirer pour effectuer le calcul pour les autres cellules. Vous pouvez utiliser les différentes techniques de copier-coller pour recopier la formule.

Si vous construisez un classeur similaire sur votre ordinateur en remplaçant la cellule B1 par la formule AUJOURDHUI() et que vous rouvrez le classeur dans quelques jours, vous verrez que les valeurs de la colonne Ecart se modifieront en fonction de la date du jour.




Lien Permanent pour cet article : https://www.excel-exercice.com/aujourdhui-maintenant/

1 ping

  1. Excel sur son téléphone portable

    […] AUJOURDHUI & MAINTENANT […]

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Vous pouvez utiliser ces balises et attributs HTML : <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

Advertisment ad adsense adlogger