«

»

AUJOURDHUI et MAINTENANT

Les deux fonctions AUJOURDHUI et MAINTENANT sont des fonctions extrêmement importante car elles permettent de créer des classeurs dynamiques en utilisant la date système de votre ordinateur.

Nous allons nous servir de ces fonctions pour créer des classeurs comme des

Présentation des fonctions

Pour afficher la date du jour, il vous suffit d’écrire les fonctions de la façon suivante
=AUJOURDHUI()

Pour afficher la date et l’heure, vous allez écrire la formule :
=MAINTENANT()

Remarque :

  • Les parenthèses sont obligatoires même si vous n’y indiquez aucun paramètre
  • La cellule intègre automatiquement le format Date.

Pour ne retourner que l’heure, vous devez réaliser une opération de déduction comme cela est expliqué dans l’article pour séparer les dates des heures.



Exemple d’application



Quel est l’intérêt d’utiliser cette fonction dans un classeur ?

Cette fonction est très utile pour calculer des écarts de dates, comme :

  • Anniversaire
  • Echéance
  • Délai de remboursement
  • Retard de facturation

Dans le classeur suivant, vous avez certains clients qui n’ont pas encore payé leur facture. C’est-à-dire que la date de paiement n’est pas renseignée en colonne C.

Donc, dans le cas où la cellule qui contient les dates de paiement est vide, nous allons utiliser la date du jour qui est en B1

Nous allons d’abord faire un test sur le fait que la date de paiement est vide ou pas

=C5=””

Si c’est le cas, alors nous allons effectuer l’opération de soustraction entre la date du jour (dans la cellule B1) avec la date de la commande.

=$B$1-B5

Nous mettons ces deux éléments dans une fonction SI
=SI(C5=””;$B$1-B5;””)

Vous pouvez essayer de reproduire cette formule dans le classeur ci-dessous ou simplement recopier la formule déjà présente en D4.



Et demain ?

Du fait que notre formule utilise l’instruction AUJOURDHUI, la valeur du jour sera différente les jours suivants.

Et donc de fait, le résultat des jours de retard seront recalculés automatiquement 😎😍👍

 




Lien Permanent pour cet article : https://www.excel-exercice.com/aujourdhui-maintenant/

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *