Statistiques

Arrondir par tranche décimale

Temps de lecture 2 minutes

Cet article va vous expliquer comment arrondir vos chiffres par tranche décimale (10 centimes, 25 centimes, 50 centimes, ...)

Les fonctions d'arrondi dans Excel

Dans Excel, il existe 3 fonctions pour arrondir vos chiffres avec un certain nombre de décimales

  • ARRONDIR
  • ARRONDIR.INF (pour arrondir aux décimales inférieures)
  • ARRONDIR.SUP (pour arrondir aux décimales supérieures)

Par exemple ici, nous avons plusieurs exemple de précision d'arrondi en utilisant les données de la colonne A et la précision de la ligne 1. La formule utilise les références mixtes pour n'écrire la formule qu'une seule fois pour tout le tableau

=ARRONDI($A2;B$1)

Exemple de précision d'arrondi

Arrondir aux dizaines, centaines

Mais ces fonctions permettent également d'arrondir par tranche comme les dizaines et centaines.

Arrondir aux dizaines, centaines, milliers le plus proche

C'est en utilisant cette technique que nous allons pouvoir arrondir par tranche décimale.

Arrondir par tranche décimale

Prenons le tableau suivant qui va nous servir d'exemple de chiffre à arrondir par tranche décimale

Exemple de nombre a arrondir par tranche decimale

Arrondir par tranche supérieure de 10 centimes

Tout d'abord, il nous faut transformer nos chiffres pour ne plus avoir de décimales. Et ceci s'obtient très facilement en multipliant nos valeurs par 100.

=B2*100

Multiplier vos valeurs par 100

Ensuite, nous allons arrondir à la dizaine supérieure grâce à la formule suivante

=ARRONDI.SUP(B2*100;-1)

Arrondir a la dizaine superieure

Et bien sûr, il ne faut pas oublier de rediviser ce résultat pas 100 (le même chiffre que la multiplication initiale.

=ARRONDI.SUP(B2*100;-1)/100

Diviser le resultat par 100 pour retourner le resultat par tranche de 10 centimes

Arrondir par tranche de 25 centimes

Le principe est exactement le même mais ici on va multiplier par 40. Car 1000 / 25 = 40

=ARRONDI.SUP(B2*40;-1)/40

Arrondir par tranche decimale de 25 centimes

Arrondi par tranche de 5 centimes

Cette fois, nous allons prendre comme multiplicateur 1000 / 5 = 200

=ARRONDI.SUP(B2*200;-1)/200

Arrondir par tranche decimale de 5 centimes

Related posts

Additionner plusieurs feuilles en même temps

Frédéric LE GUEN

Créer une somme dynamique

Frédéric LE GUEN

Nouvelles fonctions de prévision

Frédéric LE GUEN

Laissez un commentaire

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.