↑ Retour à Condition

Imprimer ceci Page

Fonction SI





La fonction SI vous permet d'afficher différents résultats dans une cellule en fonction de la valeur d'une ou plusieurs autres cellules.

Fonctions liées à la fonction SI

Avant de détailler la fonction SI, je vous invite à visiter les pages suivantes. Ce sont des fonctions connexes à la fonction SI mais elles pourraient mieux répondre à votre problème.

Présentation de la fonction SI

La fonction SI effectue un test logique qui va retourner 2 valeurs (ET UNIQUEMENT 2) : VRAI ou FAUX

La fonction SI se décompose en trois parties

  • Le test
  • Le résultat si le test est vrai
  • Le résultat si le test est faux
=SI(TEST; Si test est VRAI;Si test est FAUX)

Ecriture

Si vous souhaitez afficher dans une cellule du texte, il vous faut alors écrire vos conditions vrai et fausse entre guillemets.

=SI(test;"Accepté";"Refusé")

C'est également en utilisant des guillemets que vous pouvez écrire un résultat vide. En effet si vous omettez le paramètre FAUX dans votre formule, Excel écrira le terme FAUX dans la cellule (dans le cas où le résultat de votre test est faux).

Donc pour éviter cela, il est nécessaire d'écrire "" plutôt que de laisser le paramètre vide

=SI(test;"Accepté";"")

Pour les chiffres ou pour les formules, vous écrivez vos paramètres VRAI ou FAUX sans guillemets comme par exemple

=SI(test;A1-B1;A1-C1)

Test logique

La première partie de la fonction SI est un test logique. Un test logique est une comparaison entre 2 éléments. Vous pouvez avoir comme possibilité

Cas pratique : Match de football

Prenons l'exemple suivant d'un résultat de match de football. Nous souhaitons afficher Gagné ou Perdu quand les équipes de la colonne A ont un score plus élevé que celui des équipes de la colonne D

Pour la première cellule en E2, vous écrivez alors

=SI(B2>C2;"Gagné";"Perdu")

Remplissez le reste du document directement dans le classeur ci-dessous.

Bien évidemment, un match peut être soit gagné, soit perdu, ou encore que le résultat soit sans gagnant ou sans perdant en cas d'égalité. Nous devons donc traiter non pas 2 possibilités mais 3. Dans ce cas de figure, il faut inclure une seconde fonction SI dans le paramètre FAUX de la première fonction SI. Vous allez écrire dans la cellule E2 :

=SI(B2>C2;"Gagné";SI(B2<C2;"Perdu";"Nul"))

Remplissez le document suivant

Exercice : Donnez une mention

Vous avez la liste des notes pour les élèves d'une classe. En colonne E vous avez la moyenne pour chaque élève. En colonne F, indiquez si les élèves sont reçus ou recalés quand ils ont obtenu au moins 10.

Essayez de modifier votre formule en E2 pour afficher

  • Recalé quand la moyenne est inférieur à 10
  • Accepté quand la moyenne est comprise entre 10 et 12
  • Mention Assez Bien quand la moyenne est comprise entre 12 et 14
  • Mention Bien quand la moyenne est comprise entre 14 et 16
  • Mention Très bien quand la moyenne est à plus de 16

=SI(E2<10;"Recalé";SI(E2<12;"Accepté";SI(E2<14;"Assez bien";SI(E2<16;"Bien";"Très bien"))))

Vous avez également la possibilité d'utiliser la fonction RECHERCHEV (valeur proche) pour vous éviter d'écrire autant de SI imbriqués.

Exercice : Gestion de stock

Vous gérez les stocks et les commandes d'une entreprise. Vous ne pouvez pas honorer une commande si vous n'avez pas la totalité de la quantité demandée. Donc vous allez créer une fonction SI qui va vérifier que vous possédez la quantité commandée. Si votre stock est inférieur, vous ne pouvez livrer que la quantité que vous possédez.

Vous pouvez par exemple écrire la fonction suivante :

=SI(C3<B3;C3;B3)

Pour la deuxième partie de l'exercice, vous devez déclencher une commande auprès de vos fournisseurs si vous n'avez pas pu honorer l'intégralité de la commande. Pouvez écrire la formule de façon différente pour un résultat équivalent

=SI(D4<B4;B4-D4;"")

ou encore

=SI(D4=C4;B4<D4;"")

Exercice : Portefeuille d'actions

Vous avez un portefeuille d'actions. En colonne C vous avez le prix d'achat et en colonne D le dernier cours.
Ecrivez le résultat en colonne E si vous gagnez de l'argent ou en F si vous êtes en perte. Le résultat doit aussi prendre en compte la quantité d'actions que vous possédez.
Ensuite vous calculez la somme des colonnes E et F puis en cellule E9, vous calculez la différence entre les cellules E8 et F8 pour savoir si vous êtes en gain ou en perte.

La solution est dans la feuille suivante (mais c'est mieux si vous le faites vous même 😉 )

Lien Permanent pour cet article : http://www.excel-exercice.com/fonction/condition/fonction-si/

117 Commentaires

4 pings

Passer au formulaire de commentaire

  1. Elodie J

    Bonsoir,
    J'ai une fonction SI à faire mais c'est avec des tranches ... Je m'explique. Je dois calculer des ristournes: entre 0 et 40 000€ d'achat, j'obtiens 1% de ristourne; si j'ai plus de 40 000€ j'obtiens 4% de ristourne. Cependant, si j'ai, par exemple, 60 000€ d'achat, j'ai 40 000 à 1% et 20 000 à 4% ... Comment pourrais-je le faire avec excel ? Merci d'avance !

    1. Frédéric LE GUEN

      Bonsoir,
      Il faut utiliser la fonction RECHERCHEV dans ce cas de figure. C'est ce qui a de plus simple. J'ai mis un exemple identique dans cette page
      http://www.excel-exercice.com/fonction/recherche-reference/recherchev-valeur-proche/

  2. alexandra

    Bonjour,
    J'ai besoin d'aide, j'ai tourner le problème plusieurs fois sans trouver de solution seul.
    Dans mon tableau j'ai 4 colonnes.
    A - date
    B - nombre d'heures travaillées
    C - Nombre de dossiers traités
    D - Nombre de dossiers traités par heure

    Pour chaque colonne, j'ai 2 lignes à écrire pour chaque date.
    Ligne 1 - pour le matin
    Ligne 2 - pour l'après-midi

    Ma question est de savoir quelle formule utiliser pour rechercher le nombre de dossier moyen traité pour une date et que cela m'affiche les données pour le matin ou l'après midi.
    Merci à celui qui trouve une solution de m'aider.
    cordialement

    1. Frédéric LE GUEN

      Bonjour,
      Je pense que le mieux c'est d'utiliser la fonction SOMME.SI.ENS avec comme critère la colonne des dates

  3. Anonyme

    Bonjour, j'aurais besoin de votre aide s'il vous plait. Je vais essayer de vous expliquer mon problème.
    En C17, j'ai le sexe de la personne (soit H ou F) et en C50 j'ai un total.
    Avec ces données il faut que j'arrive à faire une formule avec soit 3 fonction Si soit avec 2 fonctions Si et une fonction ET selon ceci:
    -si c'est une femme avec un total (c50) >11 ou si c'est un homme avec un total >12 alors un texte doit apparaitre sinon rien.
    Merci beaucoup pour votre aide car ça fait 3 jours que je cherche, j'ai essayé plusieurs formules et rien à faire.

  4. koboys19

    salut monsieur j'aimerai savoir si avec la condition si nous pouvons afficher le resultat dans une cellule pour continuer les calcules par exemple si b1130 on obtient c1=b1 et les calcules continus avec c1

Laisser un commentaire