↑ Retour à Condition

Imprimer ceci Page

Fonction SI

La fonction SI vous permet d’afficher différents résultats dans une cellule en fonction de la valeur d’une ou plusieurs autres cellules.

Fonctions liées à la fonction SI

Avant de détailler la fonction SI, je vous invite à visiter les pages suivantes. Ce sont des fonctions connexes à la fonction SI mais elles pourraient mieux répondre à votre problème.

Présentation de la fonction SI

La fonction SI effectue un test logique qui va retourner 2 valeurs (ET UNIQUEMENT 2) : VRAI ou FAUX

La fonction SI se décompose en trois parties

  • Le test
  • Le résultat si le test est vrai
  • Le résultat si le test est faux
=SI(TEST; Si test est VRAI;Si test est FAUX)

Ecriture

Si vous souhaitez afficher dans une cellule du texte, il vous faut alors écrire vos conditions vrai et fausse entre guillemets.

=SI(test;"Accepté";"Refusé")

C’est également en utilisant des guillemets que vous pouvez écrire un résultat vide. En effet si vous omettez le paramètre FAUX dans votre formule, Excel écrira le terme FAUX dans la cellule (dans le cas où le résultat de votre test est faux).

Donc pour éviter cela, il est nécessaire d’écrire «  » plutôt que de laisser le paramètre vide

=SI(test;"Accepté";"")

Pour les chiffres ou pour les formules, vous écrivez vos paramètres VRAI ou FAUX sans guillemets comme par exemple

=SI(test;A1-B1;A1-C1)

Test logique

La première partie de la fonction SI est un test logique. Un test logique est une comparaison entre 2 éléments. Vous pouvez avoir comme possibilité

Lien Permanent pour cet article : http://www.excel-exercice.com/fonction/condition/fonction-si/

100 Commentaires

4 pings

Passer au formulaire de commentaire

  1. Véro

    Bonjour, je reposte car la demande précédente n’était pas compréhensible ! désolée !

    Voici ma requête :
    J’ai dans une feuille excel, un tableau à 3 colonnes dont voici les en-tête :
    colonne 1 : Liste de menu déroulant de non-conformités type
    colonne 2 : Correction de non-conformité type
    colonne 3 : N° d’attribution de la NC type

    J’aurais en //, dans une autre feuille, pour chaque NC type, sa correction et son N° d’attribution
    Le tableau est vide au départ ; je voudrais sélectionner une des NC (voir ex ci-après) et avoir un affichage automatique en colonne 2 de la correction type et en colonne 3 du N° type

    exemple :
    Colonne 1 : médicament casse ou écrasé
    Colonne 2 : remplacement du médicament
    Colonne 3 : NC-13-442

    Comment paramétrer cela ?
    Merci d’avance

  2. véro

    Bonjour, voici ma demande :
    J’ai un tableau à 3 colonnes dont voici les en-tête :
    colonne 1 : Liste de menu déroulant de non-conformités type
    colonne 2 : Correction de non-conformité type
    colonne 3 : N° d’attribution de la NC type

    Le fichier est vide au départ ; je voudrais sélectionner une des NC (voir ex ci-après) et avoir un affichage automatique en colonne 2 de la correction type et du N° type

    d’un texte (que j’aurais paramétré par ailleurs) Ainsi qu’un affichage automatique d’un N° à afficher auto (que j’aurais paramétré par ailleurs)
    Colonne 1 Colonne 2 Colonne 3
    médicament casse ou écrasé remplacement du médicament NC-13-442

    Comment paramétrer cela ?
    Merci d’avance

  3. danyrgy

    bonjour,
    j’aurais besoin de votre aide pour mon tableau excel, voila j’ai dans une colonne un menu déroulant ou j’ai plusieurs critères, je voudrais que dans une autre colonne en fonction de ce que je choisi dans le menu déroulant il s’affiche un chiffre

    exemple
    la j’ai tapé ceci en F6 : =si(c6= »mo »;33; » »)
    j’aurais aimé que quand en C6 je sélectionne OM cela m’affiche 58 en colonne F comme le 33 dans ma première formule tout en gardant la 1ere formule en F6.
    par avance merci Dany

  4. itsic

    bonjour a tous, et je ne sais pas qui a eu l’idee de faire ces tutos mais bravo en tous les cas.
    alors voici mon soucis, je souhaite afficher un resultat (dans mon cas un prix) en fonction d’un chiffre dans la colonne precedente.
    par exemple si g 1 en b1, en c1 je souhaite qu’il s’affiche 40, si g 2 en b2, 70, je crois comprendre que la fonction si permets ca mais que pour deux parametres, vrai ou faux….comment fait on pour plus de parametres.

    en vous remerciant

  5. Anonyme

    bonjour, moi j’aimerais savoir si c’est possible de faire SI(heure et entre 6h et 14h alors 1 et si heure et entre 14h et 22h alors 2 ) merci d’avance

  6. THIERSON

    Bonjour à tous
    Besoin d’une formule
    SI x inférieur à 0 attribuer la note 0
    SI x compris entre a et b attribuer la note 1
    SI x supérieur à c attribuer la note 3
    Merci d’avance

    1. kara

      Bonjour la formule qu’il vous faut si(x<a;note 0;SI(xc; note3))

  7. Anonyme

    Bonjour à tous,
    J’aimerais savoir si ce que je veux faire existe dans Excel.
    J’ai les notes des étudiants en lettre.
    Je dois les transformer en résultat.
    Je voudrais une formule qui permet de faire ceci:
    Si le résultat est A+, affiche 4,3
    Si le résultat est A, affiche 4,0
    Si le résultat est A1, affiche 3,7

    Est-ce possible?
    Merci d’avance

    1. Frédéric LE GUEN

      Bonjour,
      Il suffit de faire une table de correspondance avec toutes les notes possibles et la valeur numérique qui lui correspond dans une autre colonne puis d’utiliser la fonction RECHERCHEV pour récupérer les notes pour tous les élèves

  8. Gaël

    Bonjour
    J’ai fais un tableau ou une cellule se rempli d’un code 6001 si l’on est un jour de la semaine et 6002 si il agit du week-end, pour cela j’ai utilisé SI joursem et ça fonctionne très bien.Sur un autre onglet dans le même classeur j’ai fais un autre tableau avec les jours fériés automatique. Je cherche une formule qui continue de remplir ma cellule avec 6001 si l’on est un jours en semaine , ou 6002 si l’on est le Week-end ou un des jours férié du tableau qui les références tous.
    Merci de votre aide

    1. Frédéric LE GUEN

      Sur la page d’un calendrier automatique, vous devriez trouvez les réponses à vos 2 problèmes

  9. Anonyme

    Bonjour, pouvez vous m’aider à trouver une formule acec si. A partir d’une colonne (1) comportant soit des noms soit des cellules vides je dois créer de celleci une nouvelle colonne de resultats indiquant si trouver un nom = nonsi trouver une cellule vide = oui

  10. Dominique

    Re-CORRECTION. Quand j’envoie, certains signes changent !?!
    Je vais mettre des espaces entre chaque chaîne de caractères
    =SI(A3″ »;()AUJOURD’HUI; » « )
    = SI ( A3  »  » ; () AUJOURD’HUI ;  »  » )
    En espérant que ça aille
    Merci Dom

    1. Arthur Antz

      j’avais une petite question j’ai mon CDi demain et je n’arrive pas à écrire cette formule: somme des points des deux tests + 5 points si la personne est une femme ; sinon c’est la somme des points des deux tests.
      Merci d’avance pour votre aide :)

  11. Dominique

    CORRECTION
    =SI(A3″ »;()AUJOURD’HUI; » « )
    =SI(A3″ »;()AUJOURD’HUI; » « )
    Désolé

  12. Dominique

    Bonsoir ;
    J’ai en A3 une cellule vide, en B3, une cellule vide et en C3 une cellule vide.
    J’aimerais, quand je mets un nom en A3, que la date du jour de l’écriture s’écrive et reste pour ce jour précis en B3. Si rien n’est écrit A3, la cellule B3 reste vide.
    De plus, j’aimerais aussi, que quand je tire vers le bas pour que la fonction se duplique en A4 B4, puis A5 B5, …An Bn.
    La date d’écriture doit rester celle du jour d’écriture.
    J’espère m’être fait comprendre.
    Je pensais à :
    =SI(A3″ »;()AUJOURD’HUI; » « )
    SI(écriture en A3;date du jour de l’écriture;vide).
    Merci d’avance Dom

  13. TONIOLO MARC

    Bonjour,
    J’ai besoin de votre aide sur une formule conditionnel sous Excel je vous présente rapidement le sujet j’ai trois intitulé dont le valeur finale sera soit divisé, soit multiplié par un quotient et la dernière valeur devra être obligatoirement inférieure à 22€ (les sommes inférieures à 22€ seront prises en compte mais si supérieure à 22€ elles seront alignées sur cette dernière valeur (22) .
    Voici ma formule de mon tableur dont je ne trouve pas la solution :

    =SI(B10= »Internet »;C10/2;SI(B10= »Kilometres »;C10*0,42;SI(ET(B10= »Restaurant CE »;C10<23; C10=22);C10)))

    Merci pour votre aide

    1. Abdou

      Bonjour !je pense que tu dois ecrire quelque chose dans la partie « sinon » de ton dernier SI :

      SI( ET (B10= »Restaurant CE »;C10<23; C10=22) ; C10 mettre ici : ;suivi de valeur si le ET donne faux
      )

  14. mj

    Bonjour,

    J’ai besoin de votre aide pour une formule entre deux valeurs.
    j’ai trouvé la forme SI ET mais quand je veux mettre la valeur de al cellule cela ne fonctionne pas.
    je m’explique : ma cellule B3 =10 je veux dire dans ma cellule de calcul que si la valeur B3 est entre 10 et 20 alors mettre la valeur de la cellule sinon 0!!!
    Pouvez vous m’aider?

  15. Maxence

    Bonjour, j’aimerais de l’aide pour une fonction. Je pense qu’il faut utiliser la fonction SI mais je n’arrive pas, à bien m’en sortir.

    En faite j’ai une colonne avec le nombre de semaine et sur la colonne d’après j’aimerais que toutes les 4 semaines ma case soit égale à 0. Comment puis-je m’y prendre? Cordialement

  16. Gilles

    Bonjour,
    Je veux qu’une cellule devient rouge quand je mets ‘OCCUPE’ et vert quand ‘LIBRE’, comment faire?
    Cordialement

    1. Coucou

      Hello. Tu sélectionnes l’ensemble des cellules (ligne ou colonne) à qui tu veux faire ce changement. Ensuite « format » puis « mise en forme conditionnelle »

  17. Anonyme

    Bonjour,

    Je dois faire un modèle de facture avec 3 taux de tva à calculer (code 1 pour 5,5%…….etc) mais je n’arrive pas à faire une fonction pour que le taux se calcule automatiquement. Merci

  18. Véro

    Bonjour. Pour ma part, j’aimerais utiliser la fonction SI pour cet exemple : SI le coef est 700, que une mention s’affiche. Impossible de le faire apparaître, j em’arrache les cheveux !

  19. HOUNKANRIN A. Irénée

    tres ravis de faire votre connaissance sur le cyte de la recherche, je voudrais que vous m’envoiez votre adresse complete moi c’est irene hounkanrin béninois etudiant en masteur 1 en gestion des projets et marcketing de qualité je reponds au +22998422436 et sur +22997659996 merci

  20. Olivier

    Bonjour

    Je souhaiterais que la valeur « nombre » puisse être envoyé dans un cellule et non la cellule FAUX ex:
    0:00:01 10:00:00 30,00 € FAUX
    10:00:00 20:00:00 54,00 € 54
    20:00:00 50:00:00 105,00 € FAUX
    50:00:00 100:00:00 180,00 € FAUX

    Mon tableau calcul un total d’heure « 00:00:00″ et en face je souhaiterais que le total temps apparaisse si le résultat est FAUX alors il cherche la cellule suivante, jusqu’à ce qu’il trouve une valeur « nombre »

    Merci pour votre aide

  21. pyao

    je veux ecrire une fonction recherche ou la valeur à chercher est un test

  22. BOURRICAND Bernard

    je voudrais utiliser en même temps la fonction si et la fonction EST.IMPAIR :

    SI le contenu de la cellule N+1 est un chiffre impair , je veux voir afficher N+1; sinon N+1/2

    pouvez vous m’aider ?

    D’avance merci

    1. Frédéric LE GUEN

      Il faut combiner la fonction SI avec la fonction MOD (modulo).
      J’ai rédigé un article sur le sujet dans cette page http://www.excel-exercice.com/fonction/statistiques/modulo-mod/

    2. gypsarius

      Bonjour,
      Je suis novice et bénéficier de vous lumières…
      Je souhaite faire un tableau de 4 colonnes et 9 lignes avec le résultat de plusieurs matches et collorier les équipes gagnantes en vert (mais pas le score) les équipes perdantes en rouge et les deux équipes en gris en cas de match nul, l »opération est à répéter pour 9 matches (donc 18 équipes)…
      merci pour votre aide.

  23. benmeddah mohamed

    merci bien pour les exemple

  24. dupon landry

    bonjour, j’aimerai savoir comment utiliser la fonction RECHERCHECHV pour mettre les commentaires dans une colonne Exel

  25. Elise

    Bonjour, j’ai une colonne de valeurs, mais dans cette colonne j’ai parfois des cases vides et j’aimerais que lorsqu’on applique une fonction, ces cases restent vides, comment fait-on ?
    Merci d’avance si vous pouvez m’aider

  26. Jerome

    Merci pour ces infos. dans le calcul des scores de foot il est possible que le match n’ai pas eu lieu, ou ai été reporté, comment integrer la fonction qui permette de prendre en charge la cellule uniquement si il y a un chiffre ou ne pas prendre en compte lorsque il y a un texte (AR pour reporté, X pour exempt ou P pour un match annulé par exemple). Merci d’avance

    1. Frédéric LE GUEN

      Bonjour,
      Le site n’est pas voué à répondre à tous les problèmes qu’il est possible d’avoir sur Excel mais une présentation des différentes fonctions aut travers d’exemple simple. Pour votre cas de figure, j’ai bien DES solutions mais c’est aussi à vous de chercher par vous même la solution qui vous convient le mieux

      1. Jerome

        Merci quand meme !

  27. Lemouton

    Bonjour,
    connaîtriez-vous un moyen pour remplacer le résultat de la fonction SI donc soit VRAI, soit FAUX, en chiffre du type 0 et 1 car la fonction chercher/remplacer ne le fait pas.
    Merci d’avance

    1. Frédéric LE GUEN

      Tout simple =SI(votre test;1,0)

      1. Lemouton

        Merci beaucoup

  28. rtl en direct

    I’d like to thank you for the еfforts you’ve put in writing this website.
    I really hopе to ssee the samе high-grade blog
    рoѕts from youu later on as well. In truth, yor creatіve
    writing abіlіties has inspired me tο get my very
    own website now 😉

  29. Cam21

    Je dois pour le travail faire une formule afin de connaître le nombre de mois qui séparent la date d’entrée d’un salarié de la date de fin de compteur qui est le 31/12 de chaque année.

    Cellule A1 : Date d’entrée (ex : 13/02/2013)
    Cellule A2 : Date de fin de compteur (31/12/2013)
    Cellule A3 : Observations (nombre de mois qui séparent les deux dates ci-dessus)

    Mon problème : Je ne trouve pas de fonction SI qui pourrait convenir. Les dates d’entrée n’étant pas les mêmes je ne sais pas comment m’en sortir. Cela va changer en fonction des années (bientôt 2014).

    Si vous avez une solution je suis preneuse !

    Merci d’avance

    1. Frédéric LE GUEN

      Facile, il faut utiliser la fonction DATEDIF http://www.excel-exercice.com/fonction/fonctions-dates/datedif/ et non pas la fonction SI

    2. kennortowne

      Merci je suis très content d’avoir découvert votre site!!! Courage aux initiateurs et aux concepteurs de ce dernier

  30. Cécile

    Bonjour,

    Est-il possible de créer une fonction SI qui tient compte du début d’une cellule ?
    Par exemple, si une cellule commence par « AAA » et si une cellule commence par « BBB », existe-t-il une formule permettant d’afficher une contenu différent ?

    Merci !

    1. Frédéric LE GUEN

      Oui, bien sur c’est possible et c’est même très facile.
      Il suffit d’utiliser la fonction GAUCHE pour extraire les 3 caractères de gauche de votre cellule et c’est tout :)
      http://www.excel-exercice.com/fonction/fonction-texte/gauche-droite-stxt/
      =SI(GAUCHE(cellule;3);Si VRAI;Si FAUX)

  31. Louis

    Bonjour

    Dans une fonction SI, je voudrais en cas de réponse fausse qu’excel non seulement n’écrive rien (fonction «  ») mais qu’il ne remplace pas un texte se trouvant dans la cellule.

    Est-ce possible avec cette fonction ou est-on obligé d’utiliser une macro qui me semble compliquer…

    Merci par avance.

    1. Frédéric LE GUEN

      Je ne comprends pas le problème. Si en A2 vous faîtes un test sur le contenu de A1 par exemple, vous pouvez ne rien écrire (comme vous le dîtes en utilisant «  ») mais vous ne pouvez pas du tout remplacer le texte qui se trouve la cellule A1. Le contenu de votre cellule sur lequel porte le test ne change pas avec une fonction SI

  32. Gigi

    Bonjour,

    Je souhaiterais rajouter de la couleur à mon tableau c’est un tableau Prévisionnel dont voici une des formule:

    =SI(B4>C4; »Négatif »; »Positif »).

    Je souhaiterais qu’en cas de résultat Négatif, cela s’affiche en rouge et qu’en cas de résultat Positif cela soit en vert.
    Que dois-je faire à votre avis?

    1. Frédéric LE GUEN

      Bonjour,
      C’est une mise en forme conditionnelle que vous devez utiliser. Regardez les pages qui traitent du sujet ici http://www.excel-exercice.com/mefc/presentation/

  33. francois francine

    Bjr, je dois résoudre un exercice super compliqué (dont j’ai la solution) avec une recherche V et des « si » mais je vois qu’on a changé par exemple dans la matrice la somme « 7500 » par limite 1 et la somme du dessous par limite 2, je ne vois pas du tout comment faire cela??? merci.

  34. Felix

    Bonjour,

    J’ai besoin d’aide pour créer une formule SI. Je commence à comprendre le concept, mais je ne suis pas assez bon encore et ma formule ne fonctionne pas. Je veux attribuer plusieurs condition à ma cellule. J’aimerais si il y a le nombre 1 inscrit dans ma cellule A1 un pourcentage X s’affiche dans A2, mais que si un autre chiffre y est inscrit il s’ajuste aussi.

    En résumé j’aimerais être capable de fusionné ces formules ensemble:
    =Si(A1=1; »3,5%; »0″)
    =Si(A1=2; »2,5%; »0″)
    =Si(A1=3; »2% »; »0″)
    etc.

    C’est simple, mais je suis bloqué.

    Merci énormément !!

  35. nono

    Re bonjour, je me suis trompée il faut lire (alors G1 = 0 de façon à…. ) excusez moi… et encore merci !

    en G1 j’entre manuellement un nombre
    en I 1 j’entre manuellement un autre nombre

    en M1 je dois obtenir ceci :
    = (G1 – 28,29 qui est un nombre fixe qui ne changera qu’une fois/an, mais si G1 est inférieur à 28,29 alors G1 – 0 de façon à ne jamais être en dessous de 0 ) + I1

  36. nono

    Bonjour Mr LE GUEN Pourriez vous m’aider s’il vous plait ?

    J’ai besoin d’entrer une formule qui donnerait le résultat suivant :

    en G1 j’entre manuellement un nombre
    en I 1 j’entre manuellement un autre nombre

    en M1 je dois obtenir ceci :
    = (G1 – 28,29 qui est un nombre fixe qui ne changera qu’une fois/an, mais si G1 est inférieur à 28,29 alors G1 – 0 de façon à ne jamais être en dessous de 0 ) + I1

    Merci beaucoup si vous pouvez m’aider. Bel été à vous.

  37. guillaume

    bonjour Mr LE GUEN

    j’aimerais avoir vos lumières pour une des nombreuses difficultés que je rencontre,
    si le montant est supérieur à 210 € il y a une remise de 15% et idem pour un montant supérieur à 410 € remise de 20%, sinon rien.
    j’ai fais un petit tableau à coté du tableau principal avec les montants et les pourcentages
    B C

    TARIFS POURCENTAGE =si(E27>B35;C35; »0″)
    35 >210 € 15% E27 étant le total avant remise
    36 >420 € 20%

  38. Christian

    J’ai un tableau contenant des distances (x) en fonction des puissances (y).
    Sur de nouvelles colonnes (c) et (d), j’ai fait une distribution du nombre de puissances et de la distance car j’ai plusieurs distances de même valeur ayant des puissances différentes.
    Je souhaiterais lier les résultats de mes distributions dans une nouvelle colonne en fonction de la puissance.
    Je vous remercie.

  39. Riahi

    SVP j’ai besoin d’aide
    je veut faire un tableau qui contient des colonnes numérote du 1 au 356 et je veux un formule pour planifier automatiquement des action qui se répété à mon choix par jour ou par semaine ou par mois

  40. DEGRAND

    bonjour, je dois faire un dossier pour l’école et je suis sur un dossier ou je dois effectuée des tableaux automatique, mes tableaux portent sur les stocks et je rencontres quelques difficultés. pourriez vous m’aidez?

  41. Aimé SADO

    Bonsoir
    s’il vous plait j’ai un problème avec cette formule
    J’ai nommé les cellules correspondants à Class, IP et VBS
    Et replissant les conditions fixées dans la formule je parvient pas a obtenir A2 comme attendu.
    Pouvez vous m’aider?

    =SI(ET(Class= »A »,OU(12%<IP<=25%,2.5<VBS<=6)),"A2",)

    1. Jul974

      ATTENTION : dans cette question et cette réponse (canadien ?), les nombres ont des POINTS, et les arguments sont déparés par des VIRGULES (et non des virgules et points virgules)

      =SI(ET(Class= »A »,OU(et(12%<IP,ip<=25%);et(2.5<VBS,VBS<=6))),A2)

      On ne peut pas mettre de conditions avec plus de 2 arguments
      Exemple : 3<X<4 : pas possible. Il faut transformer en et(3<X,x<4)

      1. nelisa2669

        Pile ce que je cherchais, pas mal de temps que je galérais sur des conditions imbriquées avec des comparaisons…Je ne me souvenais plus que l’on ne pouvais pas mettre si(10<x<15)…
        Merci

  42. eva notty

    Super article, bravo !

  43. kouame

    bonjour aidé moi à paramétré cette fonction:
    si le montant de la cellule est comprise entre
    0-5000 = 0f
    5001-100000f= 100f
    100001-500000= 500f
    500001-1000000=1000f
    1000001-5000000=2000f
    au delà de 5000000=5000f

  44. haya

    Bonjour
    je ne parviens pas à trouver la fourmule qui me donne la date de début de mois si dans un cellule j’ai une date indiqué.
    exemple cellule A1 = 18/03/2013
    je souhaiterais qu’avec une formule soit undiqué en B2 le 01/03/2013, puisque 1er jour du mois.

    aussi de même pour le dernier jour

    merci de votre aide

    h

    1. Jul974

      =DATE(ANNEE(A1);MOIS(A1);1)

    2. Jul974

      =DATE(ANNEE(A1);MOIS(A1)+1;1)-1

      C’est pour le dernier mois.

  45. gladys

    bonjour

    Je n arrive pas a trouver la formule exacte pour ce problème. Pourriez vous m’aider
    je dois classer par categories des tranches differentes ex: moins de 3000 cat 1, de 3000 a 4000 cat 2, de 4000 a 6000 cat 3 etc …

    merci d avance de votre aide

    1. zohir

      =SI(B1<3000;"cat1";SI(B1<=4000;"cat2";SI(B1<=6000;"CAT3";"")))

  46. Christiane

    Bonjour Monsieur Leguen, dans la colonne D apparait 47 heures et 20 minutes ; est-il possible de transformer en colonne E 47h20mn en centièmes d’heures ?

    A B C D E F G vide H I vide J K Lvide M

    2012 semaine 35 47,20 12,20 8,00 4,20 126,87 79,97

    puis, je n’arrive pas à extraire en colonne H le nbre d’heures comprises en colonne F qui doit être entre supérieur ou égale à 0 mais inférieure ou égale à 8, en sachant qu’en colonne F j’ai appliqué =SI(D10<=35;0;D10-35) et en colonne J j'ai appliqué
    =SI(D10<=43;0;D10-43). Pourriez-vous m'aider, en vous remerciant vivement, Sincèrement, Christiane

  47. lucie

    sur excel j’aimerais utiliser une fonction si
    si A1 est inférieur à B1 alors affiché A1
    mais je n’y arrive pas.
    Pouvez vous m’aider ?
    merci d’avance

  48. Estelle

    Bonjour,

    j’aimerais utiliser une formule « si » seulement je voudrais figer la valeur par la suite.
    Exemple si (B1=C1;A1; » »), la case A1 contient une formule et je voudrais avoir la valeur. Par la suite, si le contenu de A1 change, j’aimerais que la valeur obtenue précédemment ne change pas.

    Merci

  49. her

    suis-je claire ?
    Pouvez vous m’aider svp

  50. her

    Bonjour,

    J’ai besoin d’aide : en feuille 2 j’ai une liste de déroulante en b1 car en A1 j’ai un code qui s’y référe.

    Sur ma feuille excel lorque le salarié va chercher un motif dan la liste de déroulante, je voudrai que dans la colonne juste avant le code qui s’y référe vienne automatiquement. MAis je ne trouve pas la formule.
    Suis-je cl

  51. Laurence

    Bonjour
    j’ai un souci pour faire un calcul d’heures supplémentaires

    C10 = heure deb matin
    C11 = heure fin matin
    C13 = heure deb après midi
    C14 = heure fin après midi

    si la personne fait des interventions entre 6 et 9 le matin alors je passe en heure supplémentaire à 25 %
    si la personne fait des interventions avant 21 heures je passe en heure supplementaire à 25%

    =IF(AND(C10>=6;6;C10<9;C13<21);(9-C10)+(21-C13);(21-C13))

    la fonction fonctionne très bien si les case des heures sont remplies, par contre si au moins ma cellule C13 est vide , je recupère la valeur 21…. logique puisque je demande (21-C13)
    j'ai essayé d'insérer une condition supplémentaire qui me dirait si Cellule vide ALORS rien
    mais rien ne fonctionne correctement

    auriez vous une piste à me conseiller,

    Merci
    Laurence

  52. Armel De quesnay

    Bonjour

    J’ai besoin d’aide, j’essaye d’utiliser la fonction imbriquée SI mais ça ne marche pas.

    =SI(C32=0; »tu n’as pas encore fais de cb »;SI(0<C32<=5;"bravo garde cette allure";SI(5<=C32<10;"quel talent";SI(10<=C32=15; »tu es le meilleur »)))))

    1. Frédéric LE GUEN

      C’est normal que ça ne fonctionne pas. Vous ne pouvez pas mettre la référence d’une cellule entre 2 valeurs. Au mieux il faut écrire ET(C32>0;C32<5). Mais tel que vous écrivez votre problème, il faut plutot utiliser la fonction RECHERCHEV en valeur approchante http://www.excel-exercice.com/fonction/recherche-reference/recherchev-parametre-1/

  53. Cate

    Bonjour,

    Je cherche un à faire un tableau avec trois codes TVA différentes mais en mettant les Code1, Code2, Code3.
    Je ne me souviens plus comment j’avais fait !
    Ce serait pour faire plusieurs factures différentes (genre devis) qui me feraient gagner du temps !

    Merci de me faire « retrouver la mémoire » et merci pour tous vos tutoriaux et vidéos !

    Cate

  54. greg

    Bonjour,

    Je souhaiterais savoir s’il est possible d’utiliser une fonction SI dans le cas suivant :

    Si ma valeur est vrai, je souhaite que ma case de résultat indique un chiffre (exemple SI(D19= »oui »;18; » »)

    Mais si ma valeur est fausse, je souhaite que l’utilisateur puisse indiquer le chiffre qu’il souhaite, sans effacer la formule ci dessus.

    Cela est-il possible?

    Merci d’avance

  55. Géraldine974

    Bonjour,

    Je souhaiterais écrire comme formule : si la cellule H9 contient oui alors le résultat est égal à 7 sinon 0

    Merci d’avance.

    1. greg

      SI(H9= »oui »;7;0)

      Normalement, ça marche!

      1. Géraldine974

        Merci beaucoup ça marche!

  56. sophie

    Bonjour,
    Dans cette formule :=SI(J4=0;SI(Q4=0;H4; » »)) qu’est ce qu’il cloche pour que la case m’annonce FAUX.
    Il y a une troisième condition que je n’arrive pas à intégrer (si(J4=H4; » »)
    Avez vous une idée, je vous remercie beaucoup.
    Sophie

    1. Frédéric LE GUEN

      Il faut mettre le deuxième SI dans le paramètre FAUX de votre première fonction SI (comme dans l’exemple donné avec les résultats de football). N’hésitez pas à changer les valeurs dans les documents pour voir le résultat retourné se modifier

  57. Epifanny

    Bonjour,

    j’ai besoin d’aide, je recherche une formule SI pour des calcul de note.
    Cas 1 : note d’examen > note contrôle continu « note d’examen »
    Cas 2 : note d’examen < note contrôle continu "moyenne des deux notes (examen et contrôle continu)"

    Je ne sais pas comment inclure un calcul de moyenne dans une formule SI …

    1. Frédéric LE GUEN

      Mettez simplement =SI(Note d’examen < MOYENNE(plage de cellules des notes);VRAI;FAUX)

  58. Charlotte

    Bonsoir,
    Dans la colonne D, j’ai des emails (tout les champs ne sont pas remplis car certaines personnes n’ont pas donnés leur email, et on me demande dans la colonne H de renseigner si il y a une adresse email ou non, donc je dois avec soit oui soit non, c’est une valeur SI ? Mais je ne vois pas comment je fait…

    1. Frédéric LE GUEN

      Simple
      =Si(SUPPRESPACE(Dx)= » »; »Pas de mail »;Dx) remplacer x par le numéro de ligne

  59. puech

    bonjour,

    je souhaite écrire une formule pour un calcul de tva.
    Si la tva collectée – tva déductible >0 alors écrire dans la colonne tva à payer le montant
    jusqu’à là pas de problème par contre lorsque le montant obtenu < 0 il faudrait que la formule me renvoi le montant du crédit dans la colonne crédit et me mette 0 dans la tva à payer.
    Est ce possible de faire un renvoi sur une autre cellule ?

    Merci d'avance
    Mme puech

    1. Frédéric LE GUEN

      Bonjour,
      Il faut faire 2 formules SI dans chacune de vos colonnes.
      La première =SI(collectée-déductible>=0;collectée-déductible; » »)
      La seconde =SI(collectée-déductible<0;déductible-collectée; » »)

  60. Gil Sand

    Beaux et bons exercices, joliment expliqués :)

  61. Julien

    Bonjour,
    est il possible de laisser une cellule vide si la condition n’est pas remplit ?

    1. Gil Sand

      Oui, dans la condition désirée (dans ton cas donc, quand le test est faux), il suffit d’entrer «  » (deux fois des guillemets). Ainsi, Excel comprend qu’il doit écrire ce qu’il y a entre les guillemets, c’est-à-dire rien.

      =SI(A1>B1; »VRAI »; » ») Ici, cette formule écrira VRAI si A1 est plus grand que B1, et n’écrira rien si le résultat est plus petit ou égal.

    2. Frédéric LE GUEN

      Bonjour
      Oui, il suffit pour cela d’inscrire «  » (2 guillemets) dans la partie Faux de la fonction

  62. Coum

    Bonjour,

    Je cherche en ayant la réponse « vrai » ou « faux » dans une seule cellule
    vrai <= 2% sinon faux
    seulement je veux avoir ce résultat pour une suite de valeur
    ex: E1 = 1,2% E2= 1,6% E3= 2,5%
    vu que E3 est supérieur à 2% je voudrais que le résultat affiché soit faux malgré que seul une valeur dépasse
    j'ai rentré la fonction suivante
    =SI((E1<=2%;E2<=2%;E3<=2%;E4<=2%;E5<=2%;E6<=2%);"vrai";"faux")
    mais cela ne marche pas
    Pouvez-vous m'aider?

    Merci

    1. Frédéric LE GUEN

      Et en mettant des fonctions ET ou OU dans vos formules, ça ne solutionne pas le problème ?

  63. bongo

    il est bon ce sites

  64. jean louis

    Bonjour,

    j’ai besoin d’aide, je recherche une formule pour :

    établir des prix de vente en fonction du poids saisi

    ex:
    de 0 à 500 gr = 3.60 €
    de 501 à 1000 gr =4.10 €
    de 1001 à 2000 gr = 4.72 €
    etc…..

    1. Frédéric LE GUEN

      Bonjour,
      Quand vous avez une recherche par tranche comme vous souhaitez le faire, il faut utiliser la fonction RECHERCHEV http://www.excel-exercice.com/fonction/recherche-reference/recherchev-parametre-1/

  65. OUASSIM

    Bonjour;
    SVP j’ai besoin de votre aide a propos d’une application conditionnels :
    exemple: 1-si la cellule E1= confirmée, je veux que toutes les cellules A1, B1, C1, D1, deviennent tous rouge
    2- si la celleule E1=annullee, je veux que toutes les celleules A1, B1, C1, D1, deviennent tous bleu
    merci pour vous

    1. Frédéric LE GUEN

      Il faut utiliser les mises en forme conditionnelle pour cela.
      Je vous invite à voi mon dernier article sur les mises en forme conditionnelles sur les dates

      1. Jb

        Salut les amis! merci beaucoup pour ce que vous fait pour nous éclairé dans ce domaine.
        J’ai une petite préoccupation : comment faire pour masquer les formules sur Excel.

  1. Difference entre XLS et XLSX (ou XLSM)

    […] Fonction SI […]

  2. Créer un graphique en cascade - Excel Exercice

    […] Fonction SI […]

Laisser un commentaire